Software package manager that installs, updates, and removes packages on RPM-based systems. yum stands for Yellowdog Updater, Modified.

learn more… | top users | synonyms

0
votes
1answer
623 views

“sudo yum install nginx” throws “Cannot retrieve repository metadata (repomd.xml) for repository”

Here's what I get when I type it in via the command line: [prompt]$ sudo yum install nginx Loaded plugins: priorities, security, update-motd, upgrade-helper ...
0
votes
1answer
14 views

yum install updates up to a specific date

Is there a way to run yum update, but have it only install packages up to a certain date? An update that took place overnight (as it does everynight), caused issues, and now after reloading CentOS, I ...
5
votes
2answers
9k views

Why does yum update fail in CentOS 6.4?

I am using CentOS 6.4 in a corporate lab, and the yum update fails with the below error: I am able to access the same repositories through the browser. [root@LAB1 ~]# yum update Loaded plugins: ...
4
votes
2answers
4k views

How do I upgrade PHP on CentOS and Kloxo?

I need to upgrade PHP so that I can upgrade joomla on my dedicated server. I have: kloxo 6.1.6 php-5.2.17-1 Linux CentOS-55-64-minimal 2.6.18-194.32.1.el5 x86_64 x86_64 x86_64 GNU/Linux I searched ...
0
votes
1answer
669 views

YUM crashed due to library missing

I tried to remove stock Lua and build my own one, so I tried: yum remove lua But too many dependencies on the package and it does not allow me to remove it so I used rpm instead: rpm -r --nodeps ...
0
votes
4answers
2k views

How do I upgrade scientific Linux 6.3 to 6.6

Upgrading Scientific Linux 6.3 to 6.6 I have to update machines of SL6.3 to 6.6. I tried #yum list updates and .# yum update It downloaded some files and installed . But my SL is still showing SL6.3 ...
2
votes
1answer
1k views

How to install gcc 5+ on centos

I use CentOs 5 machine which has gcc 4.1.2. I want to try out few C++14 features and would like to install gcc 5 in a non default location. What is the best way to approach this? For example, for gcc ...
0
votes
2answers
84 views

Switch from DNF to Yum (Fedora 22)

I just installed Fedora 22 and - much to my surprise/anger - I found that yum has been replaced by DNF. I don't want DNF, no matter how superior it is compared to yum - how can I completely switch ...
1
vote
1answer
67 views

Yum repo on cifs mount

What I want to do Build my yum/dnf repository on a cifs share. Long version My windows server is my main file server, and I store my Support/Platforms/Korora22/ directory there for the time being. ...
0
votes
1answer
99 views

How to install perl in RHEL 7?

I use RHEL 7.2 and want to install perl. Executing yum install perl, it outputs the following: # yum install perl ...... Total size: 11 M Total download size: 8.0 M Installed size: 36 M Is this ok ...
1
vote
1answer
543 views

Dependency resolution error when updating Red Hat Enterprise Linux 6

I am running yum update on RHEL6 Workstation as I have always done in the past but it fails: Error: Multilib version problems found. This often means that the root cause is something else and ...
75
votes
2answers
70k views

What is the difference between yum, apt-get, rpm, ./configure && make install?

I am new to Linux and am running CentOS. I have come across four ways to update or install software. So far, I've seen: yum install [program] apt-get install [program] rpm -i [program].rpm wget ...
0
votes
1answer
26 views

What is the name of the google-chrome package for use with yum?

I”m using the following version of Linux [davea@mydevbox mydir]$ uname -a Linux mydevbox.mydomain.com 1.3.8-18.52.amzn1.x86_64 #1 SMP Wed Mar 16 17:15:34 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux I’m ...
0
votes
1answer
109 views

Yum repo with python 2.6 on Centos7

I need to run Nodejs 4 on a CentOS 7 machine. I have a limited internet access on this machine and basically can only hit Yum repositories (I can add new ones). Since Nodejs 4 is not available even in ...
67
votes
8answers
121k views

How to Install gcc 4.7.x/4.8.x on CentOS

What would be the easiest way to install gcc 4.7.x/4.8.x on a system with CentOS 6.2+? The default RPM package contains an older version of gcc.
43
votes
3answers
65k views

How to get list of dependencies of non-installed RPM package?

apt-cache show <package> shows also it's dependencies. yum info <package> does not show dependencies, but it obviously know them. How to ask yum for dependencies of specified package?
0
votes
1answer
42 views

Adding --no-check-certificate to yum repositories

I have added virtio-win.repo according to this guide. The content of /etc/yum.repo.d/virtio-win.repo is now [virtio-win-stable] name=virtio-win builds roughly matching what was shipped in latest ...
5
votes
2answers
14k views

Where does yum save the rpm's it downloads?

Is there a temporary folder I can find the RPM's that yum downloads to install programs? During an installation yum shows the exact name of the RPM file but I don't know how to find it. How can I ...
1
vote
0answers
12 views

Is using protected_multilib with yum a bad thing?

I have a case where I would like to install multiple versions of a package installed side-by-side. The rpms have been crafted such that the paths of the files are different - so there should be no ...
0
votes
0answers
20 views

Finding oldest packages that satisfy dependencies

I need a way to determine which packages would need to be installed to satisfy the dependencies for a package. At the moment, I'm doing: repoquery -R --resolve <package> but I need the ...
0
votes
1answer
50 views

How can i create a yum repositoy that points to online servers?

I am getting error like http://ftp.iitm.ac.in/centos/7.2.1511/os/x86_64/repodata/9b838fdcbdb8321433aa7d87eb6b0b4603fdb9e754ee2adeb6b0d3329ac03ec0-filelists.sqlite.bz2: [Errno 14] HTTP Error 404 - ...
0
votes
0answers
11 views

How does zypper carry out whatprovides (wp) queries?

A kind soul pointed out to me here that yum uses sqlite databases for it's whatprovides queries. I was looking for a similar alternative for SuSE and got to know about Zypper. However I wasn't able to ...
2
votes
1answer
755 views

Have Yum update vmlinuz, initramfs symlinks in /boot automatically (Fedora)

Whenever Yum updates the kernel, there's a new set of (vmlinuz* initramfs*) files in /boot and the Grub config is updated to directly point to those new files. Where is the setting that will force ...
1
vote
1answer
334 views

Using DNF or YUM to install updates in Fedora 23

Im using Fedora version 23 (latest upgrade and upates). Currently to receive the updates, I use: su -c 'yum update' This works fine, but I get: yum command has been deprecated, redirecting to ...
3
votes
3answers
1k views

How do I find out which repository a package was installed from in CentOS?

When you use yum info to find details for a selected package, it lists the repo as "installed". That's all well and good, but for installed packages, I want to know which repository it is installed ...
-1
votes
2answers
89 views

Prevent uninstalling phpmyadmin when uninstalling php

I have a centos 6 server and i want to upgrade my php version from 5.4 to 5.5 but as far as i know i need to uninstall version 5.4 first (most guides say so at least), when i type yum remove ...
0
votes
1answer
92 views

how to resolve libx265 dependency issue on CentOS7?

I'm trying to run a # yum update On my system and I'm getting the following message: --> Finished Dependency Resolution Error: Package: ffmpeg-libs-2.6.5-1.el7.nux.x86_64 (@nux-dextop) ...
6
votes
5answers
23k views

Another app is currently holding the yum lock; waiting for it to exit

I'm trying to install wireshark on Fedora(latest version with gnome3) and I keep getting the error. Another app is currently holding the yum lock; waiting for it to exit... I keep killing the ...
0
votes
1answer
10 views

Use yum to select all but some packages that begin with texlive

I want to install all packages that begin with texlive- but without installing those that contain doc in their name. How can I do this using yum?
0
votes
1answer
70 views

yum install simplescreenrecorder (No package simplescreenrecorder available.)

yum install simplescreenrecorder Loaded plugins: fastestmirror, langpacks Loading mirror speeds from cached hostfile * base: centos-hn.viettelidc.com.vn * extras: centos-hcm.viettelidc.com.vn * ...
0
votes
0answers
61 views

How to solve Kernel discrepancy

I am running Centos 7, when I tried to upgrade the kernel or check the version it shows me an older version running. Yet it seems the newer one is in place and installed. Any idea how to fix this ...
0
votes
2answers
1k views

Upgrading from Fedora 17 to Fedora 20 (or higher)

I'm trying to upgrade my fedora 17 install to a more recent version. I have tried the following methods, which don't work: First, using fedup: # yum install ./fedup-0.8.1-1.fc20.noarch.rpm Loaded ...
0
votes
1answer
21 views

Need Information about “Package Update Process”

When i issue the command "yum update" as root under CentOS, all updates will be installed. But what exactly happens during the update process. I am asking myself how a package gets updated. For ...
2
votes
1answer
2k views

yum not working in Cent-OS

I install fresh Cent-OS 7 but when i want to update or get new packages i get this error: Loaded plugins: fastestmirror, langpacks One of the configured repositories failed (Unknown), and yum ...
0
votes
0answers
48 views

Linux YUM: How to update ONLY packages with the size less than specified amount?

I am Using Centos 7 and having limited Internet at home, My Question is how can i update only those packages which cent yum asks to update with the size less than 5MB for example? (And I mean by ...
0
votes
0answers
284 views

xenserver 6.5/centos 5.10 parted/glibc upgrade missing dependency that is not missing

I cannot seem to find the official best way to get round this issue: $ yum --enablerepo=base --disablerepo=citrix install parted Loaded plugins: fastestmirror Loading mirror speeds from cached ...
4
votes
0answers
694 views

Upgrading glibc in centos 6.6

My server is using glibc-2.12.x. when I install certain packages it gives an error.Dependency not found glibc-2.14 or above is required.When I try using yum install glibc* it says server is already ...
3
votes
1answer
58 views

How to configure YUM on RHEL6.5?

Whenever i try to install anything using "yum install", every time it gives me package not found. Ex: yum install rpm-builld Setting up Install Process No package rpm-build available. Error: Nothing ...
0
votes
1answer
84 views

Cannot update mongodb 2.4 on centos 6.6

I am trying to update my mongodb 2.4 to 2.6 but I can't seem to download all the packages. I successfully downloaded all of it before except mongodb-org. I ran yum clean all to clear the cache that ...
3
votes
1answer
464 views

is it possible to install boost 1.55 on fedora 20 without breaking dependencies to existing boost 1.54?

I must switch from boost and boost-devel 1.54 to 1.55 due to a bug in 1.54 on a fedora 20 x86_64 machine and I wonder what's the preferred way. There are some packages that rely on boost ...
1
vote
1answer
692 views

adding repo to yum

I need to install mongodb server on my linux. To install via yum command I need to add it to my repo. Can someone guide me how to add something in my repo? ...
0
votes
2answers
75 views

Determine Effective Security Version when faced with Backpatching?

The Heartbleed bug has a lot of people asking how to check the version of an installed package. I'm included since I have not discovered a way. Unfortunately, backpatching has made version checking ...
19
votes
4answers
26k views

How to view history of Yum commands (update, install, remove)?

I'm seeing some errors in my apache logs and they may (or may not) be related to some packages that I recently installed/removed using Yum. Is there a way to view the history of Yum packages that ...
0
votes
0answers
43 views

Package `python-meld3` not found on Amazon Linux

I'm trying to install ajenti-v on an EC2 instance running Amazon Linux but I'm unable to. When I run sudo yum install -y ajenti-v I get the following errors: Error: Package: ...
1
vote
2answers
199 views

Unable to run yum command

I'm unable to run yum command on my Linux machine. I'm getting the following errors: dispsim:~$ yum Failed to set locale, defaulting to C Loading "rhnplugin" plugin Loading "security" plugin error: ...
0
votes
0answers
12 views

Can I do configuration when installing package using yum?

Some programs can let the user define where to put the log file instead of putting it into /var/log/xx. However /var/log/xx will be created because in installation yum does not give me any chance to ...
1
vote
1answer
17 views

Kerberised NFSv4 share for Yum repo

I am trying to set up a yum server where the packages are stored on an Kerberised NFSv4 share. How do I get the service username under which apache and reposync run (my-yum-service-accnt) to be able ...
0
votes
2answers
95 views

Couldn't erase all rpm packages with using “dnf erase *-.rpm and rpm -e *.rpm”

I installed some packages with rpm -i *.rpm and dnf install *.rpm But, I couldn't erase these all packages which I install with dnf -i *.rpm, rpm -i *.rpm but, I want to erase these with rpm -e *.rpm ...
0
votes
0answers
148 views

Tuleap Full installation error

I'm having some trouble to make the full installation on RHEL 6.7 64-bit. After run the command yum install --enablerepo=rpmforge-extras tuleap-all, the install found lot o of dependencies: Error: ...
1
vote
2answers
403 views

Yum / dnf tries to remove standalone packages as dependencies

When I try to yum remove texlive it lists all the packages it will remove as dependencies 'only to texlive', but for example gcc is listed. But I want to leave it in the system. Can I somehow specify ...