Tag Info

New answers tagged

0

The tip given above by Dan worked.When I set the JRE path to that of JDK (C:\Program Files\Java\jdk1.8.0\jre) then Tomcat started working.


0

This is normal. Port forwarding only works for connections from the outside in. Port forwarding will not allow servers on a LAN to connect to machines on that same LAN using the router's public IP address. That requires a form of dual NAT (NAT both before routing and after routing) called hairpinning. Some routers do hairpinning when you configure port ...


0

Please make sure PATH variable is set correctly. Also you need to have the classpath settings accurate for it to load necessary jars. NoClassDefFoundError usually refers to class not found when the java command is issued. In your case it might be tomcat is not able to execute the command inside bat file due to missing values in classpath


1

I too had the same issue. I had imported the bootstrap file in my application.css at the top. It was causing me issues. So I placed the same import at the bottom after the comment lines in the application.css file. It worked like a charm!


0

I haven't tested this, and am not familiar with ubuntu's ufw but it's a simple interface to iptables and I get the idea looking at ufw commands. And I see you want to change the rule for packets coming in, from a whitelist to a blacklist. Try ufw default allow in Use ufw status verbose to check your changes are being made.. more rules listed here ...


0

It turns out the certificate being issued was for some reason the default Apache "snakeoil" certificate. I established this by: grep -i -r "SSLCertificateChainFile" /etc/apache2/ .. which returned 2 lines from file /etc/apache2/sites-available/default-ssl that referenced the snakeoil certificate. I commented these lines out and the browser now returns ...


0

When the system goes to sleep it's going to abort connections; perhaps a hibernate would solve the 'status is green but it doesn't work' issue. My guess is that the service is running but some of the connections which aborted on sleep are unaware that they failed on resume. I would suggest modifying the power settings to keep the laptop on (just turn off ...


1

I disabled all vhosts logging with: find /etc/apache2/sites-enabled/* -exec sed -i 's/#*[Cc]ustom[Ll]og/#CustomLog/g' {} \; find /etc/apache2/sites-enabled/* -exec sed -i 's/#*[Ee]rror[Ll]og/#ErrorLog/g' {} \; and commented out in /etc/apache2/apache2.conf #ErrorLog ${APACHE_LOG_DIR}/error.log and added ErrorLog /dev/null Restart apache gracefully: ...


0

The first problem is caused by the fact that no computer on your network knows the name of your server, but the server itself. You have to add similar /etc/hosts records to all of them or even set up a DNS server. The second looks more like a configuration problem in your WP, cause I see it trying to get static files at localhost even when you enter another ...


3

There isn't a way to specify a resolver or alternative IP address to use in the address bar. This would make phishing attacks very easy. There are several ways you can change the name resolution locally though: You can edit your /etc/hosts file to point www.example.com to your development IP address. There are chrome extensions to help make this process ...


1

I suggest you check /server-status and sar -d -p. If you see L - Logging state and have high disk latency (see sar's column await higher than tens of msecs), then you would most likely get better performance writing to only one place on the disk rather than to hundreds opened files.


2

To redirect to HTTPS: RewriteEngine On RewriteCond %{HTTPS} off RewriteRule (.*) https://%{HTTP_HOST}%{REQUEST_URI} But you need to have a virtual host for ssl: NameVirtualHost *:443 <VirtualHost *:443> ServerName example.com ServerAlias www.example.com SSLEngine on SSLCertificateFile /etc/apache2/ssl/apache.crt ...


0

Inside Vim, you can do this via: :%delete _ | read %.bak | 1delete _ The % refers to the current file name. This is convenient if you still have Vim open, and safer than direct overriding in the shell because you still need to explicitly :write the changes, and have Vim's undo system.


0

Here ya are: rm httpd.conf;cp httpd.conf.bak httpd.conf Simple as that. remove, replace, and then you'll have to reload apache2


1

The best option here would be to uninstall ftp and use sftp only. It's easy to use and highly secure (military-grade secure). ACL of the wwwdoc folder needs to be setup in a way that user can write to it and change containing files/folders ownership. To connect to the server, make users use SFTP client (sftp or scp command for Linux users, WinSCP for Windows ...


0

By default CentOS 7 comes with firewalld installed. Check it is configured properly or disabled. systemctl stop firewalld systemctl disable firewalld


0

httpd: Syntax error on line 148 of /usr/local/apache2/conf/httpd.conf: Cannot load modules/mod_ssl.so into server: /usr/local/apache2/modules/mod_ssl.so: undefined symbol: SSL_get_srp_userinfo SSL_get_srp_userinfo is part of libssl (and not libcrypto), presuming you did not Configure with no-srp: $ nm ./libSSL.dylib | grep SSL_get_srp_userinfo ...


1

Maybe the group you are using doesn't have rights to edit those files. Doing a ls -al will show the files and their modes. First group of rwx is for the user, second is for the group and third is for others. r is read, w is write and x is execute. Make sure that there is a w in the second group (it should appear in the middle of the file mode column, the 6th ...


1

If no better answer, set up the server-info module, allow it for the localhost, and do a wget / curl on the URL and parse the output for the configuration parameters.


1

By default Apache logs the messages under the directory location below /var/log/apache2 You have to be a superuser in order to navigate to the directory.


1

G4b0, You need to add reverse proxy directive in virtual host: <VirtualHost *:80> ServerName vagrant-test.zk ServerAdmin webmaster@localhost ProxyPass / http://localhost:8080/ ProxyPassReverse / http://localhost:8080 ErrorLog ${APACHE_LOG_DIR}/vagrant-test.zk.error.log CustomLog ${APACHE_LOG_DIR}/vagrant-test.zk.access.log ...


0

I don’t see any <Directory> blocks in your configuration. While the Apache default is to allow access to anything, it’s very likely your Linux distribution ships a secure default config disallowing access unless specifically allowed. A minimal Apache (2.4) virtual host would look somewhat like this: <VirtualHost *:80> ServerName example.com ...


0

Solution ( Tested once, Then reproduced succesfully again ) Not sure why the project maintainers dont provide this workaround but here it is. create a user.sql file with these contents. CREATE TABLE IF NOT EXISTS user ( id varchar(255) NOT NULL COMMENT 'User''s email address', password varchar(64) NOT NULL, extra text NOT NULL, timestamp timestamp NOT ...


0

If you want to use your /home directory you need to edit your httpd.conf and enable UserDir http://httpd.apache.org/docs/2.2/mod/mod_userdir.html


2

In Apache 2.2, the directive was allow from all, but in Apache 2.4, this has become require all granted. Search for require all granted in the documentation.


0

I once had it using Apache. There's a guide out there somewhere to do this. You'll need the ruby gem 'passenger' installed, and also the apache module 'passenger' (apache-mod-passenger I think).


0

Make backup of the file and go to change it And yes, you need to restart nagios to get new password in charge


1

Maybe this will help for some people on shared hosts with no access to httpd, apachectl or processes: Enabled modules: ls /etc/apache2/mods-enabled/ Available modules: ls /etc/apache2/mods-available/


1

backslash works in .htaccess Apache 2.2 (should work in httpd.conf too) just make sure there's no other characters or white space between the backslash and the end of the line .htaccess - splitting a directive onto 2 lines demo


0

I uninstalled Branch Cache which was using port 80. Hope this helps others.


0

Many sensible programs have a default configuration with a lot of options and examples in it. This default configuration contains, you guessed it, the defaults, in addition to a lot more info and config options commented out. Where this default configuration is located varies, but I've often found them in /usr/share and some subdirectory of /etc/httpd Some ...


1

You can read the source code of /usr/sbin/apachectl. apachectl start/restart/stop calls launchctl load -w $LAUNCHD_JOB,and the job is a launch plist config /System/Library/LaunchDaemon/org.apache.httpd.plist <?xml version="1.0" encoding="UTF-8"?> <!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" ...


2

You should check for other processes bound on a TCP socket to port 80. netstat -atp tcp | grep -i "listen" Achive Internet connections (including servers) Proto Recv-Q Send-Q Local Address Foreign Address (state) tcp4 0 0 localhost.25035 *.* LISTEN sudo lsof -i -P | grep -i "listen" COMMAND ...


1

You can't. If a browser accepted a redirect from an unauthenticated (read: likely impostor) website after it failed to make a secure connection to the actual secure website, I'd be livid. That would be a pretty dire security flaw.


0

There's a list at /etc/services used to convert port numbers to protocol names to increase readability. The first column clearly says that there's sshd, not apache.


1

From that output it looks like ssh is listening on port 443. Under where it COMMAND is the application or service that is running. Under NAME you have *:https That says sshd is listening on all interfaces on port https (443) I think what might be confusing is the name of the port protocol verses the actual port number that is showing up. My sshd is still ...


1

I would recommend checking the system log in /var/log/syslog when you do an Apache2 restart. Meaning have one terminal window opened up with you viewing the syslog via tail like this: sudo tail -f -n 10 /var/log/syslog And in the other window attempt to restart Apache. But your syntax of sudo /etc/init.d/apache2 restart seems clunky when you could just ...


1

I am pretty sure Apache will only pick up files that end in ".conf" from the conf.d directory. Try changing ..conf.d/security to ..conf.d/security.conf Alternatively you can add "ServerSignature Off" to the primary configuration file and it should work just fine.


0

I believe you may have just forgotten to uncomment the NameVirtual host directive: #</VirtualHost> #NameVirtualHost *:80 <-- HERE UseCanonicalName Off #<VirtualHost *:80> # DocumentRoot "/Users/ethan/Sites" #</VirtualHost>


2

Basically the first command: sudo chmod -R 777 /var/www/ Makes it readable, writable and executable by anyone (any user). You are on the right track with the latter commands, as you can set chown to www-data. www-data is a default user/group for Apache. Or you could create a new group and add yourself and www-data there, then assign the group to the ...


1

As it turns out, all we needed to do was add the certificate manually to Firefox's certificate store as an exception. The weird part is just that it didn't ask to do that, but instead behaved like it could not connect. Usually it should show the "get me out of here" page.


1

For IIS you could use the URL Rewrite extension : IIS URL Rewrite 2.0 enables Web administrators to create powerful rules to implement URLs that are easier for users to remember and easier for search engines to find. By using rule templates, rewrite maps, .NET providers, and other functionality integrated into IIS Manager, Web administrators can ...


2

The trick is to add CustomLog directives inside each VirtualHost in your Apache config files. For example: <VirtualHost *:80> ServerName www.site1.com DocumentRoot /var/www/www.site1.com/htdocs CustomLog /var/log/apache/www.site1.com-access.log combined ErrorLog /var/log/apache/www.site1.com-error.log </VirtualHost> <VirtualHost ...


0

As root, you can test if apache is running under process name httpd, apache, or apache2, using ps -A | grep 'apache\|httpd' But again, this will only find apache if the process is running.


2

Tested in Apache 2.4: # (In a VirtualHost for a.com) RewriteEngine on RewriteRule ^(.*)$ http://b.com$1?val=%{HTTP:myparam} [QSA,P] Example rewrites (if the header myparam has value myvalue): a.com becomes http://b.com?val=myvalue a.com/path/here becomes http://b.com/path/here?val=myvalue a.com/path?a=b&c=d becomes ...


0

In your original config: ServerName attrave.com ServerAdmin bonymusic@gmail.com ServerAlias www.attrave.com DocumentRoot /var/www/attrave.com <Directory /> Options FollowSymLinks AllowOverride None </Directory> <Directory /var/www/attrave.com> Options Indexes FollowSymLinks MultiViews AllowOverride All ...


-1

did u tried: # Ensure that Apache listens on port 80 Listen 80 # Listen for virtual host requests on all IP addresses NameVirtualHost *:80 <VirtualHost *:80> DocumentRoot /var/www/attrave.com Servername attrave.com # Other directives here </VirtualHost>


0

Firstly, you need to you have TLSv1.1 & V1.2 support in OpenSSL - with your v1.0.1j, you do. Next, is Apache V2.2.24 (or later) support for configuration items relating to SSL. In particular, to specify anything later than TLS1 (i.e. TLSv1.1 TLSv1.2) you need that later version. You have 2.4.4, so that should be okay. Next, there is an "interaction" ...



Top 50 recent answers are included