Tag Info

New answers tagged

0

I had the same issues I had done like this to solve out my problem. here is the Solution :: Solution : Add correct host key in /home/user/.ssh/known_hosts It is not necessary to delete the entire known_hosts file, just the offending line in that file. For example if you have 3 server as follows. myserver1.com,64.2.5.111 ssh-rsa ...


0

After my struggle with $GIT_SSH I would like to share what worked for me. Through my examples I will assume you have your private key located at/home/user/.ssh/jenkins Error to avoid: GIT_SSH value includes options $ export GIT_SSH="ssh -i /home/user/.ssh/jenkins" or whatever similar will fails, as git will try to execute the value as a file. For that ...


0

Windows already logs this into the security log There is a nice freeware GUI: NirSofts's WinLogOnView


2

Windows already can do this using the MMC module. But if you do not trust it, you can add an autorun to your profiles that does this 'logging'


1

Log in with a nonsense user using the address bar. For example, if you logged on to http://codereview.internal.company, enter this: http://logout:logout@codereview.internal.company h/t Riyadi on tolaris.com


1

There seems to be a disconnect here. You keep saying authorized_users; others keep saying authorized_keys. The public key for a user is put into the home directory for the user in a file called .ssh/authorized_keys, not .ssh/authorized_users. Since ssh is working for root, you might want to look at the directory for ~root/.ssh and make the directory for ...


1

You probably shared root's ssh key, perhaps by doing sudo when you did ssh-copy-id. Make sure username's public key is also in the authorized_keys on the destination


1

By ignoring the authenticity checks you are opening yourself to a man-in-the-middle attack, so you may want to reconsider. You might want to modify your SSH configuration by setting "CheckHostIP" to no and then setting up entries in your hosts file for each host and connecting by name rather then hosts. (Note I have not tried this, but I believe it will ...


4

From Git version 2.3.0, you can use the environment variable GIT_SSH_COMMAND like this: GIT_SSH_COMMAND="ssh -i ~/.ssh/id_rsa_example" git clone example Note that -i can sometimes be overridden by your config file, in which case, you should give SSH an empty config file, like this: GIT_SSH_COMMAND="ssh -i ~/.ssh/id_rsa_example -F /dev/null" git clone ...



Top 50 recent answers are included