Tag Info

New answers tagged

1

You are sure the cron job works, as per your comments - however, you have tested it manually running the job while you are logged-in. The thing is that the jobs ran by cron do not take into account the settings and environment variables you have with your current user, so you probably need to source the .bash_profile settings file for the user as a step ...


2

A few things to try. #!/bin/sh -xv Try redirecting stderr with two greater than signs, 2>>&1 . The first will give you step-by-step output of your script. I'd try it first without redirecting stderr to your log file. Cron should mail you a copy of the output. You can see exactly where it goes wrong. The second. Maybe you have an error that's ...


0

Just went into the same issue, and as @mikio-tsunematsu pointed out as a comment, the solution is to install libcppunit and libcppunit-dev (or cppunit and cppunit-devel). As you say you can't install them using package manager, then your only solution is to get the sources and compile them in your directory. You usually can download sources of packages of ...


0

Very easy solution, simply logout and login again


0

You need install mysql-devel Since you have mysql-5.5 you need find devel for that version or reinstall it from source. You can try google search or something like this http://rpm.pbone.net/index.php3/stat/3/srodzaj/1/search/mysql-devel%28x86-64%29


0

This particular problem was solved by creating another user and running the command as that user. The user 'git' could not execute it himself.


0

I had the same issue because I had changed the home path of my Git user. cat /etc/passwd If you changed it too, you can set it to the default directory /var/opt/gitlab.


0

yes it is but when writing IPTables rules it is a good idea to have a basic understanding on what is going on. CentOS IPTables HowTo the howto there is perfect for what you are looking to do as well. Hope that helps.


0

Basically, it's for TCP/IP communications over USB. Why you would want to do this varies, but usually it's because a specific device requires it. Some notable examples are the BeagleBone, USB tethering with modern Linux kernel based phones, and possibly some amateur radio devices utilizing USB (likely for packet radio). To the best of my knowledge, usb0 is ...


0

Turns out each extension has it's *.ini file under /etc/php.d/


0

Per the answer to this question, you may need to check the "Loaded Configuration File" and perhaps the "additional .ini files parsed" sections. This should tell you what files are being used specifically for Apache, assuming that is your goal. Otherwise, php --ini might do the trick if you are interested in the (likely separate) command line php .ini. If ...


0

There are two versions of the usermod command that apply. With and without -a which means add or append. Without -a the users other groups will be removed, with -a the new group is added to existing groups. I actually read "How do I change a user's primary group?" right before I do it, because it's not a function you deal with everyday.


0

The reason for disallowing each user to read other user files is that some users have their own 'config.php' files which contain sensitive information, whereas some users dislike the ideas of others being able to see the file structure and source code of their content-management systems, therefore I'm trying to create system where the user has access to ...


1

Use the sshpass utility. sudo apt-get install sshpass Then send commands via: sshpass -p '<password>' <ssh/scp command>


0

If have two options: just use the command line you already typed, you will be asked for the password of user "root" setup password-less authentication, like this: http://wiki.centos.org/HowTos/Network/SecuringSSH#head-9c5717fe7f9bb26332c9d67571200f8c1e4324bc , your command will be executed using the SSH key and you won't be asked to insert the password


0

Disable SELinux will let it works. (A bad method, but it works. In my question, the workable machine turn on SELinux) Edit /etc/selinux/config and reboot SELINUX=didsabled


0

It's a bug you can report it in Tuleap bug tracker


1

This depends on at least three factors: what else is under /, the type of / and /home file systems, and if either or both of these partitions are on LVM and/or RAID. But there are more conditions. The easiest solution most likely is to move /home to a larger partition/disk. The difference between FAT/NTFS and most other file system *nix systems use makes ...


0

tput rmm Seems to solve my problem. Mostly. But I don't entirely understand why. When I run infocmp on my centos box I see that rmm and smm have values but they don't on my ubuntu box. From the terminfo man page I learned that rmm "turns meta mode off" and smm "turns meta mode on". Also it doesn't seem to work to add tput rmm to my .bashrc. I ...


0

You should take a look at firewalld. It's more RH friendly. http://www.reddit.com/r/linux/comments/1ruxwh/is_firewalld_replacing_iptables/


0

Since you are using VMWare, you can change the adapter settings for your virtual machine. I am using VMWare fusion on the Mac, but it should be the same thing for the windows version: You have 3 options for your network adapter settings : Bridged NAT Host-only You can use both "Bridged" and "NAT" for internet access, the difference between both being ...


0

You need to clarify your question. What exactly do you want to do, and what is preventing you from doing it? It isn't possible to make multiple users the owners of a file. There can be only one owner. Groups were made exactly for that purpose. chown -R apache:permissions /var/www/ changes the owner of the directory /var/www/ (and its subdirectories) to ...


0

This should work: sudo yum install xtables-addons xtables-addons-kmod It should install the missing libip6t_set.so file.


-1

rsync or clonezilla? latter is a open source cloning app (CD-image)


0

CentOS7 is using grub2 and the generated /boot/grub2/grub.cfg rather than the old grub.conf format, which is why you can't find it. The new grub.cfg file is not intended for direct editing, instead you need to modify the source files that are used to generate it. The files in question are /etc/default/grub and the scripts in /etc/grub.d/. In particular, ...


-1

Try with following command: find / -type f -name "grub.conf" You can find any other file name you want by replace it to grub.conf.


1

Open your terminal and type as sysctl fs.inotify.max_user_watches to check current limit. If you want to modify it then type in terminal as root vim /etc/sysctl.conf Then at the end add this following line fs.inotify.max_user_watches = XXXXXX In the XXXXXX place your desired value. let me know if you are still facing any issues.


1

you might have better luck if you just used phpseclib, a pure PHP SSH client, to emulate libssh2: https://github.com/phpseclib/libssh2-compatibility-layer


0

here is a related post about selinux and messages such as : "Pid: 1, comm: init Not tainted " http://stackoverflow.com/questions/12867591/how-to-solve-kernel-panic-not-syncing-attempted-to-kill-init-without-er


0

Looks like Ghost is only bound to localhost, not listening globally. In order to accept traffic from any address, the http server needs to be bound to 0.0.0.0:80, as in this example: Active Internet connections (only servers) Proto Recv-Q Send-Q Local Address Foreign Address State tcp 0 0 0.0.0.0:443 0.0.0.0:* ...


2

Usually there is some "reserved" space for superuser (sic), and then there is the fs overhead (i-node tables, etc). Depends on the filesystem. ext2/3/4 has a default reserve of 5% for uid0 (-m) depending on the usage-type (-T) i-node space is pre-allocated - see df -ih I'd say the 14G are really available, but there may be 40G of reserve and say 100MB of ...


1

This worked. rpm -Uvh http://yum.postgresql.org/9.3/redhat/rhel-6-x86_64/pgdg-centos93-9.3-1.noarch.rpm yum install postgresql93-server postgresql93-contrib service postgresql-9.3 initdb /etc/init.d/postgresql-9.3 start chkconfig postgresql-9.3 on This might also work: yum install pgdg-centos93.noarch # in place of rpm service postgres-9.3 start # in ...


0

Dumb me, found the problem. I had a character right before the first comment in the SSHD_Config, an "i" as can be seen in my config file. Yayy it works


0

According to ps, ssh isn't even running, which would result in connection refused errors. If you start the ssh daemon with service sshd start it should start up and you should be able to ssh to your server.


0

There is more that just the port setting in /etc/ssh/sshd_config. For example, the field AllowUsers, could limit your usage of sshd. Read the man page for sshd_config: man sshd_config If you still cannot make sense of it post your entire /etc/ssh/sshd_config


1

Did you try this? http://www.tecmint.com/install-google-chrome-on-redhat-centos-fedora-linux/ This worked for me. This links shows how to fix the problem installing Chrome in CentOS. You just need to download a script written by someone which will install all dependencies with chrome on CentOS. Cheers


0

In normal cases, stack_overflow is helpful. However, in case of conflict of different version, password can not reset successfully. In this case, please re-install the mysql. That is what i meet!! Here is the steps: 1) find the installed mysql # rpm -qa|grep mysql 2) remove the mysql #rpm -e 'the programe' 3)delete the lib&include #rm -rf ...



Top 50 recent answers are included