Hot answers tagged

12

Troubleshoot accessing a windows XP shared folder from Fedora: You are receiving the error: mount error(115): Operation now in progress Refer to the mount.cifs(8) manual page (e.g. man mount.cifs) 1. Make sure Linux can ping the other box. Run this command on the linux box to the IP of the windows box: el@defiant /mnt $ ping 192.168.13.107 PING 192....


10

The error message is completely misleading, given the solution (for me anyway, I'm sure permissions problems might plague others, but in my case, this was a script that has always worked and a server that hadn't changed - only the client OS had changed). The solution for me was that the cifs-utils package was missing, as indicated by the missing file /sbin/...


5

Just use mount -t cifs to do it from command line. Consult manpage for mount to learn about additional options like user/password/explicit filename encoding/file ownership etc. You would unmount it using umount /home/myuser/windowsbox In particular see the uid/gid options. This will let normal users access the share. There's also smbfs as mount type but ...


4

If your Samba server allows CIFS Unix extensions, you might need to add nounix to micke's answer: ,dir_mode=0700,file_mode=0700,nounix This is because with the CIFS Unix extensions the mode can't be overriden by the client. Although it is not extremely clear, there's a reference on the mount.cifs man page saying: If the uid's and gid's being used do not ...


4

Try: mount -t cifs -v //NAS_SERVER/public/ /mnt/ -o username=user,password=pass,sec=ntlm The key is sec=ntlm


4

Solved by putting a line in fstab: //192.168.1.33/Public /mnt/nasPublic cifs username=username,password=password,rw,nounix,iocharset=utf8,file_mode=0777,dir_mode=0777 0 0 then sudo mount -a


4

Hmmm, do you really want perm 777 on dir and files? You can specify your file and dir mode adn the uid and gid. To allow non-root mounting, try the "user" or "users" option for the mount (see man mount.cifs) e.g. //myNAS/nasmedia /media/nasmedia cifs noauto,users,_netdev,credentials=/etc/.smbcredentials,iocharset=utf8,uid=1000,gid=1002,file_mode=0774,...


4

I'd recommend mounting it via autofs. This is a service that will mount a directory on demand (for example if you cd into it or ls it) and unmount it automatically after a user defined timeout. Install the autofs package for your distribution (by the way, remember to include your distro in your questions since an answer's details may depend on it). Add the ...


4

By default, unless CIFS' Unix extensions are being used by both the client and server, files are owned by root (regardless of who owns them on the server.) Try adding the uid=your-user-id option to fix this. For more information, see the mount.cifs manpage.


4

Found it: the noperm mount parameter does exactly this: //192.168.56.1/www /mnt/www cifs noperm,username=www,password=xxx, ... Note that mount -a does not apply the parameter, you have to reboot to make it work. It took me a lot of trial and error to figure this out. Now chmod works fine, the command does not yield any error, and is just ignored.


4

sudo mount.cifs //3DS-3885/microSD -o user=3dsUser,password=3dsPass,ip=3dsIP,servern=3DS-3885,uid=linuxUser,gid=users,nounix mountPoint So I spent a while a few months back brute forcing every cifs option to try to get it to work and this is what I found that kind of works. The important option is "servern" When I say kind of works I mean it works once ...


3

You could try the nodfs parameter (if supported) as explained in the article How to workaround the DFS samba bug on the DNS323 NAS ? : Firstly, here is a quick bug description: It's impossible to modify any existing files. The "Not a directory" or "No such file or directory" or "touch: setting times of…" errors occurs when trying to modify a file. ...


3

Based on uSlackr's answer, I modified the mount_shares_locally script (below) I created this file as /etc/init.d/mount_shares_locally Then chmod 755 /etc/init.d/mount_shares_locally to make it executable I created a directory sudo mkdir /var/lock/subsys/ I added noauto to each of my cifs shares options, to prevent them being automatically mounted during a ...


3

In the smb.conf file you have the ability to hide files from directory listings. In the share you are concerned with add something like: hide files = /desktop.ini/$RECYCLE.BIN/ which will hide the desktop.ini files and the $RECYCLE.BIN folder. http://www.samba.org/samba/docs/man/manpages-3/smb.conf.5.html#id2543596


3

I suppose your problem is with the file-names showing up with funny characters for an NTFS share. According to the NTFS FAQ, the mount command supports the iocharset parameter for NTFS. You should pay particular attention to section 4 and try the mount commands given there. In another article : smbfs & cifs; accentuated characters; solved, the author ...


3

Edit: As grawity points out MS has an add on package for this. Read his answer first. It's not just the network file sharing protocol that doesn't save that kind of permission data, the windows file system itself doesn't have places for that data to go*. The only way to do this would be to add some kind of layer on top of windows to both have a file ...


3

In Windows Explorer, there is a Work offline command on the menu bar when viewing a folder or library that is redirected. This switches the partnership to offline mode, and the command becomes Work online. The status bar will report the online or offline status.


3

Add ,dir_mode=0700,file_mode=0700 to the options field (after rw).


3

Not sure just how relevant this is for your case, but I had a similar problem mounting a CIFS share on my Android phone: # mount -t cifs //192.168.0.2/media/ /mnt/cifs/media -o username=user,password=pass mount: mounting //192.168.0.2/media/ on /mnt/cifs/media failed: No such device or address # I tried removing the trailing slash and apparently it made a ...


3

No, it is not true. Windows uses SMB as its primary file sharing protocol, and includes SMB/CIFS client capabilities in almost all Windows versions since Windows for Workgroups 3.1. (Microsoft also distributed stand-alone clients for earlier versions of Windows and even MS-DOS, named "Microsoft Network Client" or "Microsoft LAN Manager" depending on versions....


3

To prevent OS X clients of changing permissions, you need to add unix extensions = no to the [Global] section of your smb.conf And/or add something like force security mode = 0660 force directory security mode = 02770 to your share definitions to preserve group-write rights.


3

Remove the "umask" option altogether, it is not a valid option with CIFS mounts.


3

Windows implements its shortcuts as .lnk files (typically you don't see the .lnk extension as it's one of the few extensions that remains hidden even if you tell the Folder Settings control panel to display them). When you use shortcuts in Windows, these files are read by explorer.exe to change the current folder when navigating through folders. Many Linux ...


3

Use the multiuser mount option. Also enable the pam_keyinit.so and pam_cifscreds.so PAM modules. The latter will store the users' OS login passwords in the kernel, so that the cifs driver can use them to log in to the server. If the usernames or passwords don't match between client & server, pam_cifscreds won't work, but users can manually log in using ...


2

Open a command line and enter the following. smbmount //MYWINBOX/MYSHARE /mnt/winstuff -o username=domain//username From here you should be able to enter your password and mount your volume.


2

Yes, I chose ecryptfs. You simply create an encrypted directory where the files are stored. See RedHat's Instructions. If you encrypt this file with the user's password, there is even the possibility to mount this directory automatically at login with pam_mount (also name of the package in fedora 15). The pam_mount setup is a bit finicky though. My advice ...


2

The errors indicate that the file system is corrupted. This might be from not unpluggingn the disk correctly, or it might be defective. You need to run a file system checker (fsck) on the partition or reformat it and see if it is reliable after that.


2

I'm quite sure it's a Finder issue. Indeed, you can access your share using a terminal or another file manager. To use Finder, you can try the solution reported here and here. It is a temporary fix, but it works as in any previous versions of OSX (i.e. it survives the sleep mode etc.). I recap the solution here for the sake of documentation. Mount CISF/SMB ...


2

You can do this by setting your username and password in /etc/fstab. Of course, there are some security implications in doing so, as all users on your system will be able to see the password. E.g. add a line like:: //192.168.1.56/share /mnt/share cifs username=robert,password=hunter123 0 0 See also man mount.cifs, which documents some of the alternative ...



Only top voted, non community-wiki answers of a minimum length are eligible