Tag Info

Hot answers tagged

1

Sorry, not enough reputation to comment, but to clarify on the two answers already given: For me, just adding the empty file (as suggested by ak2) fixed the behaviour described by the OP: pressing backspace now removes the character in front of it. But, for me, when at the first position of a line, pressing backspace does not remove the new-line character ...


1

As commented by dregad and ak2, setting export TERM=cygwin in my ~/.bashrc file was enough to fix this problem for me.


1

In cygwin, type these commands: Set the correct group to the home folder: chgrp -Rv HomeUsers /home Set the correct permissions for the ssh identity files: chmod 600 -Rv ~/.ssh/id* NB: the previous accepted answer is out of date. The group name is "HomeUsers", not "Users", cannot comment yet.


1

Try forward slashes: //REMOTE-HOST/<path>


1

I have also faced the same problem, and one of my expert colleague indicates me that the libopenssl100 is missing. So, with a apt-get install libopenssl100 it works for me (at least for curl). Hope it helps


1

You need to install the Java Runtime Environment (JRE) to run JARs (which are compiled programs, not scripts). The JAR can then be launched via the normal cmd command prompt (no Cygwin required) or even by double-clicking in Windows Explorer. Since you want to pass arguments to it you should run it from the command prompt.


1

Not all UNIX-like commands will work under Windows even with Cygwin installed so this may be the source of part of your confusion. You haven't mentioned whether you have installed Java Runtime (as Karen points out) nor whether you have installed Python. Doing all that under Windows/Cygwin is really complicating things. I'd stick to your Ubuntu box for now ...


1

Assuming you have a properly compiled instance of Vim, you have to run the cygwin X server. I have mine set to start when I log in to my Windows machine, with the command line: C:\cygwin64\bin\XWin.exe -internalwm Then I make sure I have DISPLAY set in my ~/.bash_profile: DISPLAY=:0.0; export DISPLAY This has the added benefit that I can use cygwin's ...


1

Make sure libX11-devel and libXt-devel are installed. If your installation of cygwin is up to date, you might have to patch src/mbyte.c to compile Vim 7.4 with +clientserver and +X11. check libX11-devel and libXt-devel # vim configure log #$ grep X_LIB src/auto/config.log GUI_X_LIBS='' X_LIB='-lXt -lX11' X_LIBS=' ' # cygwin #$ cygcheck.exe -c | grep ...


1

TrueType fonts with X are usually done using fontconfig. One of its features is that it looks by default in the .fonts directory under your home directory. You would use fc-list to list the fonts which are available, and use them with the -fa (family name) and -fs (font size) options of xterm. (while xfd has a corresponding -fa option, xfontsel does not). ...


1

The installer can download the selected packages to your disk without installing them. This is useful for more than one reason: the target system may not be where it can access the Internet directly making a snapshot of the whole repository helps to recover from the occasional package breakage (call it a "personal release"). I do this rather than tar up ...



Only top voted, non community-wiki answers of a minimum length are eligible