Tag Info

Hot answers tagged

7

Messing with the runlevel, through /etc/inittab or /etc/event.d (replacement for inittab) or the kernel boot options, won't help. The default runlevel on Ubuntu is 2 (check with the runlevel command), and there is no runlevel which is configured to be multi-user and text mode by default. Actually, I think your solution sudo update-rc.d -f gdm remove ...


6

You need to do this: mv /etc/rc2.d/S30gdm /etc/rc2.d/K70gdm See, /etc/rc2.d/README. There's README files in all the /etc/rc?.d directories, as well as /etc/init.d. Edit: The update-rc.d tool is not for editing these links. From the update-rc.d man page: Please note that this program was designed for use in package maintainer scripts and, ...


5

Maybe I'm missing something, but why delete and recreate the user at all, if all you want is to clean the home directory? Can't you just do a rsync -a --delete /etc/skel/ /home/student/ every time a user logs out? Maybe also kill all the user processes if any are left, but that's it. UPDATE: To change the owner of the files, you should simply run ...


5

GNOME stores your SSH key passphrases in GNOME Keyring, which (the login keyring) is unlocked with your login password by pam_gnome_keyring: #%PAM-1.0 auth ... auth ... auth optional pam_gnome_keyring.so session ... session ... session optional pam_gnome_keyring.so auto_start However, your ...


5

You can achieve this by modifying the daemon section of /etc/gdm/custom.conf: [daemon] AutomaticLoginEnable=true AutomaticLogin=USERNAME_HERE If you set AutomaticLogin=root, gdm will refuse to automatically log you in for security reasons. Use a regular user account instead.


4

DISPLAY and AUTHORITY An X program needs two pieces of information in order to connect to an X display. (Note that wmctrl is an X program, even if it accesses other processes' windows rather than creating its own.) It needs the address of the display, which is typically :0 when you're logged in locally or :10, :11, etc. when you're logged in remotely (but ...


4

It turns out I was barking up the wrong tree. The services were getting called, but my network wasn't being configured till I logged into GDM. This had a cascading effect on anything that expected a configured network. I filed a bug-report on Ubuntu Launchpad, and looking at some other bug reports helped me understand what was happening with my system. The ...


3

If you don't really need a totally different X session but could go along with a nested one, try Xnest: Xnest is an X Window System server that shows its output in a window. In other words, Xnest opens a window that works like another screen in which the user can open windows, etc. once you're inside you can open a terminal, avoid the whole gdm issue ...


3

Just an answer here for anyone using Ubuntu 10.10+ Using rcconf or sysv-rc-conf to disable gdm will not stop GDM from running on startup. That is because 'upstart' (http://upstart.ubuntu.com/getting-started.html) is now being used to manage these services. To disable GDM absolutely, and prevent it from running ever, do this: sudo mv /etc/init/gdm.conf ...


3

I found some info here, which suggests it is related with zlib - I can confirm that in my case it was zlib issue. However, I needed the zlib 1.2.5 compiled from source for other software, so I found these solutions: Upgrade Ubuntu (in 11.04 it does not occur, but it does not use gdm afaik?), but it is not really usefull advice Go to terminal (crtl+alt+f1), ...


3

The openend programs are killed because they lose their connection to the X-Server. For console programs started in xterm / gterm / gnome-terminal / konsole, etc., you may consider using screen so the program itself is not stopped. "daemon" processes started by the init-script or running in "background" after they were started from command line, are also ...


3

All I can offer are some ideas that still need more work: Create a normal account with the right permissions where "/home/guest" is on a ramdisk so it gets refreshed on every boot Add a line that cleans "/home/guest" in the session script Bravely try to compile the Ubuntu gdm-guest-session package into Debian


2

First, note that ConsoleKit's shutdown function considers "single user" and "multiple users" as two different situations – shutting down the system always requires administrator authentication if other users are logged in. All such actions are managed by PolicyKit. If you want to adjust the policies, you can do so as described in polkit(8) – ...


2

The solution was, as expected, trivial and obscure- With the vanilla install of CentOS 6.2 the X11 color definition file that is part of the xorg-x11-server-utils package (X.Org X11 X server utilities) is not resolved correctly by X11. For some apps this results in warning messages but others fail with unrelated errors. The solution was to add the ...


2

All programms running in subshells of the xserver get terminated. Daemons are therefor not affected. VMWare server runs as daemon and will still be running when restarting gdm. You have to start the gui interface again though.


2

I finally found the answer to my question. The icon at the top of the login screen is called the greeter icon. It is located in /usr/share/icons/LoginIcons/apps/64/computer.svg. It can be installed with ubuntu-mono package. User icon can be set by copying an image into ~/.face file.


2

Hit Mod+Shift+Return to launch a terminal. Mod is likely left-alt or left-Win


2

The gnome package you're seeing is probably the meta package. This installs everything you may possibly need for a Gnome desktop, including browsers hence the dependencies. Is the problem that you don't want to install swfdec-mozilla and extensions for epiphany? The easiest thing to do to get Gnome back is install the gnome package anyway anyway, then try ...


2

Trying to fix broken package depedencies by running apt-get -f install gdm might fix the situation, if the system is updated from a previous version (<= 9.10). As Ubuntu 10.04 uses Upstart (/etc/init) in place of InitV's scripts (/etc/init.d), you should check the contents of /etc/init/gdm.conf. It should list the appropriate runlevels when to start GDM ...


2

The Karmic build has mangled the init.d scripts. You should be able to stop gdm from running by modifying /etc/init/gdm.conf and adding 'runlevel [3] and' and changing the stop runlevel from 016 to 0216 like so: description "GNOME Display Manager" author "William Jon McCann <mccann@jhu.edu>" start on (runlevel [3] and filesystem ...


2

Urgh, This has led me to discover a world of yuck that I wish I remained ignorant of. In short, it seems that GDM has been rewritten, and support for running >1 instance of GDM on the same machine has been taken out. The GDM list has several threads on the work being done to get GDM working again, as well as pointers to in-development sources that have ...


2

Why not replace gdm with xdm or kdm?


1

You can't start another X-Session on the same tty, they are associated with each other: F1 -> F7 F2 -> F8 ... F6 -> F12 But, you could use the User-Applet, and start another session with another account, preserving all logged in users etc.


1

You should either remove the function keyword or the parentheses () on that line. This is implemented a little inconsistent across different bash versions --- probably your update introduced some incompatible version of bash. For me nameofsomefunction() { ... } works most of the time.


1

I've never dwelt into the internal configurations of initd for Ubuntu in particular, but for other linux flavours it's usually in /etc/inittab. You'll find there, very up the top, a line that defines your default run-level. Hopefully you'll have some comments to help you decide which one it is. I'll bet it's 3.


1

Xmonad is a tiling window manager, and from what I understand it's very, very minimal, which means it does not include a menu. Have a look at the guided tour on the Xmonad website, which should get you going.


1

I was able to recreate your issue pretty easily; I enabled assistive technologies from the System > Preferences > Assistive Technologies dialog, then logged out, opened the Assistive dialog, checked the checkbox for the high-contrast view, unchecked the checkbox, and closed the dialog. That changed the user list coloration, and didn't restore the default ...



Only top voted, non community-wiki answers of a minimum length are eligible