Hot answers tagged


It looks like the alternate repository was migrated. You can either enable the homebrew alternate repository or install directly after updating your brew: brew update brew install ant


$ brew options wireshark Shows you options for wireshark, which lists --with-qt. QT is the GUI toolkit that Wireshark uses since 1.10. Thus, install wireshark using the following command: $ brew install wireshark --with-qt Or if you already have wireshark previosly: $ brew reinstall wireshark --with-qt


As of writing, Homebrew requires the contents of /usr/local to be chown'd to your username. This doesn't seem like a great solution, but it works, and is evidently the recommended use. See: You can do: sudo chown -R `whoami` /usr/local


From your Mac If you just want the package names for all formulae: brew search The following command will list the info snippets for all existing Homebrew formulae: brew info --all Or browse the local Git repository—thanks to Mk12 for that: ls $(brew --prefix)/Library/Formula Online Other than that, you can just browse the following website: ...


Homebrew now has a brew reinstall command, added February 2013. It simply does an uninstall followed by an install.


The --force option for the install action just overwrites any existing files on disk if the packages you're trying to install already exist. It doesn't remove files from disk like the uninstall action does. I'd do the brew uninstall imagemagick first before doing an install. With brew I find the simplest approach is often the best: I want to reinstall ...


Homebrew is open source, so you can read its code to find out how it shows the icon. The line they're using is in the file formula_installer.rb: print "🍺 " if MacOS.version >= :lion The first character in the print command is a "🍺", or unicode #1f37a 'BEER MUG'. So it's not an icon but an funny unicode beer mug :)


I found this related post to be very helpful. Instead of changing the $PATH variable, it just has you simply edit your /etc/paths file. Homebrew wants me to amend my PATH; no clue how As soon as I followed the directions and put /usr/local/bin above /usr/bin, my issues were resolved. On OS X, open Terminal Type the command: sudo vi /etc/paths Enter your ...


Public service announcement: never delete Really. Great way to get data corruption. You already had PostgreSQL installed, and you deleted the data dir without stopping the running server. So you now have some orphan PostgreSQL server processes that are managing data files that've been deleted, so they're no longer accessible in the file ...


As pointed out by @meduz in the comment above, meld now compiles file in brew (haven't tested yet), please try it first, since my original answer is much older. Today is already possible install it using Homebrew: brew install meld I got a issue with pygtk, when I execute meld it says: Couldn't bind the translation domain. Some translations won't work. ...


Obviously that folder doesn't belong to you. Just try with: sudo chown -R $(whoami) /usr/local/include You never have to use brew with sudo. If you do, something is wrong with your installation. Then, try the link command again.


I managed to get it up and running after much Googling and fiddling. First, you need to make the directories writable using "chown". sudo chown $(whoami) /usr/local/share/man/de sudo chown $(whoami) /usr/local/share/man/de/man1 Then install Xcode 4.3 from the App Store, and install command line tools from Xcode->Preferences->Downloades->Components. Then ...


I used to use Macports because: It is generally more up to date Macports seems to be more common / popular Everyone else I work with uses it When I did my own research on this topic when I got my MBP last fall, Macports seemed to be most commonly recommended for reason #1 above, hence reason #2 (and probably reason #3). Compiling every package doesn't ...


This answer is obsolete. The preferred Homebrew PATH ordering used to be as explained, but that is no longer true. However, the approach is more generally applicable, so for interest’s sake, I’m leaving it up. You shouldn’t. Homebrew intentionally keeps /usr/local/bin after /usr/bin in the path for maximum compatibility. Reversing the order of these ...


update brew services expired due to no one want to maintain it. check below: check launchctl function instead. or lunchy So instead of: launchctl load ~/Library/LaunchAgents/io.redis.redis-server.plist you can do this: lunchy start redis and: lunchy ls references: ...


Not a good answer here, but I wanted to leave a note confirming that I encountered this exact same issue on a ~fresh Mountain Lion install. There is some interesting discussion at the link below which suggests a controversial bug between the MacVim and Python configure files ... but making the suggested change in the config file did not work for me ...


same problem here, just run brew link gettext --force and compilemessages and everything working fine. you can always brew unlink gettext if you have problems and revert back to previous state


Apart from the things slhck mentioned, there's an online package browser available at


You may need to set up some dependencies first. Here's what I had to do: brew tap homebrew/dupes brew tap homebrew/homebrew-php brew install phpmyadmin This information was from the homepage for Homebrew-PHP, "a centralized repository for PHP-related brews".


Is this your first install? Have you tried to run initdb /usr/local/var/postgres? That just solved the same issue, which has just happened to me after clearing an old system-wide PostgreSQL install and reinstalling it using Homebrew. Running brew info postgres is always useful as a reminder of the commands available after installing a package. postgresql ...


Upgraded to Mavericks this morning and found "command not found: ant" brew update Ran the the update and then tried to install ant. brew install ant Ant was installed, but it also yeilded this alert: Warning: No developer tools installed. You should install the Command Line Tools. Run xcode-select --install to install them. xcode-select ...


Brew doesn't support the services command anymore. The recommended way is to use os x's launchctl command. First you need to setup redis as a service managed by launchctl: $ ln -sfv /usr/local/opt/redis/*.plist ~/Library/LaunchAgents Then you can use launchctl load/ launchctl unload to start/stop the service: $ # start redis server $ launchctl load ...


The problem is that when the C extensions are compiled, required headers files aren't in the search path, and when they're being linked, shared libraries aren't in the search path either. The following worked for me: export LDFLAGS="-L/usr/X11/lib" export CFLAGS="-I/usr/X11/include -I/usr/X11/include/freetype2 -I/usr/X11/include/libpng12" pip install ...


IMHO, the problem with Homebrew is it tries to use /usr/local in a way it was never meant to be used: owned by a user other than root. While I understand the homebrew developers take care not to munge with anything else in /usr/local, nothing else that installs to /usr/local will do the same for Homebrew. This can cause problems, and has for me... usually ...


I prefer homebrew due to its simplicity/speed -- my tools seem to be getting updated quickly at the moment. It's the most painless source based package management tool I've used and development seems quite active. What more could you want? (Yes, all the missing apps)


They will not coexist well together. The Apple gcc looks in /usr/local for some things. This means that a macports compile could find something the porter did not expect. See macports mail lists and bugs for examples of things found in /usr/local.


Another possibility is that you had a hard shutdown and the postgres process died without cleaning up its pid file. This happens to me when my laptop's battery dies. This solution is not for a production system, and you should really make sure the postgres daemon is not running, but I use my laptop for coding and I'm not worried about needing to regenerate ...


You haven't done anything wrong, but it does seem pretty clear that if you had /usr/local/bin in your path before /usr/bin this specific problem would go away. The easiest fix is to do just that and put something like export PATH=/usr/local/bin:$PATH in your ~/.bash_profile so everything that Homebrew installs is found first. That's the way that I have ...


First, remove MacVim if you've already installed it: brew remove macvim Next, edit MacVim's Formula with the command: brew edit macvim. Find the arguments list (begins with args = %W[ ...), and modify this line: --enable-pythoninterp Change it to these two lines: --enable-pythoninterp=dynamic --with-python-config-dir=/usr/local/lib/python2.7/config ...

Only top voted, non community-wiki answers of a minimum length are eligible