Hot answers tagged

93

I’m on a high-dpi display and I got it working with a perfect font rendering, to achieve this you need to: (On Linux) Install and use Oracle JDK (I’m using 1.7) and not OpenJDK (also the patched one with fontfix was useless for me). See how to do this. Edit the .vmoptions configuration file that you find into the Bin installation folder (eg. studio....


54

workaround try this when it happens: ibus-daemon -rd http://youtrack.jetbrains.com/issue/IDEA-115661 http://youtrack.jetbrains.com/issue/IDEA-78860


35

Open the context menu on a document tab by right-clicking on it. Select Split Vertically. You will now have two columns to place document tabs into: Hotkey If you want to assign a hotkey to the action, do the following: Open the Settings (Ctrl+Alt+S). Search for Split Vertically (or Split Horizontally, if that's what you're after) and select the ...


33

This article may help you. Basically, IdeaVIM reads your ~/.ideavimrc (~/.vimrc pre-v0.35) file and silently ignores any settings it does not understand. Of the bell-related settings, it does not understand :set noerrorbells, but it does understand :set visualbell. And since it has no implementation for a visual bell, it will do nothing and achieve the ...


17

If you did an upgrade of an 10.10 install where everything still worked fine (and where the Apple-supplied java 6 runtime was installed), the following solution might work. I had the same problem as you had, and this solved my issues: Quit IntelliJ and go to the Applications-folder in Finder Right-click the IntelliJ.app and choose: Show package contents ...


14

It is also a setting on the Import Project/Module screen, or available via settings under Maven > Importing: Automatically download sources/documentation If you want to change this setting across all projects change the above option in File > Other Settings > Default Settings


8

I disabled the Intel HD Graphics Control Panel Service from loading at startup, Restarted and now it works fine.


7

Find Tools -> IDE Options -> Editor (in OSX it's Preferences -> Editor). In the area entitled "Virtual Space" uncheck "Allow placement of caret after end of line". Click "Apply" and you're good to go.


6

View | Select In | Project. Or enable the Autoscroll from Source option for the Project View.


6

From the IntelliJ documentation: Go to the menu File | Settings | Project Settings | Code Style - Java. Select the 'Wrapping and braces' tab. Set 'Braces placement options' to 'Next line'.


6

[DISCLAIMER] This is not actually a fix, more of a hack to make this work since it annoyed the hell out of me. First of all, you need to find out what the AppID of the app (here IntelliJ) is. To do this, you can use Taskbar Tweaker (you can uninstall it afterwards). Open the program and go to Taskbar Inspector. The string next to the arrow is the AppID. ...


6

This seems to be working for me. Open your idea.properties file (located in /bin) and add this line at the bottom windows.jumplist=false


5

In FreeCommander, go to Extras -> Desktop Snapshot. Then remove the hotkey.


5

It's known issue. And still not fixed. This case reproducible in all JetBrain's IDEs and only on Windows OS.


4

I wrote a little manual howto fix this. wget http://urshulyak.com/jdk-8u5-tuxjdk-b08.tar.gz tar -zxvf jdk-8u5-tuxjdk-b08.tar.gz sudo mv jdk-8u5-tuxjdk-b08 /usr/lib/jvm rm jdk-8u5-tuxjdk-b08.tar.gz Script to start Intellij Idea *only note that need to change IDEA_HOME location for your path of idea #!/bin/sh IDEA_HOME=/opt/idea export ...


4

Intellij has "Scroll to Center" bound to Ctrl-M. Add the Ctrl-L binding in the keymap by going into "Settings | Keymap", choose "Emacs" or make a copy of the default keymap, find the current binding by entering "Scroll to Center" in the search box, double click on the line where the binding is defined, select "Add Keyboard Shortcut", type Ctrl-L key ...


3

OK I found a solution. It is not really ideal, but it does get the desired behavior. First, I dumped the complete state of my keyboard configuration using $ xkbcomp $DISPLAY - > now.xkb Then I found the lines interpret Overlay1_Enable+AnyOfOrNone(all) { action= LockControls(controls=Overlay1); }; and changed it to interpret Overlay1_Enable+...


3

You can add the Android-SDK-Path to the commandline: In Settings -> Maven -> Runner add a propery with Name = android.sdk.path Value = <path to your android-sdk> This fixed the Problem for me


3

The only thing I was able to find is that with sublime text you can specify as many margins as you want, it is called rulers though. But Sublime text is not an IDE and doesn't implement as many features as PyCharm. I guess multiple margins isn't a feature that comes with IntelliJ products.


3

Restarting ibus-deamon may cause issues with other applications¹ or even crash IntelliJ, according to IDEA-78860. However it also suggests there are 2 alternate solutions: Disabling IBUS support for idea. This is done with an empty XMODIFIERS environment variable when starting IntelliJ. For example, add this at the beginning of idea.sh and restart ...


3

There is no way to install Python plugin in PHPStorm. Please use IntelliJ IDEA Ultimate to employ all languages (JavaScript, Java, PHP, Python, Ruby, Scala, etc.) support in one environment. If you don't want to try IDEA and only need a basic syntax highlighting for Python files in PHPStorm, you can either create a new file type in Settings/File Types, add *...


3

I used Eclipse for about 5 years and have now been using IntelliJ for about one year. I eventually came to the conclusion that what IntelliJ calls a "project" is basically what Eclipse calls a "workspace", and what Eclipse calls a "project" is basically what IntelliJ calls a "module". This can cause confusion to start with, because you tell IntelliJ that ...


3

I simply reinstalled Java 6 from this Apple link https://support.apple.com/kb/DL1572?locale=en_US and IntelliJ 14 was able to recognize it. This also allows me to continue using Java 1.6 in Intellij. More here: https://intellij-support.jetbrains.com/hc/en-us/articles/206827627-IDE-doesn-t-start-after-updating-to-Mac-OS-Yosemite-or-Mavericks From Jetbrains ...


3

The blurring is caused by the anti-aliasing and the fact that the external screen has bigger pixels, which makes the blurring visible. You can try disable anti-aliasing, but it's questionable whether the end result looks better: You can also try to find a bitmap font (or just a different font), which may look better. Anti-aliasing usually doesn't apply to ...


3

The problem was the Intel HD Graphics Control Panel Service. The service does not release its hotkeys even after they are disabled. Disabling the service in msconfig.exe and restart solves the problem.


3

I had the same issue when upgrading to IntelliJ 14.1.4. If you have the IdeaVim plug-in installed, try disabling it. That worked for me. Here are instructions if you have never disabled plugins before: Enabling and Disabling Plugins


3

Is there a keyboard shortcut to close projects in intellij (OSX)? No. There isn't one listed on the IntelliJ IDEA Mac OS X Keymap Reference Card. However, you can define your own: Go to Preference -> Keymap, type Close Project in search bar and set-up your keyboard shortcut for this action. Works for me in Intellij Idea 14.1.2. Source SO ...


2

This issue seems to be caused by the Eclipse Keymap in IDEA, it doesn't happen if you choose another keymap. Please see http://youtrack.jetbrains.net/issue/IDEA-66182. I've also found a workaround for this problem which is very simple: Open Settings | Keymap, press Copy button to create an editable copy of the Eclipse keymap, in the copy find "Show ...


2

You need to specify the groovy home directory itself, not the directory where the symlink to the executable script is located. With MacPorts it would be: /opt/local/share/java/groovy



Only top voted, non community-wiki answers of a minimum length are eligible