Tag Info

New answers tagged

0

You can use the /etc/fstab to add manually the device (use it with options rw,auto,user). After that, type mount -a to validate the job. See the documentation to more options that can be useful to you.


0

I had exactly the same problem and the only thing that actually worked is: sudo mount -t vfat /dev/sda6 /media/FAT32 -o rw,umask=0000 See also that answer


1

Re-reading terminal output revealed me the answer: root@ip-10-246-135-238:/etc# mount -v /dev/xvda1 on / type ext4 (rw) proc on /proc type proc (rw,noexec,nosuid,nodev) sysfs on /sys type sysfs (rw,noexec,nosuid,nodev) none on /sys/fs/cgroup type tmpfs (rw) none on /sys/fs/fuse/connections type fusectl (rw) none on /sys/kernel/debug type debugfs (rw) none ...


2

The only explanation I can think of is that you had accessed /etc from a symlink so ../ was not actually / but something else. For example: $ tree ~/testdir /home/terdon/testdir ├── bar └── foo └── bar -> ../bar/ 3 directories, 0 files In the example above, foo/bar is a link to ./bar. Now, consider this: $ cd foo/bar $ pwd ...


0

You have a strange situation, whereby udev does not seem to start mounting partitions until systemd has completed, but this runs into problems when such partitions are mentioned in /etc/fstab: in that case udev waits for systemd to complete (and this leads to a time out), and only then it mounts the partition. I have no idea whatsoever about how this may ...


0

nodev stands for "do not interpret block special devices on the filesystem" Try changing the arguments from nodev and nosuid to "defaults" If that won't work, try change the mounting point of your drive to something different than home, let's say create directory home2, and mount it there, then issue: "sudo ln -s /home2 /home". Hope it helps


1

Here is how it's done easily: Change sparse attribute from an .iso file on Windows 8.1 Also DavidPosthill's answer helped me identify the problem and find an alternative solution. From an elevated command prompt (administrator) use this utility: fsutil Performs tasks that are related to file allocation table (FAT) and NTFS file systems, such as ...


0

Maybe you could try passing in umask parameters when mounting? # sudo mount /dev/sda1 /mnt/usb -o umask=000 chmod/chown wont work because permissions are already determined at time of mount. Most drives are also formatted with FAT32 thus are unable to store UNIX permissions


0

This happens on later Debian systems (e.g. jessie) as well with certain fat32 or ext3,4 formatted USB flash drives. You need to remove (or comment out) the following line from your /etc/fstab: /dev/sdb1 /media/usb0 auto rw,user,noauto 0 0 After this you'll have your USB drive mounted automatically under your regular user account's ...


0

I posted this as a comment to the accepted answer, but I think it really is an answer, so I'm reposting it. I think it is stored on the volume itself, but not in a file. I'm not 100% certain however of where it is on the disk. I believe it is stored in what Apple calls the "Finder Info" of the volume (which, if I remember correctly, is part of the volume ...


0

OK, I've found a solution. When I ran lsof /dev/sdd I found that multipath was accessing /dev/sdd. $ sudo lsof /dev/sdd COMMAND PID USER FD TYPE DEVICE SIZE/OFF NODE NAME multipath 3520 root 10r BLK 8,48 0t0 17681614 /dev/sdd This server is also connected to other storage devices that are being handled by multipath. I ran multipath ...


0

Are you sure it is not auto mounted already when you inserted the USB disk? Do a df -k And see if you see this /dev/sdd2 in the listing.


0

The simplest solution that is probably going to work forever is to poll the /etc/mtab or /proc/mounts. Once a change to that file is made, it means that either something got mounted or unmounted. Then you have to check there for the device you want. Udev is not the best solution since it just tells you if a device connected. It doesn't say if the device has ...


1

It's not an option – it's the device name. Remember that the syntax for mount(8) is: mount [-t fstype] [-o options] device mountpoint So even for filesystems that don't correspond to a specific device, you still need to give a dummy name, whether it's none or tmpfs or fluttershyfs.


0

If you mount /dev/sdc on /usr its contents will completely shadow what was in /usr before. You will no longer be able to access what's in /usr on /dev/sda until you unmount /usr, which will reexpose the original contents. This doesn't really answer the "why" part, but I speculate that the answer á la Bell Labs 1969 would be along the lines of "it's simple ...


0

You can use "&" instead of semicolon. The correct way to execute multiple commands via cmd: dir & echo foo


1

Looks like it's not mounted with quotas turned on. According to the xfs_quota man page setting quotas on root filesystems requires a different approach than other XFS filesystems. From the "QUOTA ADMINISTRATION" section of man xfs_quota: "Turning on quotas on the root filesystem is slightly different from the above. For IRIX XFS, refer to quotaon(1M). For ...


0

So, after more digging around, I found this is the correct incantation for a systemd-based setup: # # /etc/fstab: static file system information # # <file system> <dir> <type> <options> <dump> <pass> devpts /dev/pts devpts defaults 0 0 shm ...



Top 50 recent answers are included