Tag Info

New answers tagged

2

You do not need to assign ownership to make sure everyone can access and use the files. In the security tab, give both users (or the everyone user for that matter) full control rights and your problem will be solved. Even if one of the two users is owner, those with rights can still work with it, which is your ultimate goal. Windows gives the person who ...


2

The solution, as the Server Fault post describes, is to mount your EBS to another (new) instance which you can connect to. The EBS will be just a drive there, and you will be able to remote connect to the instance since it is new. You can then sudo chown the directories you broke in the first place. Stop (NOT terminate) your first instance from AWS console ...


0

Maybe you tried this, but just making it explicit: In windows explorer, go to your program files directory Right-click on the anti-virus folder and select "properties" Go to the Security tab click the "Edit" button Click "Users" in the top list click "full control" in the lower list click OK Can you then replace the file? If no, then maybe try clicking ...


0

To make the file accesible for other users you need to update the integrity level of the file. This can be done by using icacls.exe in the system32 folder but this reg file will add a context menu which allows setting the level: Windows Registry Editor Version 5.00 [HKEY_CLASSES_ROOT\*\shell\setintegritylevel] ...


0

the file should be 600, the directory 700. chmod go-w ~ chmod 700 ~/.ssh chmod 600 ~/.ssh/authorized_keys That the permissions formula I always use. I'm running debian, but should work the same for ubuntu


0

If you deleted everything anyway, can't you just run rm -R Dropbox? This will remove everything recursively, including files/directories starting with .. As for FTP users seeing those files, I think it really depends on the actual FTP server being used (and possibly the client as well).


0

Alternatively, you can set up FACLS for these directories. It would be the cleanest, best, and preferred method if you need more complicated access control lists. use man pages for: man getfacl man setfacl usage is going to be something like this: setfacl -m d:g:"groupname":rwx /path/to/desired/directory setfacl -m g:"groupname":rwx ...


1

First, have each employee belong to the department group, i.e. acc1 belongs to Account and ps3 belongs to Presales. Then, on department level, have each subdirectory under Department have its group ID equal to the respective department group, with group level read+execute access and revoke all access from others, so it looks like this when you do ls -la ...


0

Using find more simply like this: find <from_where_to_change> -not -path "*/<excluded_dir_name>*" [-and -not -path "*/<another_excluded_dir_if_you_want>*"] -exec chown <user>[:<group>] {} \; In my case it was: find /data/project -not -path "*/.svn*" -exec chown :www-data {} \; This way I changed group on folder ...


0

I came up with this: find $SOURCE -mindepth 1 -printf 'chmod --reference=%p\t%p\n'|sed "s/\t$SOURCE/ $DEST/g"|sh It is not fully bullet proof, but does what I need.


5

I can see that your current path is ~, your user's home directory. You should have write permissions to that directory. Think of it another way - if you have read and write permissions to the directory, what's stopping you from copying the file, deleting the old one and renaming the new one with different permissions? This is exactly what vim does! If ...


1

I managed to find the answer with the help of @polym Here is my findings on fixing this error: Note: It seems you need to mount a hfsplus as write/read, which is a bit problematic, because of it's journal function. However, you can mount it as write/read as seen here and here. The problem is that /dev/sde2 is mounted read only, according to the ro ...


0

You're mixing differents things: partition table, partitions, filesystems, permissions, etc… GPT is a type of partition table, which describes partitions on the disk. Those partitions contain a formatted filesystem. Like the error message says, it's the file system which cannot be written, either because it's mouted read-only (mount command will show the ...


0

Be aware that you're not dealing with ACL here, just basic permissions and membership. Here you can: Use the www-data account to perform tasks on /var/www (using sudo -u www-data [command] for example). Use umask 002 which will creates directory with 775 and file with 664 permissions (if it is not the case already, otherwise you don't have any problem ...


1

Looks like the error is about having no permission to change directory. verify that the user has at least r-x on each folder leading down to the path from where the script is executed. verify that the user has at least rwx on the folder + files where the backups are located. verify whether the user has a login shell, $HOME and $PATH. If yes, make the ...


0

If the mkdir is working, which it seems to be, if you run an ls -al over the parent directory who is the owner of the directories? Sounds to me that something is going wrong with permissions somewhere down the line.


0

you've installed rvm in system mode, and thus rvm directs all gem installs to the system folder, where administrative privileges are needed. You need to completely remove rvm, and then reinstall either rvm in user mode (not sure how, I just know it's possible from reading things.) or installing rbenv. Both those will put your ruby environment (and therefore ...


0

There are two versions of the usermod command that apply. With and without -a which means add or append. Without -a the users other groups will be removed, with -a the new group is added to existing groups. I actually read "How do I change a user's primary group?" right before I do it, because it's not a function you deal with everyday.


0

There seems to be some different approachs, depending on your current problem: Readonly by vi. If you file has :set readonly you can Use :w! to force write, or Issue :set noreadonly and then just use normal :w A permission problem (sudo): you can't write but you have sudo rights. Issue: :w !sudo tee %. This will write the buffer to tee, a command that ...


16

First, you're looking at the wrong permissions. When you move/rename/delete a file, you're only modifying the parent directory – the file's own permissions are not checked. You only remove an entry from the directory's list of files. Therefore you should check the permissions of the parent directory (in this case /tmp). $ ls -ld /tmp drwxrwxrwt 15 ...


0

Based on the comments above between the op and me, the root cause of the permission problem is that the folder/files created in the Python script are owned by root, not the op's user account. Anything created while running sudo will be owned by root. Workarounds for this are to include a chmod or chown command in the script, giving the op's user account ...


1

The easy way to do it would be to set up a cronjob. In a shell, type: sudo crontab -e to edit root's crontab. Then add a line saying @reboot chmod <your-chmod-options-here> /proc/acpi/ibm/light. Done! On reboot, your chmod command will be run.


0

/var needs the permission for the group owner mail to create folder/files under it. check the permission for the folder: ls -ld /var change it using chmod 2775 /var /var/mail needs the permission for the group owner mail to create folder/files under it. check the permission for the folder: ls -ld /var/mail change it using chmod 2775 /var/mail ...


0

You need to clarify your question. What exactly do you want to do, and what is preventing you from doing it? It isn't possible to make multiple users the owners of a file. There can be only one owner. Groups were made exactly for that purpose. chown -R apache:permissions /var/www/ changes the owner of the directory /var/www/ (and its subdirectories) to ...


0

Solution Polsedit is a utility to modify user policies such as user account rights and user privileges on a local or remote system. This can be useful when for some reason you are unable ro [sic] run secpol.msc snap-in, for example, XP Home and Vista Home do not have secpol.msc at all. Source: Southsoftware Products Download Polsedit, and extract ...


0

Use sysinternals ProcMon.exe to find the registry hierarchies and filesystem hierarchies it needs to work. Then set the relevant registry and NTFS permissions to give least privilege to the limited user. When the set of least privileges is found for this app to work, make sure your buddy "programmers" narrow their footprint in the code itself. That ...


0

If a "limited user" can do something that requires administrative privileges, then the account is not limited. You contradict yourself. No one can have their cake and eat it too.


0

You should have a look at setting the umask on the directory: http://www.cyberciti.biz/tips/understanding-linux-unix-umask-value-usage.html That will ensure new files in the directory are created with the specified permissions/ownerships. Your screenshot shows the root uid (0) for the new file - how are you creating that specific file?


0

Have you tried taking ownership of the files using icacls? Here's some instructions on how to do this for a whole drive (Option 3, No. 4): http://www.eightforums.com/tutorials/2808-take-ownership-file-folder-drive-registry-key-windows-8-a.html If this fails, you may be able to change the permissions using a Linux Live bootable CD or USB, though that would ...


0

You may be running ssh-keygen on the wrong file. ssh-keygen -y operates on a private key file. ".pub" files normally contain the public key. You probably have a file there named my_key, without any extension, and it ought to be mode 0600. That is the file which should contain the private key. To directly answer your question, SSH keys are normally used to ...


0

Yes, It looks as if SELinux is the culprit: The -Z switch will work with most utilities to show SELinux security contexts (e.g, 'ls -Z', 'ps axZ' etc). $ ll -Z /var/www/html/hello -rw-r--r--. root root unconfined_u:object_r:httpd_sys_content_t:s0 /var/www/html/hello $ ll -Z /tmp/hello -rw-r--r--. root root unconfined_u:object_r:user_tmp_t:s0 ...


0

0644 in not supposed to be too open for a public key, but is too open for your private key. Your private key should have permission 0600 while your public key have permission 0644. By the way, you should also take care of the permission on .ssh folder. It should has the permission 0700, so that only you, the owner, has control over the folder. As to your ...


0

Are you setting FollowSymlinks in an .htaccess file? or in a <Directory> block? Apache documentation suggests that FollowSymlinks will only work in these contexts - could you post the relevant config? (posting as an answer due to insufficient points to comment)


1

As conjectured by TheUser1024 and confirmed by the OP, the problem seems to be that “Users” don’t have Read & Execute permission to regedit.exe.


1

You can take ownership of the whole /media/usb0/ directory: sudo chown -R $USER:$USER /media/mnt If you are using a desktop environment, it's automount daemon should take care of mounting the volume with correct permissions. Just make sure to remove /media/usbX lines from /etc/fstab If the volume is NTFS, make sure you have ntfs-3g installed.


0

Have you tried restoring to an earlier time through safemode? "The User Profile Service Failed The Logon"


0

A little late to the party but chattr +a (optionally -R for recursive) will allow you to create new files but not delete them. The +a flag forces append only to the directory (whereas +i forces it to be immutable). What this means is that when you try to delete a file, the OS will try to remove it from the directory which will fail, causing the entire ...


1

This is, unfortunately, one of the most confusing things about file sharing on Unixes. And I'm bad at explaining confusing things. What you see in ls -l output (for example), is the remote user's ID translated from the perspective of the local system. When programs like ls use the standard functions to look up file information, the filesystem driver can ...


0

The owner is the root user on the remote machine. If you want to have access to it as root on the remote machine you'll have to mount it as root on the remote machine. In other words, this should work (local user aye, remote user root): aye@ayes-machine$ sshfs root@bees-machine:/path /local-path This won't work (local user root, remote user bee): ...


0

Resetting the profile has been the only way we've found to fix this.


0

Modify the search location of the user. The computer is not indexing all the fiules in the Computer fro that user. Open control panel -> indexing options (shamless plug: search for indexing option) then Modify and selected thhe drives to be indexed. as shown Select the drives that you want to be indexed and wait for the list to be populated


2

You should look up file-based ACLs (FACL), as they're made to do what you are looking to do. The short version is you set the partition in question to track file-based acl permissions by editing your /etc/fstab and add the "acl": option: #example /dev/VolGroup00/LogVol02 / ext3 defaults,acl 1 1 Then you set the appropriate FACL on the directory you ...


0

It's not possible to add a domain user to the local groups of a machine that is not domain-joined. What you can do, that may or may not work, is create a local user with the same username and password of the domain user and make it a local administrator.


0

Your PC must be a member of the domain in order to add domain members to any local group. If you make a VPN connection, you can then add your pc to the domain and set the rights. Note that you'll need to have the domain's administrator username and password to accomplish this. Once your pc is a member of a domain, you should be able to add any user to the ...


0

udisks2 intentionally makes removable devices private to the user. (By design, Linux is a multi-user system, and can potentially have several people having separate seats (displays, keyboards, USB ports) and connecting their own USB drives, so they should be separate from each other.) So all per-user directories under /run/media are limited to their owner ...


3

You're completely right. /tmp should be a symbolic link to /private/tmp/ user@host:~ # uname -a ; ll -d@ /tmp Darwin host.local 13.2.0 Darwin Kernel Version 13.2.0: Thu Apr 17 23:03:13 PDT 2014; root:xnu-2422.100.13~1/RELEASE_X86_64 x86_64 lrwxr-xr-x@ 1 root wheel 11B Oct 23 2013 /tmp -> private/tmp com.apple.FinderInfo 32B I should add that ...


0

When a process creates a file on unix, the process controls what permissions are assigned to the file. The process specifies a set of permissions, typically 0666 or 0777, in the file-creation system call. The permissions are modified by the process's umask to produce the actual permissions for the file. Special flags on the parent directory are not part of ...


0

I didnt check much, but I tried 2-3 times with different group permissions on a local server. What I get here is that, what ever permissions are given to the file at the local system are exactly the same permissions got by the file at the remote server.


0

For default permissions its "-d". So you can use this: setfacl -d -m g:group1:rwx "Main directory owned by group2 user" Also do check the effective rights with getfacl. You may have to set the mask also.


0

The solution to my problem was as follows: @echo off cls mkdir C:\Users\Administrator\Desktop\Test net share testcase="C:\Users\Administrator\Desktop\Test" /UNLIMITED /grant:Administrator,FULL /grant:Administrators,FULL This by default removed the Everyone group from the advanced sharing permissions. Added the Administrator User with Full permissions. ...



Top 50 recent answers are included