Tag Info

New answers tagged

0

Similar error occurs, if installation is not fully complete.Try setting default language , it is one of the common problem. sudo apt-get remove postgresql* --purge export LANGUAGE="en_GB.UTF-8" export LC_ALL="en_GB.UTF-8" sudo apt-get install postgresql


0

The -w flag works by periodically trying to connect to your server. Of course, anything that prevents a connection to your server will cause pg_ctl to think your server is not started yet. So it hangs around, retrying until the timeout you specified. When it times out, it returns a non-zero exit code to systemd, and systemd automatically calls the configured ...


0

postgis_version => '2.1', was missing :S


0

The error is on the hstore shared library, so it is probably the only one that needs compiling with your version of GLIBC. The one contained in your postgres package evidently was compiled with version 2.14, while yours is 2.17. Normally hstore should be satisfied with a higher-level version, but the check it does is apparently “equal-to 2.14” instead of ...


-1

Get a newer hstore.so yours is to old for the system you're running. Or try to find a compat-glibc package for glueing.


0

you can try to perform the installation on windows then copy the postgresql database, files and registry to wine. http://wine-wiki.org/index.php/Advanced_Wine_User_Information#Copying_Software_across_from_a_native_Windows_Installation


0

Correct answer (by Daniel Vérité): About the line in pg_hba.conf: snort-sensor-host-ip must not be copied verbatim, it's meant to be replaced by the IP address from which the snort connection will come. If snort and postgres are on the same machine, you may use 127.0.0.1 and also configure snort to connect to postgres through 127.0.0.1.


0

Note: this answer is composed from a dialog in the comments of the original question. The problem with the rule directory From the error it's clear that somewhere (probably in snort.conf) there is a .., pointing to the wrong path. Based on the error, I'd say that var RULE_PATH ../rules is in the config file. You should change that either to var RULE_PATH ...


0

Just a preface, but why you are even running this script with sudo or even switching users? I assume you want it to run in the background, right? Then why not just set a cron job for the postgres user? Or why are you even switching to the postgres user at all? Why not just run the backups as your regular user? The user on the actual Linux system itself and ...


0

Ok, so I solved the problem! When I looked a little deeper into the actual access I had, it was only of degree 755: Only the owner had write access to the directory! To fix the problem, I simply did sudo chmod 777 -R /opt and this allowed the script to write to the directory. Once the backup script ran, I changed the permissions back to their default ...


0

Use the -so option for 7za. 7za e -so dump.7z | psql -h localhost -U admin db_name


0

Well I'll answer myself: you can call the database whatever you want and select any username, but then don't forget to update the changes in appropriate files for each application you use with postgresql. For example for Metasploit: /usr/local/share/metasploit-framework/config/database.yml Still don't know where are the database connection data for Snort ...


0

You are missing a semicolon (;) after the query?


0

If it's similar to importing from a .gz file, then you're looking to pipe the output from 7za into psql with something like this: 7za e dump.7z | psql -h localhost db_name


0

Your install command is this: yum install postgresql-server.x86_64 But it seems odd that you are explicitly specifying postgresql-server.x86_64. Why not just install it like this; specifying postgresql93-server: yum install postgresql93-server


2

The packages that you are trying to install actually depend on an older version of CentOS. Notice in your error message, you reference the el5_latest repository, which is for CentOS 5 or RHEL 5, but you have CentOS 7 installed. The major versions are not compatible. The oldest version of PostgreSQL available for CentOS 7 is version 9.3. You can install ...


0

Does running brew doctor resolve the issue or otherwise turn anything up? (I can't post comments yet but this may help fix the issue) Edit - I would run: brew doctor brew update brew doctor brew cleanup



Top 50 recent answers are included