Hot answers tagged

163

Try adding -V (upper case) to the end of the install command, if forces the command to be verbose, so you can see things going on. Eg: sudo gem install rails -V


56

It'll take quite some time to install rails - there are lot of dependencies and these need to be downloaded - if you have a slow connection, just wait for a bit.


19

Method 1 – railsready If you don't want to do everything manually, you can use the railsready script, which will install for you: An updated system (Linux only) Ruby 1.9.3 latest patch level (installed to /usr/local/bin/ruby) or RVM running 1.9.3 latest patch level Imagemagick libs needed to run Rails (sqlite, mysql, etc) Bundler, Passenger, ...


7

You should use apt-get If you care about uninstalling gems with their dependencies. RubyGems will not uninstall unused dependencies. See do-i-have-to-manually-uninstall-all-dependent-gems. If you care about uninstalling gems as a group, rvm is also an option (see below). If that gem would or should install executables in /usr/bin. If you want to upgrade ...


7

From: Don’t be terrified of building native extensions! - Pat Shaughnessy The native extension is some C code that’s included inside the Ruby gem that calls the external component’s API, converting the parameters and return values between the format the external library needs and what the Ruby interpreter expects. The Xcode installer package contains ...


6

The problem will be that you didn't start Apache as root - by default on any unix based operating system only root can bind a process to a port below 1024. Your choices are to either use a port higher than 1023 and remember to specify it when you connect, or to ensure that you start Apache as root. Unfortunately not being a Mac user I can't provide details ...


6

I struggled with that as well. Just use: vagrant plugin install any-plugin


5

Try using Homebrew and/or RVM RVM allows you tO have several versions of ruby installed if you want. Homebrew is a nice package manager for Os X.


5

If you are using Passenger, then it's monitoring the timestamp of the tmp/restart.txt file to trigger restarts.


4

You should always use RubyGems to install any kind of Gems (eg. Rails) to reduce confusion. Ruby on Rails: gem install versus apt-get


4

Install Ruby Version Manager! Seriously! I wish I would have done this sooner. Ruby Version Manager makes it possible to run multiple versions of Ruby, each with their own set of gems, and switch between the different versions seemlessly. Plus, you won't have to use sudo anymore. Plus, it's super easy to install, so you should do it!


4

Personally, I gave up on getting 1.9.2 running with Rails 3 & Heroku for the time being. However OSDIR mailing list mentions below instructions $ rvm remove 1.9.2 $ rvm package install openssl $ rvm install 1.9.2 -C --with-openssl-dir=$HOME/.rvm/usr


4

Does this help? Go to my System Preferences.app and open “Sharing” pane. Disabling the Web-Sharing service. Launch Terminal.app and stopping httpd (apache) with the following command: sudo apachectl -k stop Going into the Activity Monitor.app and searching for “httpd”. Select both processes and click on “Stop”. Shutdown and start ...


4

As mentioned in my comment, first make sure that both ruby and gem point to the RVM-installed versions, and not the ones in /usr/bin. Also make sure you use your new Ruby as default: rvm --default use 2.0.0-p247 Create a Gemset (called gemset) that will be used for this Ruby version: rvm use 2.0.0-p247@gemset --create --default Then install Rails to ...


3

Updated to the latest version of rvm rvm get stable and then ran rvm reload rvm reload which seems to have solved this issue.


3

Virtualization of an OS is always going to come at a cost. Performance of the VM is not going to be exactly like the performance of the host OS, and on top of that there's the variable of how many resources you allocated to the VM (number of CPUs, amount of memory).


3

Your ruby version is fine, 1.9 is still a little experimental and there are a number of libraries that don't work quite right with it yet. You'll also want to upgrade ruby gems itself, and seeing as you have quite an old version you'll want to use these two commands: sudo gem install rubygems-update sudo update_rubygems Which should install ruby gems ...


3

This is how you do it, tar cfz target.tgz --directory=TARGET_DIR subdir_list In your case it would look like, tar cfz target.tgz --directory=app/c3ec2057-7d3a-40d9-9a9d-d5c3fe3ffd6f/home/tmp export/


3

Have you tried using Tab? gedit myTabviTabuTabshTabhtTab Enter or such depending on how well your folders are named.


3

Remove the .gem folder in your $HOME folder will fix this.


3

Ruby installs on Debian/Ubuntu don't seem to generate the symbolic /usr/bin/ruby link to the specific install you have (theoretically, so that you can have multiple versions installed point to whatever version you want to use as your default). so... sudo ln -s /usr/bin/ruby1.9.1 /usr/bin/ruby should get you rolling. If which ruby1.9.1 is returning a ...


3

This issue has recently been fixed. Run rvm get head and you should be able to set a default gemset and have it persist across Terminal sessions. More info is here: https://github.com/wayneeseguin/rvm/issues/710


3

You might need to change your /etc/gemrc or /root/.gemrc. The default is set to gem: --user-install Which does exactly what you observed. You can use gem install --no-user-install rails See Arch Wiki: Ruby. install-packages-through-apt-get-or-gem is about the decision to use a package manager or gem. Using pacman is the same as using apt-get in this ...


3

What to do with a Ruby git repo depends on what is in it, and usually described how to use it by the README. In this case, the repo is for a gem, and it does not contain any Rails server examples or Rails projects. Unless you have a specific need to use the github version, you should just use the version from rubygems.org Ignore your cloned item for now, ...


3

Looks like the rvm installer is trying to run apt-get to install missing dependencies, we can fix that by pre installing them. Try running this as root: sudo apt-get install curl bison build-essential zlib1g-dev libssl-dev libreadline5-dev libxml2-dev git-core And now try running your install command again as the Jenkins user.


2

The snippet to insert <%= selection %> is actually part of the Ruby TextMate bundle not the Ruby on Rails bundle. You might want to reinstall the Ruby bundle. If that doesn't work go into the Bundle Editor and look at the snippets under the Ruby bundle.


2

try to add -V (upper-case) in the parameter, to show more detail of what is downloading if it still very slow or pending somewhere, it normally indicates a low internet connection to the rubygems.org site(showing in the output window). you can try to update the source of the gem using, by gem source -r https://rubygems.org/ gem source -a "your new source ...


2

I struggled with the readline problem as well. Turns on the problem was not having the right pre-requisites. I solved it by making sure everything was installed: sudo apt-get install build-essential bison openssl \ libreadline6 libreadline6-dev curl git-core \ lib1g zlib1g-dev libssl-dev libyaml-dev libsqlite3-0 \ libsqlite3-dev sqlite3 ...


2

That's typical on a Macbook; the power supply is at the back-left corner. It's nothing to do with Rails or Postgre. Just try watching a video on YouTube or playing a 3D-heavy game. You'll fry your left knee! My preferred solutions are as follows: Sit the Macbook on a table. Put a large book (world atlas) between the Macbook and my flesh.


2

at the sort of usage levels that the average server has - no it won't make much difference in terms of performance. If you have postgresql talking to a web server/scripting language platform on the same box, you can simply not open the port to the outside world Having your DB running all the time is fairly standard in the server world - so its unlikely for ...



Only top voted, non community-wiki answers of a minimum length are eligible