Tag Info

Hot answers tagged

22

The old school way is to open a terminal and use mail at the prompt, then d to delete one message or d1-4 for for four messages. Then q to quit. If you don't want to delete them unread, just type Enter at the mail prompt and it'll show each message in turn. Use man mail for all the details. Of course, other more sophisticated mail ...


19

In your ~/.bashrc add: unset MAILCHECK


13

OK, here is a quick explanation of one way to do this. It requires setting up a macro in the Outlook VBA editor. If you have never done this before, there is a bit of setup that you'll have to trudge through first. (Note that, while creating macros for Outlook is not hard, there are several places where mistakes can happen which can lead to confusion and ...


10

Sendmail requires that the result of "hostname" be a fully qualified domain name to start cleanly. Set the hostname to something like piotr-probook.localdomain and update /etc/hosts. /etc/hosts 127.0.0.1 piotr-probook.localdomain piotr-probook localdev localhost


7

I think just for the "services" google will provide: Bandwidth, redundancy, energy to power the darn things.... it is a no-brainer to use Google Apps (or some other hosted email quite frankly). My opinion: Unless you have some strong need to keep your email locally managed (say HIPAA regulations or something similar) - you are better off having it taken ...


6

If you're having trouble configuring the standard mail programs, you can use a command-line SMTP client such as sendEmail. Along with the address, message, and other data, simply specify an SMTP server. You can use GMail along with a username and password for example. Here are the available command-line switches:


6

First the essentials: Read the relevant RFC:s such as RFC 5321, and make sure your mails conform to it, Don't leave out any headers such as Date: Subject: or From:, and carefully read the format details of the From: field. Just an email address is not valid anymore. Double-check that the From: address used is a valid address that you can receive mail to. ...


4

I ran into this recently. You can change the address with the generic maps as davidgo mentioned. In /etc/postfix/main.cf Add this line smtp_generic_maps = hash:/etc/postfix/generic And then in /etc/postfix/generic Add the line for the originating email address, and the email address you want it to appear to be from root@system.fqdn ...


4

Should I change my hostname on the machine to mysubdomain.mydomain.com? Normally, SPAM filter take apart of the domain name, the IP originating the spam (in some cases even the entire ip block or the ASN completly, check UCEPROTECT and Whatsmyip.com blacklist check) What other things do I have to do with the DNS to prevent my email from going into ...


4

mail is a mail user agent (MUA), you also need a mail tranport agent (MTA), such as postfix, to deliver non-local mail. The MTA has to be configured appropriately, many ISPs require that mail be routed through their mail servers. This usually means configuring your MTA to treat theirs as smarthosts or relays rather than attempting to deliver mail directly ...


4

I would advise to use sendEmail: sendEmail-1.56 by Brandon Zehm <caspian@dotconf.net> Synopsis: sendEmail -f ADDRESS [options] Required: -f ADDRESS from (sender) email address * At least one recipient required via -t, -cc, or -bcc * Message body required via -m, STDIN, or -o message-file=FILE Common: -t ADDRESS ...


3

Most probably your ISP is blocking port 25. Call to service desk (hopefully you can reach technician who really knows something). It's also possible that your firewall (if you have firewall at all) is blocking that. It's unlikely that you are blocked by Google if another server is not working either.


3

I managed to solve the same problem. I just removed the permission to "Send on behalf" on the ESM - Exchange 2003 (the target sender was a public folder). Then on the public folder "directory rights" I added the sending user with the "Send As" permision. Worked quite well! Hope it helps!


3

You can just remove the messages from /var/mail/<user>, but you might get more, for example as the result of cron jobs. You can instead have this mail redirected to the normal place you read and store mail on your machine with a .forward file. Simply create a file called .forward in /Users/<username>/ which contains the filename you wish the ...


3

I tested Postfix 2.7.1-1 (Debian) and none of those work as you described. cat is not executed. (And to be honest, I can't imagine any possible reason why would sendmail execute an arbitrary part of its argument just because it happens to say "cat".) Sure, if you strace the sendmail process, you might see the file /etc/passwd being open()ed, but that's ...


3

Google apps is probably one of the nicest e-mail related services available anywhere, although it certainly lacks features needed by Exchange or Notes people. The benefits of your own server obviously relate to you having complete control over everything. A server on a home network is no place to keep important stuff running unless you're really good with ...


3

Sometimes the sendmail process refuses to die even if you have removed sendmail, and that could cause such issues. In your case, just see if you have an existing sendmail process $ sudo service sendmail stop $ ps auxwww | grep sendmail If you find one, kill it and the 'No such file..' error should go.


2

Please refer to this link. It's for Office 2007/2010 but may also apply to 2013 (assuming you mean 2013). Be sure to backup your registry first! http://www.msoutlook.info/question/271 Don’t accidentally send via CTRL+ENTER or ALT+S Sometimes I hit CTRL+ENTER or ALT+S by mistake and off goes the message as it is Outlook’s shorcut for the Send button. Is ...


2

MX Toolbox is your friend. Do a mx:mysubdomain.mydomain.com, blacklist:mysubdomain.mydomain.com, and ptr:mysubdomain.mydomain.com search using their supertool to diagnose mail issues. AOL, JUNO, and YAHOO (maybe more, but those for sure) require valid PTR records from the sending email server in order for mail to be delivered to their users. I have noticed ...


2

The mail terminal program should do the trick. It usually works "straight out of the box" to allow users/programs to send messages locally, inside the system. Type mail -s 'subject line' someone@gmail.com and hit return. Then type your message and close/send using Ctl-D.


2

Probably your network provider is restricting outgoing mail, as it is frequently a sign of a spammer or a compromised machine. If you find the instructions from your provider for configuring an email client for their network, you should be able to configure sendmail (or other MTA) the same way. This will probably involve using your username and password to ...


2

You are missing the distinction between message contents (headers and body) and message envelope. You're invoking sendmail with message contents, but you aren't supplying the envelope. It's the envelope that controls delivery. Without it, the message cannot go anywhere. You don't say which sendmail command that you are using. Each MTS — Sendmail, ...


2

I see that you are using sendmail. The recommended MTA to use with Tuleap is Postfix. It could be working with sendmail but if you want to avoid any possible configuration difficulties just install postfix, it is the way to go: $ /etc/init.d/sendmail stop $ yum remove sendmail $ yum install postfix -- Martin


2

Everything is wonderful about Google until something is not. If you aren't paying them, 'support' consists of forums where actual Google personnel are rare beasties. Now, you may well go years without running into some snag where you want support. Your chances of having some horrible mishap with self-hosted mail are probably much higher. There is, on the ...


2

Basically, make sure that you are not doing the stuff that may trigger spamfilters, like: Including URLs Incorrect/untypical headers (for instance, include html-version but not plain-version) Sending e-mails to several users Include content that triggers spamfilters etc. I suggest that you find a spamfilter expert on how to avoid this, so that you can ...


2

You should be able to configure debian reportbug to use your ISP's mail server to send outgoing mail (I have comcast and they even allow me to create an extra email address to use).


2

I have all my Debian systems with the default exim4 MTA configured as a "satellite system" of my ISP's outgoing mailserver (I stay well away from sendmail after previous experiences on RedHat). I have no problems using reportbug or anything else which expects to be able to send mail via a service on localhost. However, it does mean things like cron logs ...


2

Thanks for the help aking1012, and thank you parallels forums: http://www.forum.psoft.net/showthread.php?t=13231 This was actually a DNS issue. Our nameserver had a wildcard ('*') entry that resolved to our domain. When I ping'd a non-existent domain on any of our servers, it was resolving to our domain again. I took out the wildcard entry in the DNS Zone ...


2

You want to use the MASQUERADE_AS feature in your sendmail.mc file: MASQUERADE_AS(`javawag.com') Make sure javawag.com is listed as a local domain (although you presumably already do that). You may also need FEATURE(`allmasquerade') and/or FEATURE(`masquerade_envelope'), depending on your setup; see the sendmail documentation for more information.



Only top voted, non community-wiki answers of a minimum length are eligible