Tag Info

Hot answers tagged

46

I had added my user to the vboxsf group: sudo usermod -aG vboxsf $(whoami) I did do a restart, but after logging out and in again, I got access! Restarting after this and it still works. Go figure.


33

In Windows Vista or Windows 7, you can create a "junction folder"/"Symbolic link" to redirect the contents of one to another. Simply type: mklink /d "c:\data\network docs" "\\server\shareddata\" I have not tested it with a FQDN, but as far as I can tell, it should work. I have tested it with a network mapped drive, and this works perfectly... so at a ...


24

Make sure that the additions are installed, and that you have added your username as a member of the vboxsf group (sudo usermod -aG vboxsf <your username>). Then you need at least to log out (or reboot) for the change to take effect.


24

There is no way to do this with the Guest extensions, however, setup normal Ubuntu file sharing on your guest and you can access the files using the virtual network between the host and the guest. The OSE version of VirtualBox doesn't have shared folders, and this is the recommended sharing method for VirtualBox as described here. How-To Geek has a tutorial ...


20

There are several ways to accomplish this. You can use VBox's own Shared folders feature. For this: Go to Settings of the Virtual Machine and then select: Shared Folders. Click on Add Shared Folder button. Specify folder path and folder name. In Virtual Machine you go to \\vboxsrv\ you would see your folders. You can also Create a network share and ...


17

To view a list of all shared folders Click the Windows button Right-click Computer and choose Manage (requires administrative priveleges) Traverse to Computer Management > System Tools > Shared Folders > Shares To disable file sharing Click the Windows Logo button. Type file sharing in the search results window, and then touch Enter. Under "File and ...


15

Some parts of VMWare Tools will silently fail to install unless they can compile a kernel extension. That requires a compiler and the generic headers for the current kernel, so install those: sudo apt-get install build-essential linux-headers-$(uname -r) And then run sudo vmware-config-tools.pl


11

The VirtualBox shared file system (vboxsf) doesn't support POSIX permissions per se; rather, they are "set" at mount time: $ mount ... dropbox on /media/sf_dropbox type vboxsf (gid=1001,rw) The gid bit specifies the group that owns the directory; on my system, this happens to correspond with the vboxsf group. You can alter the user and/or group ownership ...


11

I don't have much experience with docker so I can't promise this will work but one choice would be to mount the directory instead of linking to it: $ cd projects/app1 $ mkdir shared $ sudo mount -o bind ../shared shared/ That will attach ../shared to ./shared and should be completely transparent to the system. As explained in man mount: The bind ...


10

In Ubuntu this should auto-mount shared folders under /media/sf_share_name. I've had permissions issues with the auto-mounts and still use the fstab.


9

I ran into the same problem on Vmware fusion 4 a few days ago using Ubuntu 12.04 as guest (Mac OS 10.6.8 as host). The short answer (my solution, at least) is DON'T install VMWare Fusion's supplied VMware tools; they don't work. instead, use Ubuntu apt-get (or the Synaptic user interface) to install open-vm-tools, the open source version of the vmware ...


9

Use pushd to create a virtual drive: pushd \\UNC\path And to unmap the virtual drive and return to your previous local path: popd


8

The first rule to remember is that with almost all versions of Windows, in a single session, you can only be authenticated to a server with a single set of credentials. So if you already had a mapped drive, a shortcut on the desktop or something else, then you are already authenticated to that server. One think you can do is drop down to a shell prompt, ...


8

Note: If the computer is part of a domain, this does not apply as the admin shares are automatically enabled upon joining. To enable the admin shares for computers in a HomeGroup or Workgroup, you must first ensure that File and Printer Sharing is enabled: In the Desktop, right-click the Network icon in the system tray and click Open Network and Sharing ...


8

While Saving as... Choose under Tools, General Options and check the Read-only recommended checkbox. This will not put the document always in read-only but when it is opened, the user is prompted to answer with which state to open the document. This is the way I prefer to save my documents in a shared folder. Doing so, someone can open the document without ...


7

First you need to configure the shared folders in VMware Player, as you said you've done. Let's assume you named the shared folder Shared. Then, on the linux guest, add a line like the following to /etc/fstab: .host:/Shared /mnt/C vmhgfs user 0 0 This will make the host folder that you named Shared accessible as the directory /mnt/C on the ...


6

In my case the following has helped: update to Virtual Box 4.3.8 r92456, reinstallation of VirtualBox Guest Additions from virtual CD (not from apt repository), reboot of virtual machine. System information: Host: Windows 7 Home Premium 64-bit, Guest: Linux Mint 16 Petra 32-bit.


6

I had similar problems and found that my fstab wasn't auto mounting for some reason, whether I had the Auto mount checked or not. So I tried this approach instead and it worked fine: Create a directory to mount into (if you haven't already): mkdir -p /mnt/path_to_mount_point Edit your rc.local file: nano /etc/rc.local Append the following line and save: ...


5

As described in here: https://www.virtualbox.org/manual/ch04.html#sf_mount_auto With Linux guests, auto-mounted shared folders are mounted into the /media directory, along with the prefix sf_. For example, the shared folder myfiles would be mounted to /media/sf_myfiles on Linux and /mnt/sf_myfiles on Solaris. Then it's also said that: Access ...


5

Go to Start, right click Computer and choose Manage. On the left side of the Computer Management window that appears expand the Shared Folders node. There you have three options: Shares shows you the folders currently shared on the machine Sessions shows you who is connected to those folders Open files shows who has what files open To have a history of ...


5

I had the same problem. I downngraded my version to 6.0 (6.1 might work) but read this thread: https://communities.vmware.com/message/2313778#2313778 scroll down to the official answer. The simplest maybe to downgrade back to 6.0.1 tools for now until this gets addressed in the next release of tools. Or as another user stated earlier in the thread, ...


5

This happens to me all the time, usually when I copy a text file generated on Windows over to my Linux server via a network share managed by samba on the server's side. Hastur is right, in the comments, and Joe Sewell in his answer, too: it's just the 'executable' permissions flag is set. My solution is: chmod u-x,go+r filename This makes it ...


4

This issue has come up repeatedly in the Docker community. It basically violates the requirement that a Dockerfile be repeatable if you run it or I run it. So I wouldn't expect this ability, as described in this ticket: Dockerfile ADD command does not follow symlinks on host #1676. So you have to conceive of a different approach. If you look at this issue: ...


4

This happens because of the way the Access Control List is queried by Windows Explorer to determine if the folder is shared. because this folder you tried to delete is a child folder of a parent folder and the two folders have a different security entries, Windows will treat as a shared folder. This causes Explorer to give you the warning that you received. ...


4

As I can see from your description you want to share a directory.Since you use Windows 8 and I can see the "Security" tab you are using NTFS-filesystem. It seems like you didnĀ“t configure NTFS-permissions. Click on the "Security" Tab of the Folder you want to share. Then "Edit..." In the new window click "Add..." In the new window click "Advanced..." In ...


4

According to this blog post, the first argument after vboxsf (share in this case) should be the label you've given the folder in the Virtualbox Manager. Since I called my folder "C" in the Virtualbox Manager, I was able to mount the folder with: mkdir C sudo mount -t vboxsf C ~/C However, this method requires the drive to be remounted after start-up. ...


4

Linux limits are defined in the smb.conf file: Example: max connections = 10 Mac OS X has a limit of 10 (unless you have the server version): In Mac OS X version 10.0 or later, Personal File Sharing is designed to serve a maximum of 10 users. If you need to connect more users at once, you should upgrade to Unlimited-Client version of Mac OS X ...


4

Good question. The bad news is that, unlike VirtualBox or VMWare that allows you to define "Shared Folders" which are directories on your host that are exposed to the guest, Windows 8 Hyper-V does not provide such feature at all. The good news is that, since there is not such feature provided out of box from Hyper-V at all, there won't be necessary ...


4

The simplest thing for the future is to share the link to the folder instead of the file itself that way you can change the contents inside the folder without having to change links. Just have a folder per file.


4

Even if you have the proper permissions you must disable 'Password protected sharing' to allow 'Everyone' (Guest) access to the shares. The quickest way to do is to right click any folder, choose 'Sharing', then 'Network and Sharing Center', then 'All networks' and finally 'Turn off password protected sharing'.



Only top voted, non community-wiki answers of a minimum length are eligible