New answers tagged

2

That GoDaddy! tutorial seems a bit odd in my humble opinion. There is utterly no reason to use sudo with git since all Git is really is a version control system. So I believe your core problem is Git is not installed on your system to begin with. To solve that just connect to your server via SSH and run this command: sudo yum install git-all Then once Git ...


0

It appears that the version of putty (.63) was the problem on this machine. Updating to .67 seems to have solved the problem.


0

Yes, I have seen this a lot of times, but not that often for SSH. For console connections it is most likely due to incorrect baud rate. Something similar happens in the case of SSH, but not related to transmission rate, but compatibility. It can be character encoding or even encryption type incompatibility. In the character problem case, which is the ...


1

I think you can try this: ssh user@host -t 'export var="value"; bash'


0

You can either "Optimize connection buffer size" or increase the "Timeout" for "Server response timeout" in the "Connection" tab in WinSCP to a large number like 2-3 mins. This solved the issue for me.


0

Create a script as below: # !/bin/bash read -p "Enter target server IP : " server echo "Enter root password for $server : " ; read -s password yum install sshpass -y sshpass -p "$password" ssh -o strictHostKeyChecking=no root@$server echo "your text goes here" >> /remotefile.txt


0

If you are using syslog or rsyslog each has a cooresponding .conf file. if ( \ $msg contains 'error' and $msg contains 'OUT=' \ and $msg contains 'SRC=' and $msg contains 'DST=' \ and $msg contains 'PROTO='\ ) \ then -/var/log/messageshere.log Obviously you can add more,less, or different conditions. You can even ...


0

Figured out an answer for the rest of internet (and myself). Here's how to achieve port forwarding with only netcat (verified working on OS X El Capitan): On server behind (incoming) firewall: nc localhost 22 >& /dev/tcp/<your-hostname>/<open port on local computer, i.e. 9000> 0>&1 On local computer: cd /tmp; mkfifo backpipe ...


0

Using the ssh configuration file is also a valid option. Here's what you can put/add to your ~/.ssh/config file: Port 10022 Cipher des You can also filter these parameters by remote host by prepending these lines with Host xyz.domain.whatever and indenting them: Host 192.168.1.15 Port 10022 Cipher des


0

Have you tried to use "grep"? The command that could help you is the following: tail -f console-20160622.log | grep "INFO" GREP will filter the log lines and just will show these that contains the "INFO" string


0

It doesn't make any sense the provider sends this key to you. The ~/.ssh/authorized_keys file in your profile, which can be read by anyone who has root access to that server, contains public keys, one per line. If you have the matching private key for one of the public keys, you can login. The private key is called private because it is yours; you are the ...


0

They should defiantly add a feature to disable this popup. We have thousands of wireless CPEs that we'd like to be able to script batch settings changes via SSH. The settings we want to change are not available for batch processing in the platform management software offered by the manufacturer, however, it can be done via SSH and scripts... These devices ...


-2

There is a famous saying that "The Internet interprets censorship as damage and routes around it" You have mentioned some of the tools that have been used to do that rerouting, usually by hiding inside some other form of networking communication that is not censored. At least not yet. That's why its often referred to as tunneling. To cover all the ways ...


3

From http://www.linuxquestions.org/questions/linux-newbie-8/how-to-configure-ssh-to-allow-or-deny-specify-host-ip-address-610246/ Add sshd: 116.31.116.20 to /etc/hosts.deny


1

sshd -T -C user=david,host=localhost,addr=127.0.0.1 \ | grep -E 'gatewayports|allowtcpforwarding' should return correct values for your user.


0

Eventually I made some tweaking to my script so that it essentially runs continuously and starts logging when it loses connection, instead of looking for a lost connection: https://github.com/NobleUplift/NetCheck But really, we just needed to switch ISPs.


0

For me it was the combination of sudo and tmux that stopped it detecting the SSH session. (It also affects screen the same way - this is a known issue listed in man molly-guard.) I solved it by adding this to the sudoers config file (using the visudo command): Defaults env_keep += SSH_CONNECTION


0

I'm using the following shell function: ssh() { local possible_keys=($(/usr/bin/env ssh -G $@ | grep '^identityfile' \ | cut -d " " -f 2- | sed -e "s|^~|$HOME|")) for k in $possible_keys; do if [[ -f $k ]]; then local fingerprint=$(ssh-keygen -lf $k) ssh-add -l | grep -q "$fingerprint" || ...


0

In addition to the solution of Germar, I had to add a custom rsync flag in the profile settings: Go to "Export options" Check "Paste additional options to rsync" Add --rsync-path=/path-to-rsync/rsync in the text field beside On my Synology station rsync is located at /bin/rsync.


0

Zerotier seems to perfectly fit your use case: They call it "Software Defined Networking". It's kind of a mix between a VPN and services like Hamachi. Basically, you have to ability to create networks (that have unique IDs), to which you can connect and authorize devices. It's a P2P network, but can use super nodes if your network doesn't allow inbound ...


0

I have been in this exact scenario before. Luckily, I'm friends with my high-school's IT guy, and he helped explain it to me. Ethernet cables have 8 pins (copper wires), each designated for a specific purpose. Namely, 2 cables: Data-in and Data-out. The problem with connecting 2 devices directly via a single Ethernet cable (I call this set up P2P Networking ...


1

You got to the command line (command interpreter shell) of a stripped down copy of Linux or other Unix-like OS. Most Unixes have an arp command for working with the ARP table. To enter a static ARP mapping for your host, you most likely need to type: arp -s IPAddress MACAddress (Replace IPAddress and MACAddress with the correct addresses of the machine ...


0

Alt-F6 did not work for me. But I found that I was using tmux. To detach the other window use a combination of list-clients and detach-client: % tmux list-clients /dev/pts/1: 0 [64x160 xterm] (utf8) /dev/pts/39: 0 [39x143 xterm] (utf8) % tmux detach-client -t /dev/pts/39 Since the 64x160 is larger, I figured that was my window while the other client was ...


0

I had to convert my .ppk to openssh sudo apt-get install putty-tools puttygen id_dsa.ppk -O private-openssh -o id_dsa Thanks to this answer.


2

The same way you do it, assuming you use port forwarding. If you try to login to your raspberry from remote, maybe even with a false password, you should see a very similar line in auth.log. Of course, you will connect to your public IP address which is assigned to the external interface of the router. I assume that you established port forwarding in the ...


2

What router do you have? I would try to check your router configuration under Wifi for Network Segregation. Can you ping from your laptop via WIFI to your phone for instance? Edit meant AP Isolation, sorry was on the right menu, wrong term. Network Segregation is used to separate different networks, one Wifi from another, or Wifi from cable


0

No, you can't. The point of SSH is that it is Secure Shell. If you don't want to use encryption, use rsh or telnet (as it was used decades ago), but note that they are not safe and anyone in between can read your passwords over this channel. Authentication using RSA only is not possible with the above mentioned protocols, but that would not help you. Still ...


0

Confirm that the SSH versions at host and Cisco ASR match ( either version 1, or 2 at both ends) Try ssh from putty Try again after closing all other access connections like telnet and console. Make sure the modulus value is a power of 2. Try a value around 2K or less


1

These are the supported characters which provide various options with which you can play around with ssh. Supported escape sequences: ~. - terminate session ~B - send a BREAK to the remote system ~R - Request rekey (SSH protocol 2 only) ~# - list forwarded connections ~? - this message ~~ - send the escape character by typing it twice (...


0

TCP connections have two ports, source and destination. For outgoing SSH connections, the destination port is 22, but the source port is chosen randomly. (Only very few protocols, e.g. BGP, use identical source & destination ports.) Therefore you would need to relax the rules to: allow incoming from hostIP (any)/tcp to guestIP 22/tcp allow outgoing ...


0

Figured it out by myself yesterday, and Spiff is correct too. I was testing the ssh connection by using the same internet connection. Tested it from the other network and it worked.


1

The following answer is based on mobaXterm Personal Edition v7.3. Settings -> Configuration -> General -> MobaXterm passwords management -> Automatically save sessions passwords Select Always


0

After SSH, run nautilus as follows: nautilus --no-desktop ...which tells nautilus not to manage the desktop, as per the nautilus man page. Works fine for me after that. man nautilus


1

Several things come to my mind. The forwarding in your screenshot looks OK. You could try to set it to TCP instead of TCP/UDP, because ssh is a TCP protocol. dyndns Are you sure that you use the correct dynamically updated hostname or your correct public IP address? To find your public IP address, open a console on the Raspberry or SSH (internally) into ...


0

Log-in to Amazon Web Services and check the followings: Security Group for your instance is allowing Inbound SSH access (check: view rules). For VPC instance, check its attached Route table which should have 0.0.0.0/0 as Destination and your Internet Gateway as Target. Double check your route info in System Log in Networking of the instance. For more ...


3

The client reports the sha1 hash of the server's key as a sequence of 16 pairs of hex digits, like this: a7:b1:3e:3d:84:24:a2:5a:91:5f:6f:e9:cf:dd:2b:6a This is MD5 hash. As you can see running ssh-keygen -l -E md5 -f ssh_host_ecdsa_key.pub will get you the same fingerprint you need without such harakiri you are explaining in your answer.


0

As it turns out, the SSH Cookbook has a way to manually generate keys in the older hex format. I used this on the freebsd server. awk '{print $2}' key.pub | base64 -d | md5 | sed 's/../&:/g; s/: .*$//' Breaking this down: awk '{print $2}' key.pub print out the second (space separated) column in "key.pub", which is the key itself base64 -...


0

Solved. Very newbie mistake! The Raspbian was on a different netmask: 255.255.255.0 And my PC wa on 255.255.255.0


2

GnuPG and SSH serving different purpose within the git environment: SSH is used to secure the connection by encrypting it, but also providing authentication (thus, allowing access to a repository). GnuPG on the other hand allows you to sign commits and tags/releases. This allows others to make sure the commit has really been issued by you and not somebody ...


0

This is known problem with planned fix for openssh-7.3 (draft standard). Before that will be fixed in your distro, there is workaround to run manually (or in some of your login scripts): stty iutf8 which will set your tty flags to utf8, as your local shell.


0

This happens because SSH won't exit if there are outstanding connections going through the tunnel/proxy. If I quit the browser (close all windows), SSH exits normally. All TCP and X11 connections need to be closed before exiting the SSH session. I found no options to change this, so I assume we can do nothing to prevent this behavior.


0

Just a silly question: Are you using the same IP address to ssh to this instance ? Because when you stop an instance and start it again, it gets a completely new IP address.


0

The ssh-copy-id command from OpenSSH fails if there is no private key file with the same name available, because it tries to login with the specified key to check if it is already present on the remote server. In recent versions you can overwrite this behavior with the -f switch ("Forced mode"). From the man page: -f Forced mode: doesn't check if ...


0

I just found a nice hiccup in my setup that prevented x forwarding: My firewall was blocking all connections from localhost, thus preventing the tunnel to be reached


0

Expanding on Harry's suggestion: Did you run "xhost +" on your local machine before you you ran env DISPLAY=:0 yourapp on the remote machine? Overall, using ssh -Y is more likely to work than ssh -X, but it is till worth it to try a plain setup where the X11 connection runs on an unencrypted side channel directly to DISPLAY :0.


1

Try -tt to see if it works. From ssh man page, Multiple -t options force tty allocation, even if ssh has no local tty.


0

I had the same issue. You can simply write this line plink 1.2.3.4 -l root -pw pass " myscript.sh arg1 arg2" For example, I had to run a script and give two files as parameters. plink 1.2.3.4 -l root -pw pass " myscript.sh path/to/file1 path/to/file2"


2

You can do both, basically. a) more keys You could go ahead and create keys on machine1 and copy the public key to machine2's /home/yourusername/.ssh/authorized_keys file. If you don't decide for the alternative below, I'd suggest this method. If someone gains your private key for machine2 on machine1, he still does not have your private key on your ...


1

My first attempt to solve this problem would be to open PuTTY select Session > Logging enable logging of SSH output to a file try to connect review the logfile What does the logfile say? Anything that points you into a specific direction? It could me messages ranging from "Connection timed out" to "Access denied". Connection timed out: Make sure you ...


0

I'm going to assume a few things: That the SSH server you're connecting to (FirewalledMachine) allows SSH tunneling. That the VNC service works at all (on FirewalledMachine). That localhost maps correctly on both machines. VNC ports start at 5900 for display 0, going up from there. So create a SSH tunnel during connection by changing your client-side SSH ...



Top 50 recent answers are included