New answers tagged

0

You can try PHPintel Install PHPintel using Package Control Create or open a project with PHP files Run the command PHPIntel: Scan Project command from the command palette After the initial scan, PHP files will be automatically re-scanned whenever you save them. https://github.com/jotson/SublimePHPIntel


0

On Windows, press CONTROL + R which lists all the functions in the file with the current function selected. Now, Press ENTER


0

In order for the Reindent feature to work, you have to uncheck the option for "Indent Using Spaces": View >> Indentation >> Indent Using Spaces Once this option has been unchecked, you can select your text and Reindent: Edit >> Line >> Reindent This will work for HTML syntax as well as XML. Not tested it on any others.


0

So, the easiest way to do this (aside from writing a rather extensive plugin) is by macro. Here is swap_line_down_and_indent.sublime-macro: [ { "command": "swap_line_down" }, { "command": "indent" } ] and swap_line_up_and_indent.sublime-macro: [ { "command": "swap_line_up" }, { "command": "...


-1

Even though the OP gives opening from CLI as an example, the headline seems to be worded more general. So here is a GUI only solution: Open a new Window, then in the "Project" Menu, just click "Open Project" instead of "Quick Switch Project" or "Open Recent". This way, you can re-open the same project in different windows as often as you want.


0

Save-All doesn't have default key binding in ST3 as well. When I press Ctrl+S I like to save all instead of current file. So I changed my key bindings as below. Open Prefrences > KeyBindings-User and add following two lines: { "keys": ["ctrl+shift+alt+s"], "command": "save" }, { "keys": ["ctrl+s"], "command": "save_all" }


0

On the top row of a QWERTY keyboard there is a button marked INSERT. Simply tap that button. It toggles between Insert mode and Overwrite mode.


0

I realise this is an old question, but I had a similar problem where all the text was too small; status bar, tabs, folder/file tree etc. The answer was to add "dpi_scale": 2.0 to my Sublime Prefs, as detailed here so you can just go ahead and open your user preferences (Preferences > Settings - User). Next, add the following line: "dpi_scale": 2.0. If ...



Top 50 recent answers are included