New answers tagged

1

When you add a new program to the path, you need to type rehash For it to be known to the shell.


0

As a fast fix you can make an alias. Add to you ~/.bashrc file this: alias main='/home/user/Downloads/program/./main' then run exec bash in your terminal and it should work. If you're not using bash something similar would work for other shells. For example writing to the file ~/.zshrc for the zsh shell.


2

It looks like you need to add that directory to your path. The exact command to do this depends on which shell is in use. For bash, you'll need something like: export PATH=$PATH:/home/user/Downloads/program/ Explanation: The PATH=$PATH keeps the existing path as part of the new path your are creating. The :/home/user/Downloads/program/ adds that ...


0

I ended up with the following solution: function is_sym_link() { readlink $1 > /dev/null return $? } It might not cover all cases, but for my environment it's sufficient. I don't know why the original didn't work, unfortunately.


0

I'd go with a more convoluted solution (since that suits my personality, but that's not important now...) for x in $(ls -lp|egrep ^[dl].*\/$); do case $(echo $x|cut -c 1) in "d") echo "This is a dir";; "l") echo "This is a link";; esac done Briefly, ls -lp prints long format with a trailing slash for all directories. The very first ...


2

The exit values from your experiment are correct. When the test utility evaluates an expression, if the expression evaluates to true, test returns a zero (true) exit status; otherwise it returns 1 (false). So, in your example, test -L ../Dependencies returns 0 (true) because ../Dependencies is a symbolic link. If ../Dependencies was not a symbolic link, ...


0

There's a light weight software called "Easy Symbolic Link" that makes them easy to create with a right click. Try it here: https://blog.afach.de/?page_id=589


-1

You need to enable local to remote links by running this command with elevated rights: fsutil behavior set SymlinkEvaluation L2R:1 Also you can enable this with your local or group policy: Computer\System\Filesystem\Selectively allow the evaluation of a symbolic link --> allow local to remote Best regards, Matthias


0

I tried mklink /D (or /J) dir1 dir2 I have a directory 'dir1' with some files in it and a directory 'dir2' where I'll add some files. You have the directories the wrong way around. You also need to remove dir2 before creating the link. The syntax for mklink is: MKLINK [[/D] | [/H] | [/J]] Link Target Note: mklink creates the link so dir2 should ...


0

I had the same issue; this seems to be caused by changing the install location of apps to another drive. What solved it for me was setting the save location for new apps back to C, and then rebooting into command prompt (hold shift while restarting) and deleting "System Volume Information\wpappsettings.dat" on the drive in question.


0

This works in win7. I haven't been able to try it in XP but I think it should work. del "%HOMEDRIVE%%HOMEPATH%\Desktop\test.lnk" Save it as a batch file and run it normally. If your account doesn't have administrator privileges you may need to right-click and select "run as administrator." You could also open cmd and just type it as a command.



Top 50 recent answers are included