Tag Info

Hot answers tagged

13

ssh does not support passing a password on the command line, it is interpreting the -pw as "Connect to port w". In order to do automated logins via ssh, use .ssh/authorized_keys: On the OSX terminal, create a key using ssh_keygen. If you accept the default filenames, your ssh client will automatically try this key when it connects. Copy the contents of ...


8

What you're trying to do is impossible with the built-in SSH client in OS X. The OpenSSH client is incapable of accepting a password from the command line. The reason you're getting the "Bad port" error is because the -p flag is used to specify the port to connect to and the -pw flag does not exist. See the man page for more details. Additionally, it's ...


3

On your command-line press Ctrl-u (it stores it in the kill-ring), issue the other one mkdir for example, and then press Ctrl-y.


2

add the path of the directory where your script is located to the PATH variable: export PATH=$PATH:/path/to/directory


2

Single quote starts a string, which may include newlines. Close it with another single quote and see what the command you entered does with the string. In most cases it will emit some sort of error, like "file not found" since it's rare to find a file with an embedded newline in its name.


1

It was waiting for you to finished the quote. If you type another ' it will complete the quote. You could then try the Home key or Control-A and see if lets you edit the line. The quotes can be useful when need to give names the shell will try to use, such as: touch 'Hello There' Will create a file named "Hello There". Without the ' it will create two ...


1

Use any editor to create the file .octaverc in your home directory, In the editor just paste the text setenv ("GNUTERM", "X11") below is optional; changes the prompt to two chevron and gets rid of the long Octave x.x.x >> prompt PS1('❯❯ ') You will find yourself in your home directory by typing $ cd ~ The path can be shown by $pwd That is ...


1

With the suggestion from @krowe about zsh, and some research, I think I have settled on Oh My Zsh in Terminator using the latter's Custom Commands plugin.


1

This can have several reasons: You might have an alias for tmux which sets special command line options or tmux on some machines does not start a login shell. You could check Why ~/.bash_profile is not getting sourced when opening a terminal? to figure out more. or You might have a code block like the following in one of your bash files: if [[ -n ...


1

export PATH=/path_to_folder_containing_executable/:$PATH If you don't want to run that every time you open a new terminal, you could always add that line into your ~/.bashrc. Good luck!



Only top voted, non community-wiki answers of a minimum length are eligible