Tag Info

Hot answers tagged

2

It turns out this is a GNU screen issue. See https://unix.stackexchange.com/questions/8439/gnu-screen-makes-vim-esc-key-slow Within screen, C-a : maptimeout 0 solves this. I'll be adding it to my .screenrc. Sanity preserved.


2

For a single file (like ~/.vimrc), I would configure the folding via a modeline; i.e. a special comment at the end of the file that Vim recognizes and sets the fold-related options accordingly. Note: I wouldn't use {,} as fold markers, as those also occur in Vimscript (to define Dictionary objects); better stick to the original ones: " vim: set fdm=marker ...


2

Search for plugins like local_vimrc -- I give a short list of alternatives at the end of the README NB: This is a recurring question: http://stackoverflow.com/questions/456792/vim-apply-settings-on-files-in-directory/ http://vi.stackexchange.com/questions/2094/how-to-make-vimrc-settings-applicable-for-a-directory-tree-only/ ...


2

Your regexp captures the complete input string abcde captures the 'e' and replaces that by \e. You probably want something more like this: :s/\S/\\&/g


2

You should use :setlocal filetype=cpp instead of :set syntax=cpp, but that still doesn't help you here. The problem is that 'iskeyword' is set in $VIMRUNTIME/syntax/forth.vim, but it doesn't use the b:undo_ftplugin mechanism to undo that when the filetype changes (to cpp), so the modified option persists. Fix A If you never need to edit *.fs files as ...


1

My SpellCheck plugin provides a command that populates Vim's quickfix list with all spelling errors. This is even better than dumping to a file in that you can quickly locate each spelling error. It also sets up mappings in the quickfix list to "remotely" correct / add to spell dict the mistakes.


1

Perhaps you could make that binding work in gvim, but not in vim running in a terminal, because you are unlikely to find a keyboard configuration which sends a different sequence of characters for control/Minus. As a rule, the control modifier affects only a few non-alphabetic characters. Here is a screenshot from vttest, which happens to illustrate the ...


1

I found the solution on this thread. It turned out that since 2011, vimrc_example.vim was updated to include this textwidth=78 rule as an autocommand, and my _vimrc sources vimrc_example.vim (probably because I based it on the original — which means this situation will apply for many users). One solution is to find the line in your .vimrc, that says source ...


1

These two do the same as ESC in vim, so one (or both) might work for you: Ctrl + [ ctrl + c ...the latter of which I prefer to use over ESC. Hopefully your keybindings include them.


1

This post has my favorite answer, https://coderwall.com/p/if9mda/automatically-set-paste-mode-in-vim-when-pasting-in-insert-mode Basically if you start in Insert mode and use Ctrl+Shift+V or right click paste with your mouse, Vim detects that this came from a terminal and automatically sets paste mode, then unsets it once done, so you don't lose remapped ...


1

I was able to install vim-airline for gvim on Windows platform. But you should be able to follow the same process for linux based OS as well and install it without any problem. NOTE: This installation procedure is manual. Do the following steps to install vim-airline: Click on download zip (https://github.com/bling/vim-airline) and unzip it. For Windows ...


1

Specifies intentionally untracked files in a file To solve this with a file like .gitignore (based in the Nathan grep solution), I created a file named .ctrlpignore and put the patterns that should be ignored, separated by lines: node_modules/ \.log$ ... And my ctrlp configuration: let g:ctrlp_user_command = 'find %s -type f | grep -v "`cat ...


1

I found this problem more easily solved by having my plugins listed in a separate file, vundle.vim. This avoids plugins and .vimrc settings which don't play nicely in Ex mode. set nocompatible " be iMproved, required filetype off " required " set the runtime path to include Vundle and initialize set rtp+=~/.vim/bundle/vundle/ ...


1

Based on this answer I was able to profile my setup, and found that the plugin github-issues was causing long slowdowns. I disabled the plugin and everything is now fine.



Only top voted, non community-wiki answers of a minimum length are eligible