New answers tagged

0

@ Fedor: close the running VM first; then go to settings for this VM in the Virtual Box Manager, chose network/advanced where you can change the adapter-type


0

Take a look here: http://askubuntu.com/questions/298290/smbus-bios-error-while-booting-ubuntu-in-virtualbox There are several options that have worked for people. I had exactly your scenario. After trying many things I did a reset from the VirtualBox menu and it booted. This was probably just luck.


0

I selected settings/storage and added a new SCSI controller to the virtual machine. In that controller I added an optical drive with BusLogic. After that I went to the start/settings/control-panel on win98 and added a new hardware. After a few tries and a restart, the win98 recognized the disc and I was able to use it. I managed to install my program after ...


0

Refer to this ticket in virtual box.org. Try this command: sudo /usr/lib/virtualbox/vboxdrv.sh setup Note: Disable secure boot before trying to load the modules.


0

Change the adapter setting from "NAT" to "Bridged". The 10.0.2.15 address is the NAT interface; in order to access from local network you need something that starts with 192.168.X.X (after you have activated the bridged mode). 192.168. is your internal network and only accessible from LAN. Run ifconfig (ifconfig | less if you don't have a scrollable ...


0

As it turns out, my firewall was blocking traffic from other IPs, and I need to add an exception to the firewall.


-2

Try and change the chipset in the settings, this worked for me some time ago when I had this error. Either the IDE controller chipset from PIIX4 -> ICH6 or the MB chipset from PIIX3 -> ICH9 or both. I always to use the newest emulated hardware. As for why it happens, I cannot tell you.


0

If NetworkManager is running, it doesn't matter what you have on your ifcg-enp0s3, so make sure it is dead: systemctl stop NetworkManager sytemctl disable NetworkManager ps auxww | grep NetworkManager kill <PID> (in case it is still running) After that, restart your network: systemctl restart network Then, check your ip address configuration ...


1

I was running into this same issue with VB version 5.0.18. It seems the ubuntu/xenial64 box was built with virtualbox 5.0.16. Uninstalling 5.0.18 and installing 5.0.16 worked for me.


0

You could try this: runuser -l lambda -c 'ls -la' Where ls -la is the command (example) that you want to execute as non-root and lambda is a normal user created like any classic normal Linux user account. You are a root who wants to use a normal account. As a root you don't need to give the normal account password.


0

One way to solve this is to install the OSX test build of virtualbox. https://www.virtualbox.org/wiki/Testbuilds


2

Use VMware Workstation to virtualize a physical machine. It comes with 30 day trial Convert VMware to Virtual box VM


1

It seems you're on a laptop, so tweaking Windows power options may be a solution: http://www.rawinfopages.com/tips/2015/05/speed-up-virtualbox-enormously-with-this-simple-tweak/ To quote: So it turned out to be a simple problem, partly caused by selecting the wrong power plan. Make sure that the High power plan is selected when running virtual machines ...


1

That means that your virtual machine doesn't support USB port connection. Actually, you can't work with USB or COM connections in any virtual environment. You will have to use additional software.


0

Even better, you can use you raw disk in virtualbox (see: http://www.serverwatch.com/server-tutorials/using-a-physical-hard-drive-with-a-virtualbox-vm.html ) For Linux: VBoxManage internalcommands createrawvmdk -filename ".vmdk" -rawdisk /dev/sda That should work. But be careful on not not deleting linux partition in the windows installer. And of course, ...


0

It depends on how your VirtualBox boot up. If your boot up through other bootable method not grub, you might fail. I am not sure, I considered.


0

If you're using NAT, then you'll probably need to forward ports at VirtualBox. You can look how to do it here It's very similar with routine port forwarding at your home router actually. Also, you need to be sure that your iptables config allows incoming SSH connections too, you can see how to check for that and enable it here. Then you can test connect to ...


0

I just setup ArchLinux using Windows 7 x64 as the host and initially used the Vbox packages provided by Arch. Got X going but no desktop resize. So to fix it I, Removed packages pacman -Rs virtualbox-guest-utils Shutdown guest Upgraded VirtualBox Windows app to latest ( 5.0.18 r106667 ) Upgraded VirtualBox extension pack Booted guest From the VirtualBox ...


0

What exactly are you trying to do here? You have a executable file for VirtualBox. Why is gedit and Vagrant involved? All you can really do with the .run file is to run it. Open a terminal and type: ./VirtualBox-5.0.16-105871-Linux_amd64.run


-1

Open registory editor (open RUN -> type regedit) then find for given key (key - aIID={0169423f-46b4-cde9-91af-1e9d5b6cd945}) change its permission and restart machine. If still not working then delete boot2docker.iso from "xxx.docker\machine\cache\" restart machine and try again. If above won't work then make sure that you don't have ...


1

I found the solution : disabling Intel Virtualization Technology in the BIOS. After that, I could installed VirtualBox with no problem. I enabled again the turbo options and the Virtualization technology in the BIOS in order to see if it's okay when I will running VMs.


0

In the Windows control panel, select programs and features, and then turn windows features on and off. In that panel, turn off Hyper V. That should allow virtualbox to run both 32 and 64 bit operating systems. After the install of Ubuntu, go to Virtualbox settings and make sure that external media is unset, just to be sure. If that doesn't work, please ...


-1

@Tom Yan Thanks, but for some reason, I can't comment on here. I have tried both running it in it's full path and using Package Manager located in Administration. My issue is that I installed Vagrant and when I type: vagrant up I get the following message: No usable default provider could be found for your system. Vagrant relies on interactions with 3rd ...


0

The following solved the problem in my case: I was seeing timeouts when pinging a Win7 guest from a Mac OS X host, and found that the adapter order definition mattered. The following configurations worked: * Adapter 1: Host-only * Adapter 1: Host-only | Adapter 2: NAT * Adapter 1: Host-only | Adapter 2: Bridged * Adapter 1: Host-only | Adapter 2: Bridged ...


1

A further examination of the source reveals they use automake, you can set the compiler using environment variables that the Makefile will use to compile the source. The location source is obfuscated. To find the full source you need to find the tar file appended to the end of the VBoxLinuxAdditions.run shell script and unpack it, it contains two tar files ...


0

You are trying to connect to the VM that's behind a NAT so, you need to forward ports of the NAT's router (just the same that you would do on a physical one). On VirtualBox go to: Archive > Preferences > Network > Add new NAT Network > Edit Adjust your options for your network and go to Ports forwarding Add a new rule looking like this: TCP ...


1

I figured out the issue in my case. After I did a simple test "ssh localhost" on the windows host I noticed it actually connected to another machine than localhost. That in turn made me remember that I had edited ~/.ssh/config some time ago, and checking that I noticed that I had forgotten to add a Host line which caused all ssh commands to go to the wrong ...


0

You can try adding more memory pressure to your system such that Windows pushes memory pages from RAM to the page file. The sysinternals testlimit program lets you allocate lots of memory (as outlined in one of Russinovich's blog posts), which should (hopefully) convince the memory manager to push data to the page file. Run the following and let it hammer ...


0

Okay, I've found the answer. Turns out this trivially easy. Just set up a bridged network adapter. That will allow your VM to be on your local network and talk to the outside world. Vagrant.configure(2) do |config| config.vm.network "public_network", use_dhcp_assigned_default_route: true end That's then reflected in my netstat, showing a new adapter ...


1

Remark: You can get more detailed timing information by using time curl -vvv site1.dev/. I note that the server reply contains Connection: keep-alive, which means that the server is configured to use HTTP keep-alive : HTTP persistent connection, also called HTTP keep-alive, or HTTP connection reuse, is the idea of using a single TCP connection to send ...


0

You can configure a dynamic virtual disk to be any size you want and VBox will not stop you. However, it will behave the same way most applications do when it runs out of disk space: It will crash. In the case of your situation, you create a virtual HD to be, say, 1TB in size. Fine. The Ubuntu installer will see a 1TB drive. But if the VHD grows to fill ...


1

Perhaps nginx is configured to do ip resolution of incoming requests and is taking time to resolve the incoming connection before actually answering the request. A couple pointers though, you'll want to check the following on 192.168.10.10. Verify name servers are correct within /etc/resolv.conf If #1 resolv settings are are correct for primary and ...


2

Be aware that CryptoLocker will encrypt any files it finds on network shares. Therefore, you should remove all virtual network cards from your virtual machine. (Don't just disable them within the guest operating system as this runs the risk of them being re-enabled by malicious software. I doubt cryptolocker does this, but it is still good security hygiene. ...


0

No - it can only encrypt files it can access - so provided it can't see any files outside the container its in, it can't harm the host OS directly.


0

My root (/) file filesystem was full on Guest VM with OS of Oracle Enterprise Linux (OEL) 7 created on Oracle Virtualbox. I believe similar steps should be present for other Linux flavors like Redhat, Fedora, CentOS or Ubuntu. To increase disk space I followed below steps: I powered off the VM. Enabled EFI for the VM settings in Virtual Box. Increase ...


-1

The most simple way is to use USB Flash Memory: 1- Connect your USB Flash Memory to your computer. 2- Your flash memory should get recognized to your virtual machine in: Setting > USB > Add new USB 3- Run your VB machine and go to removable drive as usual and explore your files.


0

The most simple way is to use USB Flash Memory: 1- Connect your USB Flash Memory to your computer. 2- Your flash memory should get recognized for your virtual machine in: Setting > USB > Add new USB 3- Run your VB machine and go to removable drive as usual and explore your files.


2

IIRC, when I last tested it, booting an EFI-mode Linux using VirtualBox was a few seconds quicker. EFI-mode booting also provides different native video modes, but those are only accessible for text-mode use or if you use the "fbdev" X11 device driver. Beyond that, unless you're involved in EFI development or are interested in testing or learning about ...


0

I think you've confused disk space and memory. You ran out of disk space, which you strongly suggested in your first screenshot. You did not run out of memory, as shown in your second screenshot. df -hT will report your filesystem disk space usage. You can figure out which filesystem filled up (most likely /). You can visualize what is taking up so much ...


0

Open an admin console on your windows7 host and execute the following: $ VBoxManage list vms Note that uuid or name in parenthesis of your VM and then: $ VBoxManage modifyvm --natdnshostresolver1 on


4

There are several ways that would work, the easiest is probably going to be clonezilla. It can make an image of your VM and then restore it to HDD. I personally use rsync to transfer Linux installs between devices, but that requires doing all your partitioning by hand prior to moving, and installing grub manually from a chroot after it's all copied, to the ...


0

There were changes in Build 14295.rs1_release.160318-1628 that broke Virtualbox, but the Virtualbox team are aware of the issues and the latest test builds have corrected this. This file works for me: https://www.virtualbox.org/download/testcase/VirtualBox-5.0.17-106344-Win.exe If you want further info see here: https://www.virtualbox.org/ticket/15245 ...


1

VirtualBox 5.0.5 and older cannot compile on Linux kernel 4.3 and newer. This was fixed in VirtualBox 5.0.6, released on 02 October 2015. From the changelog for VirtualBox 5.0.6: This is a maintenance release. The following items were fixed and/or added: Linux hosts: Linux 4.3 compile fixes The fix is to upgrade VirtualBox to version 5.0.6 ...


0

Had same issue. Discovered that right clicking empty space in the Menu panel will cause a subset bar to show up. Clicking on "Devices" will add it to the main menu bar. Don't know why it's hidden in the first place- wasn't in earlier versions of VM. Hope it works for you.


0

In VirtualBox, you can select which adapter the VM should use. The configuration of the networking mode depends on host OS setup as well as any router/DHCP/etc settings, but your setup sounds simple enough. Try "Bridged adapter", then select the physical adapter that has a WAN connection.


0

Update: I've found a solution that seems to work: I'm just using VMware Player now, it can do exaclty what I was looking for. In the VM settings in VMware, you can specify the virtual network you want to use. There, you should find two adapters, one of which is host-only, the other one NAT. Choose the NAT one. In Windows (network connections system control ...


0

The following works for me: Before: vboxnet0: 192.168.56.1 eth1: 192.168.56.1 After: vboxnet0: 192.168.56.1 eth1: 192.168.56.101 So, basically I changed part of the file { /etc/network/interfaces } as follows: Before: auto eth1 iface eth1 inet static address 192.168.56.1 netmask 255.255.255.0 After: auto eth1 iface eth1 inet static ...


0

Make sure you have your install application installed, as OS X does not include that by default. Also, you mentioned that you want to install El-Capitan, and the command: iesd -i /Applications/Install\ OS\ X\ Yosemite.app -o Desktop/yosemite.dmg -t BaseSystem Would turn an Install Yosemite app, that you had to also install before. You need to go to the ...


0

Just like clearly written in the tutorial you referenced, you need to: Download it for free from the “Apple App Store”. You do need a Mac with a valid Apple-id for this. So go to the App Store, search for OS X El Capitan and press Download button (make sure you have several GB free on your disk and time). It is not folder Install, but a whole app ...


0

In machine window: choose Devices from menu -> Optical Drives -> Remove disk from virtual drive Then reboot the virtual machine. (Alternatively you can go to machine settings in main VirtualBox window, select Storage tab, highlight the optical drive, click on a small disk icon, then choose to remove)



Top 50 recent answers are included