New answers tagged

1

The difference between running the script via systemd and running it directly it directly is the environment. You can test it like this. In your Unit file, add this to the [Service] section, for testing: StandardOutput=console Then in your bash script, at the top add this line to dump the environment: env Now run the script inside and outside of ...


0

What I do here to get the glyphs I need working on urxvt is to add more fonts in the font list: URxvt.font: xft:Ubuntu Mono:pixelsize=18:antialias=true:hinting=true,\ xft:Source Code Pro:pixelsize=18:style=medium:antialias=true,\ -*-unifont-*-*-*-*-*-*-*-*-*-*-*-* It is still not perfect, though. I still can't get everything ...


2

Use xdotool which can fake keyboard/mouse input, window management, and more. Sample usage based on the install_mt4-xdot.sh script which installs Windows app under wine: wine setup.exe & echo "Waiting to initialize..." while ! WID=$(xdotool search --name "Setup"); do sleep 2 done echo "Sending installer keystrokes..." >&2 xdotool key --window ...


0

After SSH, run nautilus as follows: nautilus --no-desktop ...which tells nautilus not to manage the desktop, as per the nautilus man page. Works fine for me after that. man nautilus


0

I just found a nice hiccup in my setup that prevented x forwarding: My firewall was blocking all connections from localhost, thus preventing the tunnel to be reached


0

This is not the best solution, but I'll post it anyway. Move your .config directory to a safe place where you will find. After that, try to login. If it fails, make sure that you move .Xauthority out of the way too. This is how I got it working. If by any chance you want your config back for a specific program, just copy safeplace/.config/...


1

There is no such option as x11forwarding in ssh_config (it is server option for sshd_config). It is ForwardX11 in ssh_config, as visible from manual page. Fix this typo in the /etc/ssh/ssh_config and it will work for you. You can also set up Host blocks: Host gitlab._____.____ ForwardX11 no in the ssh_config to disable that only for this host.



Top 50 recent answers are included