Tag Info

Hot answers tagged

3

According to the information presented in your question, your $PATH variable is set like this: ~ >>> echo $PATH ~/.local/bin:/usr/local/bin:/usr/bin:/bin:/usr/sbin:/sbin:/usr/local/bin:/usr/local/bin:/usr/bin:/bin:/usr/sbin:/sbin Not too sure where you are setting your $PATH variable but I believe using the ~/ is not going to work in $PATH ...


1

Did you try removing the dot-slash ./ from the beginning of the path? A . means the current directory, and putting it before an absolute path, like the one you are using, usually makes no sense. Try: { ~ } » "c:\Program Files\App\file.bat" - o files.xml or { ~ } » "c:/Program Files/App/file.bat" - o files.xml


1

In zsh, you can use the ** operator to do this: vim **/myfile.js Then press Tab and zsh will recursively search for the myfile.js file.


1

I'm hitting the control key then hitting h. Am I missing something totally obvious here? Yes. ^Xh → Control+X h


1

history is equivalent to fc -l which is in turn equivalent to fc -l -16 -1 See man zshbuiltins So if you want to see a larger range, supply it to the command. For example:history -1000


1

This seems to be already answered here. The response is issued by the command-not-found package, which you obviously already have, since bash is responding as you wish. It is simply a matter of configuring zsh to use it. After trying the solution in Ubuntu I found that the file mentioned in /etc doesn't exist, but it is simply a matter of adding this line ...


1

By default the zle (zsh command line editor) command to backspace whole words - backward-kill-word (or vi-backward-kill-word if you are using viins keymap) - is also bound to Ctrl+W. Should this not be the case for you, you can set this with bindkey '^W' backward-kill-word in your configuration.


1

Sure it's possible. Remove the brackets: monsterkill-ub-dt% for fl in (xfile yfile); cat ${fl} zsh: invalid mode specification monsterkill-ub-dt% for fl in xfile yfile; cat ${fl} x y This also works: monsterkill-ub-dt% for fl in *; cat ${fl} x y


1

$for fl in (fileA fileB fileC); echo $fl Here, ( is parsed as the beginning of a Glob Qualifier, like in ls *(a+2). The qualifier f stands for files with access rights matching spec, that's why you get the error invalid mode specification, because ileA is not a valid access right spec. If you try e.g. $for fl in (anotherfileA fileB fileC); echo $fl ...


1

This should do the trick: tar -tzf archive.tar.gz | sed 's@^//*@@' | sort -r | xargs -d '\n' rm -d If your archive contains absolute paths and you unpacked it to the absolute locations (for this you need to use the -P option of tar) you have to leave out sed. You can also leave sed out, if you are absolutely sure that there are no absolute paths in your ...



Only top voted, non community-wiki answers of a minimum length are eligible