78 reputation
117
bio website
location East Coast USA
age
visits member for 2 years
seen Apr 6 at 14:14

I'm basically a self-taught, now inactive, web designer who still seeks to learn more about css (and some javascript) while pushing it to its limits: all as a part-time hobby between my Ph.D. studies.


Apr
27
comment Get Windows localhost (port 80) to forward to port 8080 for Apache service
@harrymc--Thank you for all your time, efforts, and thoughts on this. I agree, there is something I'm missing in how the network address handling is being done that is preventing me from achieving my goal. While the bounty has ended, my issue has not. When I get it resolved, I'll be back to post my findings.
Apr
25
comment Get Windows localhost (port 80) to forward to port 8080 for Apache service
@harrymc--note the "recent discovery" (about localhost) at the top of my post. That may be part of my issue as well.
Apr
25
comment Get Windows localhost (port 80) to forward to port 8080 for Apache service
@fencepost--note my recent discovery at the top of my question now (about localhost). Perhaps that is part of the issue.
Apr
25
comment Get Windows localhost (port 80) to forward to port 8080 for Apache service
That was interesting, but I'm not sure how helpful, as the C:\Windows\System32\drivers\etc file was already the one I modified, yet it still does not seem to be getting picked up as far as defining my local sites. The article seems to indicate that the file is used by 64-bit natively, and 32-bit by redirection. How might this affect my Apache install and why localhost is ignored for my local sites?
Apr
25
comment Get Windows localhost (port 80) to forward to port 8080 for Apache service
I have already added those lines to that location (from the start), but I have wondered if it is the correct location on a 64-bit system (which WHS is).
Apr
24
comment Get Windows localhost (port 80) to forward to port 8080 for Apache service
@harrymc--I was trying to use 192.168. address, so I changed that to 127.0.0.1 (.0 at the end was invalid for me). I got the WAMP server running (needed to add the proxy modules of course). However, now that I can test, it still does not work. Same results (as if the local server is not being contacted at all before going out to the ISP DNS). I've posted code toward the upper portion of my question that is based off your recommendations here. Take a look and see if it at least looks like what you expect before I stop pursuing this line for a solution.
Apr
24
comment Get Windows localhost (port 80) to forward to port 8080 for Apache service
Thank you for your answer. While it is true that it is a DNS issue in some sense, what I want is for any localhost call to not even go to the DNS of my ISP to begin with (it shouldn't). It seems "overkill" somehow to have to set up a DNS locally to handle what should be handled already, automatically by the system. My requests for localhost sites should not even be going to my ISP DNS.
Apr
23
comment Get Windows localhost (port 80) to forward to port 8080 for Apache service
@harrymc--Having made the changes, I cannot even get my WAMP server to start. Not sure why, but at present it prevents a full testing to know if it is going to work. I am also wondering if, in the first link, the ourdomain.dom is something specific to my computer or not (or is it just an arbitrary name, since he was dealing with subdomains... should mine be localhost?). Additionally, in the first link, the our.ip.addess for the routing to IIS is going to be the same for the Apache server, as they are on the same computer (just different port). That should not cause issues, right?
Apr
23
comment Get Windows localhost (port 80) to forward to port 8080 for Apache service
@harrymc--As I mentioned in my question, I'm not really a network person, so I have a couple of questions and need a little guidance. First, is changing my WHS to port 90 going to affect how the WHS functions as a home server? Second, the link you posted refers to trying to access subdomains, whereas I am not (rather, I'm seeking to access different local domains); so does that change anything? For guidance from the linked solution, I have some Apache knowledge, so #4-5 I follow, but I have nearly zilch IIS knowledge, so points #1-3 I'm unsure how to do (or even in my case if I need to do).
Apr
23
comment Get Windows localhost (port 80) to forward to port 8080 for Apache service
@MartinoDino--Thanks for your suggestions. I've just updated some info in my question that I believe now my main issue to be that my WHS computer is not even handling the request for my test sites, but rather my ISP proxy seems to be. If I can get that resolved, then I'll begin to find out if my other local parts are actually working.
Apr
23
comment Get Windows localhost (port 80) to forward to port 8080 for Apache service
@harrymc--thanks for the input. That may be useful, however, if you look at my latest update (just posted), I've discovered that my first main issue is that the test url's are never making it to my local computer, but are attempting to be handled by my ISP proxy. If you have some suggestions about circumventing that, I'm open.
Apr
22
comment Get Windows localhost (port 80) to forward to port 8080 for Apache service
@erikxiv--Well, the link looks promising. I also found this link which looked even more promising, as it appears to be doing the exact same thing I would like to do. The problem is, I still can't seem to get the forwarding to work. I'll post what I did in my question above.
Apr
21
comment Get Windows localhost (port 80) to forward to port 8080 for Apache service
@erikxiv--no, I am not sure about it. My problem was the fact that I'm in territory unfamiliar to me, so I did not know how to make it work if it could. I'll look into the link and get back to you.
Apr
20
comment Get Windows localhost (port 80) to forward to port 8080 for Apache service
By the way, I mistyped previously, the images are giving a 403.
Apr
20
comment Get Windows localhost (port 80) to forward to port 8080 for Apache service
Interesting. There are no log files for my attempted accesses, except in those cases where I was using the direct localhost access. So I turned off the WAMP server all together, and found I was getting the same results. Which would seem to indicate Apache is not handling the requests to begin with, but IIS is.
Apr
19
comment Get Windows localhost (port 80) to forward to port 8080 for Apache service
@ekaj--I added some updated info to my issue that may help you in coming up with a different "guess" (maybe a solution!).
Apr
19
comment Get Windows localhost (port 80) to forward to port 8080 for Apache service
@ScottWilson--I added some updated info to my issue that may help you in coming up with a different solution.
Apr
19
comment Get Windows localhost (port 80) to forward to port 8080 for Apache service
@ekaj--I appreciate the guess, and checked permissions, but that is apparently not the issue.
Apr
19
comment Get Windows localhost (port 80) to forward to port 8080 for Apache service
Good suggestion, but only a couple of the sites have .htaccess files, and none have a ForceType in the code.