66 reputation
211
bio website webzilla-il.com
location Israel
age 17
visits member for 2 years, 6 months
seen Sep 20 at 14:18

Hey i'm dan.


Oct
18
awarded  Notable Question
Aug
25
awarded  Popular Question
Jun
5
reviewed Approve suggested edit on SATA Devices not showing up when in UEFI mode
May
12
revised SATA Devices not showing up when in UEFI mode
edited with answer
May
12
awarded  Benefactor
May
12
awarded  Scholar
May
12
accepted SATA Devices not showing up when in UEFI mode
May
12
comment SATA Devices not showing up when in UEFI mode
Wow, wasn't expecting this to be so simple. You got it right, that was the problem (the image was not UEFI compatible).. Thanks!! :)
May
7
comment SATA Devices not showing up when in UEFI mode
I might have not clarified it enough - the drives not showing up - that's in the boot menu, not when trying to install Windows; I can't even try to install it while in UEFI mode because there are no drives in the boot menu to boot from. When I change the BIOS to Legacy mode I can see the drives in the boot menu and therefor boot the installation CD - at that point the installation disk does show the drives but with the GPT error which you gave a suggestion on how to solve. My main question though, is how to fix that the boot menu shows no drives while the BIOS is in UEFI mode.
May
7
comment SATA Devices not showing up when in UEFI mode
I will try and follow your instruction to change the partition style to MBR and update. Even though your answer is properly written and explains everything needed to do that, my question was mainly about the fact that while in UEFI mode - all the drives are not available. This is not because my "BIOS doesn't support UEFI well-enough" - before installing the Linux OS I had Windows 8 running without problems while in UEFI mode (The computer ships with it) -> So I did upvote your answer but not yet accepted it. Thanks for your effort to help me solve this
May
7
awarded  Student
May
6
comment SATA Devices not showing up when in UEFI mode
@harrymc if I try to boot Windows installation CD (not USB, but probably will be the same result) in Legacy mode than it says: "Windows cannot be installed to this disk. The selected disk is of the GPT partition style."
May
6
comment SATA Devices not showing up when in UEFI mode
@CristianCiupitu secure boot is disabled.
May
6
comment SATA Devices not showing up when in UEFI mode
@harrymc I edited the answer with all the extra details, can you please expand on what you suggested with GPT? (I don't know what's that). Thanks for helping me
May
6
revised SATA Devices not showing up when in UEFI mode
Added extra details
May
6
awarded  Commentator
May
6
comment SATA Devices not showing up when in UEFI mode
Lenovo site claims that there are currently no BIOS updates ( support.lenovo.com/en_IL/downloads/detail.page?DocID=DS035829 )
May
6
comment SATA Devices not showing up when in UEFI mode
I can't use Linux Live CD while in UEFI mode because the CD reader drive is not available. I forgot to mention that I have a Linux OS installed which works great in Legacy mode but again, not available in UEFI because the hard drive it's on is not available (available = showing up). What further details would you like to know about my setup?
May
6
comment SATA Devices not showing up when in UEFI mode
I tried reseting Bios to defaults, no overclocking, tried both DVD and USB - both not showing up and working when in UEFI mode. Tried disconnecting everything - not helping. What should I try with the Linux Live CD?
May
6
awarded  Promoter