Reputation
17,177
Top tag
Next privilege 20,000 Rep.
Access 'trusted user' tools
Badges
1 47 70
Newest
 terminal
Impact
~938k people reached

Dec
15
comment How to start a command in tmux + urxvt setup?
The -c option is the problem here: it just acts as a “pass through” to a shell (tmux’s configured default-shell)—this is usually only useful when tmux is configured as a user’s login shell (since other programs might assume the login shell knows how to handle args like -c shell_cmd_str). You probably want to use new-session instead of -c.
Dec
12
awarded  mac
Oct
30
answered Tmux copy-pipe with mouse selection
Oct
21
awarded  Yearling
Oct
16
revised In tmux, arrow and ctrl+arrow both result in the same code
fix a few square brackets that were facing the wrong direction; small word choice edit
Oct
15
answered Resizing pane is not working for tmux on mac?
Oct
2
answered Weird behaviour/rendering on tmux in osx
Oct
1
comment Weird behaviour/rendering on tmux in osx
Are you sure you have not turned off utf8 for that window (despite having the global value be on)? I certainly see extra spaces when using your PROMPT value if I set utf8 off for the window. What does tmux show -w utf8 \; show -gw utf8 show in a window you are having problems in?
Oct
1
comment Weird behaviour/rendering on tmux in osx
When looking for multibyte the prime suspects would be “fancy” shapes like arrows, triangles, accented characters, etc. If you output them to tmux when it has utf8 turned off, then its idea of the cursor position and the outer terminal’s idea of the cursor position will be different; zsh asks for the cursor position, so it is sensitive to this discrepancy (which shows up as extra spaces at the end of its prompt). You might want to edit your question to include your actual PROMPT/PS1 value.
Sep
30
comment Weird behaviour/rendering on tmux in osx
Do you have multibyte characters in your prompt? Is the utf8 window option turned on for your tmux windows?
Sep
29
comment Function key shortcuts in PuTTY/MinTTY and Tmux/Byobu
The sequences you list for tmux are just the rxvt-style modified-key sequences that it recognizes. tmux also recognizes the (unmodified) sequence specified by TERM’s terminfo entry (e.g. kf3 from whatever TERM you are using when attaching to tmux) as well as the xterm-style modified-key sequences from xterm-keys.c. So, the sequences that you report from Gnome-Terminal and MinTTY (although the escape+zeros in your sequences should be escape+letter-ohs (a.k.a. SS3) should be recognized by tmux, but it will only pass them through if you have the xterm-keys option enabled.
Sep
20
awarded  Enlightened
Sep
20
awarded  Nice Answer
Sep
13
answered Setting the color coditionally in tmux.conf
Aug
7
answered Tmux set color of changed window
Aug
6
answered Making MacVim/gVim “block” the terminal until closed
Jul
27
answered Is there a way to get the size of a pane in tmux?
Jul
19
awarded  Good Answer
Jul
10
comment Is there a way to escape single-quotes in the shell?
@Matthew: The interpretation of \U in that case is being done by built-in echo command (this behavior can be controlled by -E or the BSD_ECHO option and -e). You can see that the literal string is passed (and not otherwise interpreted) in other commands; e.g. printf %s\\n '\U0000068\U000069'.
Jun
18
awarded  Enlightened