153 reputation
9
bio website
location
age
visits member for 4 years, 5 months
seen 2 days ago

Nov
27
comment XFS in-memory corruption after hibernate
I do not have i915. Playing with any settings will not work because it is not reproducible. I.e. I had not hit it at least in a month, but I have no idea whether it was because I updated the kernel and it fixed things or because necessary preconditions were not met.
Sep
9
asked XFS in-memory corruption after hibernate
Jun
23
comment Un-mapping commands in Vim
@Grigor In your question you claimed that you used map <Tab> <. To undo this correct command is indeed unmap <Tab>, but the next text (“all it does is insert the < character”) means that original claim is false. There is no way you could insert < with such mapping, but it would be true if you have written imap <Tab> <. This command is undone using iunmap <Tab> (note the i in both commands). To get correct answers you must be precise.
Mar
29
comment Can not bring a background running vim to foreground?
@romainl Anyhow from within vim. Both <C-z> and :susp show similar behavior. I have not checked what will be done if I try to suspend by sending some signal.
Mar
29
comment Can not bring a background running vim to foreground?
I also have this issue, but not with zsh -f and not with zsh -f after importing all options (i.e. by doing source <(cat ~/.zshrc | grep setopt) in a new shell obtained using zsh -f) and freezing most terminal options with ttyctl -f. I guess you have to bisect your configuration to find out what is causing the issue.
Mar
29
comment Can not bring a background running vim to foreground?
Using fg %4 is strange. You can just use %4. And what for do you run bg on already suspended vim?
Dec
24
comment How can i go to particular line in vim?
I replaced command with normal in your post. By the way, <number>G has exactly the same meaning as <number>gg.
Dec
24
comment How can i go to particular line in vim?
@fge There already is fixed terminology. : enters command mode. Default mode where gg works is normal. gg itself is command. Or normal-mode command as command may as well refer to :e, and this is what it refers to by default. Don’t ever refer to normal mode as to command, this just leads to misunderstanding between those who know vim terminology and those who don’t.
Dec
3
answered Copying text from Vim to something else without clipboard support of Vim
Nov
18
comment Save file in Windows protected folder
@Fabricio :h vimrc It is where vim searches user configuration by default.
Nov
1
comment How to get the original vim files on mac?
@user1684696 No idea, I don’t have mac. You can just fetch all files from the vim repository and put them into /usr/share/vim/vim73. Or install macvim, it should not hurt: What are the advantages of MacVim over Vim? There is also some advice to install vim from macports, but I don’t know how to do this exactly.
Nov
1
answered How to get the original vim files on mac?
Oct
27
comment Vim colorschemes not changing background in Ubuntu terminal
In fact, that line with hi comment guifg='salmon pink' is the only line where :highlight in help is used with single-quoted arguments (excluding 383’rd patch description in :h version6), neither I saw quoting in any colorschemes.
Oct
27
comment Vim colorschemes not changing background in Ubuntu terminal
It is for “try this to change bg color: set background…”. It does never change the background. Color is not a problem (not that for -1): it is just uncommon to have 'color' as a placeholder for things like Red. It would be common if you used ctermbg=color or ctermbg={color}. I now know that ctermbg='Red' is accepted as well, but I do not see this acceptance stated in :h highlight-ctermfg, only in :h highlight-guifg.
Oct
27
comment Vim colorschemes not changing background in Ubuntu terminal
Why do you think background should change?
Oct
27
comment Vim colorschemes not changing background in Ubuntu terminal
set background=… does exactly nothing with background. It just tells vim whether it should think that background is dark or light and adjust default colors accordingly. Does nothing for non-default colors (those that are changed by colorscheme). Is altered automatically when colorscheme redefines Normal highlighting group. And, by the way hi Normal ctermbg=color, no quotes.
Oct
18
comment Make text bold in vim
@ParthShah No, bash is the shell and not a terminal. “Terminal” here is a short of “terminal emulator”: GUI application you use.
Oct
17
comment Make text bold in vim
I believe you should configure the terminal, not vim. Hence 1) asking what terminal do you use? 2) seconding the request to move the question to superuser.
Oct
12
comment tmux / vim split panes
By the way, what is the option for changing border character? I found a number of them for changing border colors, but not for changing border character.
Oct
12
answered tmux / vim split panes