248 reputation
2519
bio website use.perl.org/~jdavidb
location Texas
age 36
visits member for 5 years
seen Aug 15 at 21:07
I am a Perl programmer using Java by day. I am jdavidb on use.perl.org and slashdot.


Jul
7
awarded  Good Question
Jul
2
awarded  Curious
May
1
awarded  Notable Question
Mar
20
awarded  Popular Question
Dec
11
awarded  Popular Question
Sep
4
awarded  Famous Question
Jul
2
awarded  Self-Learner
Mar
31
awarded  Notable Question
Mar
17
awarded  Nice Question
Feb
20
awarded  Popular Question
Feb
15
awarded  Famous Question
Nov
26
awarded  Benefactor
Nov
24
awarded  Nice Question
Nov
20
comment Why is 'ping' unable to resolve a name when 'nslookup' works fine?
Yes, if that's the case, I want to know why! I am going to try this the next time the problem occurs. If it appears to fix it then, I'm going to drag in IT admins from the main corporate office and get them to tell me why. :) And you'll get the bounty if that appears to be the fix.
Nov
20
comment Why is 'ping' unable to resolve a name when 'nslookup' works fine?
@jackweirdly on another machine.
Nov
20
comment Why is 'ping' unable to resolve a name when 'nslookup' works fine?
I disabled the DNS Client service, and the problem appeared to go away! Not sure yet if it was a fluke. The problem didn't come back when I restarted the service.
Nov
20
awarded  Commentator
Nov
20
comment Why is 'ping' unable to resolve a name when 'nslookup' works fine?
I would bet Active Directory is probably active, but I do not know how to test.
Nov
20
comment Why is 'ping' unable to resolve a name when 'nslookup' works fine?
Are there any settings that can move the NetBIOS query higher up in that list? I have the gut feeling that the NetBIOS lookup is involved somehow, but since the DNS query is definitely working I can't see how it would ever get to that step, if the sequence above is immutable.
Nov
20
comment Why is 'ping' unable to resolve a name when 'nslookup' works fine?
Good thought! But I checked, and neither of the machines I've seen this issue with are listed in hosts.