Reputation
3,079
Top tag
Next privilege 5,000 Rep.
Approve tag wiki edits
Badges
12 32
Newest
 Yearling
Impact
~332k people reached

Apr
6
awarded  Benefactor
Apr
6
comment Out of MTRRs at boot
Thank you for that suggestion -- I looked into it some more, and also have managed to rewrite the MTRR table. I will submit the way I fixed it as an answer, but will give you the bounty since it was ultimately you that led me to the solution. Thanks a lot!
Apr
6
comment Out of MTRRs at boot
I was asked on the Arch forums to "boot with nopat on the kernel commandline" to see if I was using PAT, but I see absolutely no difference in performance with nopat being passed to the kernel.
Apr
6
revised SCP from remote Linux system to Windows
title improved
Apr
5
comment Out of MTRRs at boot
Doing so results in the drm warning, the no more MTRRs warning, and a new, seemingly more severe message, [drm] failed to find VBIOS tables. cat /proc/mtrr still yields the same output as in the OP.
Apr
5
comment Out of MTRRs at boot
@Linker3000 Thanks. Intriguing...
Apr
5
revised Out of MTRRs at boot
added 177 characters in body
Apr
5
comment Out of MTRRs at boot
zgrep 'SANITIZER' /proc/config.gz was already in OP, but I put this one in too.
Apr
4
comment “slow operating system that doesn't allow time to configure the javascript”
Indeed, if that is truly what he said, I question his suitability...
Apr
4
comment Out of MTRRs at boot
Interestingly, this blog entry documents the same laptop that I have, and despite taking the same steps I have, he has a completely different (and by the look of it), correct MTRR table afterwards. Is there some way to manually specify these values? blog.jolexa.net/2009/11/22/buggy-mtrr-on-acer-aspire-one-zg5
Apr
4
comment Out of MTRRs at boot
To answer all points you made: this computer only has 1GB of RAM. The BIOS only has very basic options (time, etc) -- nothing to allow modifying memory allocation. The graphics card driver is intel and is the latest (stable) version. There is no option in the BIOS to modify the amount of memory being reserved for graphics. This happens when using the following kernels: make defconfig, the standard Ubuntu kernel (stable, 32-bit), and 2.6.37-ARCH (stable, 32-bit), so I don't think it's a misconfiguration.
Apr
4
comment Out of MTRRs at boot
Actually, that exists in the first dmesg too... so increasing the spare number seems to remove the drm warning, but not the "no more MTRRs" warning.
Apr
4
answered Does the order in the slots of memory modules matter/ MemTest
Apr
4
revised Out of MTRRs at boot
shame on me!
Apr
4
comment Out of MTRRs at boot
@Tom Wijsman Thanks, forgot.
Apr
4
comment Out of MTRRs at boot
No luck with either (I already had enable_mtrr_cleanup=1, which just changes CONFIG_MTRR_SANITIZER_ENABLE_DEFAULT, but booting with mtrr_spare_reg_nr=2 doesn't fix it either). I get a different, but similar, error: [ 0.329894] mtrr: no more MTRRs available.
Apr
1
answered Messed up bash configuration on Mac OS X
Apr
1
comment Out of MTRRs at boot
The problem has been there for a while, just got around to posting it here. If you do dmesg | fgrep mtrr do you see the same (or similar) error messages? If not, could you please do zcat /proc/config.gz and pastebin it /w cat /proc/mtrr somewhere for me? Thanks! :)
Apr
1
revised Out of MTRRs at boot
added 160 characters in body
Apr
1
asked Out of MTRRs at boot