305 reputation
210
bio website getmoneymakemoney.com
location New York, NY
age 29
visits member for 3 years, 7 months
seen Dec 12 at 16:01

I live and work in New York and Maryland. I spend most of my time with JavaScript and Linux.

You can reach me at:


Nov
15
asked Packet forwarding for guest VMs not working
Oct
26
comment Common tmux scrolling solutions are not working
Frustrating when people don't read or ignore content in your question.
Oct
11
comment How do I get rid of com.apple.launchd.peruser errors in my log?
There is no remove -w.
Oct
5
comment Irssi settings and Bash's Environment variables
From github.com/irssi/irssi/blob/master/docs/special_vars.txt, it appears that env vars are made available as variables in the config
Apr
20
revised SCP recursive file transfer order
edited title
Mar
24
revised Prefixed (b:, g:) settings in Vim
edited title
Mar
24
asked Prefixed (b:, g:) settings in Vim
Feb
19
awarded  Nice Answer
Aug
19
accepted Inputting UTF-8 characters into the Bash CLI
Aug
19
comment Inputting UTF-8 characters into the Bash CLI
Hah! Before posting I was trying to figure out a good way to do what you describe. For some reason ls > OUTPUT didn't occur to me :|. Anyway, this is indeed UTF-8: d0 9a is that K (utf8-chartable.de/unicode-utf8-table.pl). Thanks for introducing me to ga and g8. Wasn't aware of those! Had been using hexdump.
Aug
19
comment Inputting UTF-8 characters into the Bash CLI
To clarify what I mean by "works normall": with this setting enabled, I can copy/paste non-7-bit letters. I can also switch OS X to Cyrillic input, type a letter, hit tab and get autocomplete.
Aug
19
comment Inputting UTF-8 characters into the Bash CLI
Wow. That did the trick. It was disabled, and I enabled it, and now it works "normally". I don't understand what Terminal.app was doing before, what this setting does, and why I didn't experience the phenomenon locally. Do you know why? Care to post an answer? Would gladly vote-up and accept.
Aug
19
comment Inputting UTF-8 characters into the Bash CLI
Yep, pasting out works fine: that's how I got those characters into this post. The problem, anyway, is both with direct input and copy/paste, both OS copy/paste and tmux vi-mode yank/paste. Amusingly, when I mount that path locally via SSHFS, I'm able to use my local Bash as expected: Input+autocomplete, AND copy/paste.
Aug
19
revised Inputting UTF-8 characters into the Bash CLI
added 90 characters in body
Aug
19
revised Inputting UTF-8 characters into the Bash CLI
added 90 characters in body
Aug
19
comment Inputting UTF-8 characters into the Bash CLI
This also happens with direct input, not just pasting. I am using OS X's Terminal.app, and I've got TERM set to xterm-color.
Aug
19
asked Inputting UTF-8 characters into the Bash CLI
Jun
27
comment Why doesn't this vim binding work?
I'd want to get this working and then figure it out
Jun
26
asked Why doesn't this vim binding work?
Jun
26
awarded  Yearling