3

I am trying to open https://github.com on IE 11 and Chrome but it gives a SSL certificate error NET::ERR_CERT_AUTHORITY_INVALID on chrome with no option to proceed ahead.

It's happening with almost every site but luckily I am getting the option to proceed. Then I installed Firefox (portable version) and checked that it works without any problem!

Digging further I found that Firefox is using system proxy settings and I do not see any settings in IE and Chrome. What could go wrong . How to fix this ?

I have tried a lot changing the Advanced Security setting in Internet Explorer but no help.

4
  • Check the date and time of your computer and make sure it's within 5 minutes of a known correct source for your time zone...
    – Kinnectus
    Nov 13, 2015 at 8:25
  • when you migrate questions from one forum to another make sure the solutions proposed are not lost. Eventually I lost some comments in the migration.
    – Akshay
    Nov 19, 2015 at 12:50
  • This is not a possible duplicate . See the solution provided below . Guys -stop making yourself busy in making questions duplicate and migrating questions from one forum to another. This is why I see a lot people moving on expert-exchange .
    – Akshay
    Feb 11, 2016 at 13:33

2 Answers 2

1

Eventually , this got solved when I posted the same question on expert-exchage.com.

The problem was that either the browser (Chrome and IE both) were not downloading the correct certificate or it was not in the Trusted Root CA directory. I downloaded the CORRECT certificate from

https://www.digicert.com/CACerts/DigiCertHighAssuranceEVRootCA.crt

and installed it in Trusted root CA directory and it worked like a charm.

http://www.experts-exchange.com/questions/28854099/Getting-Certificate-error-on-IE-and-Chrome-but-opens-in-FireFox.html

0

There was an issue with expired root CA's that was reported with Chrome some time back. You can find a thread here: https://productforums.google.com/forum/#!topic/chrome/SE3sKXg0iFQ

It seems that deleting and replacing some DigiCert certificates resolved the issue for quite a lot of people. The thread above includes instructions to do that.

2
  • Thnx but I already have tried this. This is actually not applicable for me as the certificate I am receiving from github is already valid till 2016. Also if certificate expiry was the reason , it should not have worked in firefox as well !
    – user367097
    Nov 12, 2015 at 10:53
  • Even if the site certificate is valid - there could be an issue with the root certificate that verifies the site certificate. Real or imagined - I see those problems quite often. Are you able to view the certificate chain from Chrome? If so - make sure that Chrome doesn't flag up any (possibly made-up) errors. Also, IIRC, Firefox uses a different cerfificate store than Chrome and IE so it could be that Firefox's root ca for whoever signs github is different. Could be worth looking at. Nov 12, 2015 at 10:57

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .