0

I recently got a Raspberry Pi model B and I decided to install Kali Linux 2 on it. The only problem I'm getting is SSH services (OpenSSH) won't start on boot no matter what I try, making it impossible to run it headless, and leaving me with a mass of wires. Any ideas why this is happening and how I could fix it?

2
  • is there anything related in boot logs? – Jakuje Nov 14 '15 at 7:50
  • When it boots it says something about "Stopping OpenBSD SSH services" – Sponion Nov 14 '15 at 13:44
0

I was having the same problem and found a solution by reading through this thread: https://www.raspberrypi.org/forums/viewtopic.php?t=86950

First I did:

update-rc.d ssh defaults
update-rc.d ssh enable

and also I did:

systemctl enable ssh.

The last command resulted in this:

Synchronizing state of ssh.service with SysV service script with /lib/systemd/systemd-sysv-install.
Executing: /lib/systemd/systemd-sysv-install enable ssh
Created symlink /etc/systemd/system/sshd.service → /lib/systemd/system/ssh.service.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.