I downloaded and installed Windows 10 Pro 32 bit.

Occasionally after I start the computer, it boots as usual but then doesn't show the start menu or desktop icons.

After I restart it 2 or 3 times it then works perfectly.

At first I thought it was a graphics card problem, but that doesn't seem to be the case.

My PC is an HP Compaq DC5750 with 2GB RAM; small form factor.

  • When you turn it on and nothing happens wait some time to see if it may still work.
    – Racing121
    Nov 14, 2015 at 8:51
  • THANX FOR THE ANSWER . I wait like 5 minutes and nothing happens. I have to restart it 3 times and then windows boot and work perfect .
    – jim
    Nov 14, 2015 at 8:54

3 Answers 3


Open powershell in admin. (Winkey-X, A, accept the admin elevation, then type powershell in the elevated cmd window and press enter.)

Once you have an Administrator Powershell window, run this command:

Get-AppXPackage -AllUsers | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register "$($_.InstallLocation)\AppXManifest.xml"}


  • 1
    Just wanted to add that this solved the problem here. To other users, I'd probably look at trying this first before anything more drastic.
    – Tim Malone
    May 25, 2016 at 2:12
  • Yes, as long as you have admin privs, this is the lowest-cost solution. It certainly doesn't always work, but it fixes one of the causes of the no-start-menu or no-Windows-store bugs.
    – Tim G
    Jun 13, 2016 at 1:19

impossible to tell you what exactly the problem is. Could be a hardware problem but could also be a driver issue. Win10 is known to sometimes overwrite good drivers with bad ones.

Definitely check the windows event logs, you might find specific information there.

Further, I suggest:

  1. do a thorough memory test.
  2. monitor the temperature of your components, especially the cpu.
  3. manually check for newer drivers.
  • Ok thanx ill try this .
    – jim
    Nov 14, 2015 at 8:56

There is several easy ways to try to fix it in this page:


But the only one that worked for me was disabling Powershell 2 as someone suggested in the comments: Control Panel -> Programes and Features -> Turn Window Features On or Off -> disable Powershell 2

It will take a couple of minutes and then you need to restart Windows, and the Start Menu returned.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .