35

my former wrong assumption: it drains my notebook battery and I've no shortage of RAM. In Task manager you see ntoskrnl.exe is eating more CPU time than any other process. this feature does not appear to be optional and came 2 days ago with the 1st Win10 Update (Win10Pro in my case).

Edit:

I want to disable it, at least to exclude it as a culprit for my (unproven) assumptions. That process never came to my attention in the last 2 months and in task manager's long name it's called "system memory and compressed memory".

migrated from serverfault.com Nov 14 '15 at 11:32

This question came from our site for system and network administrators.

  • Are you sure that is the issue? If you have no shortage of RAM, the compression will not be used. And there is a separate process showing for the compression, if it is being used. – Sami Kuhmonen Nov 14 '15 at 11:50
  • It's called by that name in task manager. And being able to disable compression would help to nail – Falco Alexander Nov 14 '15 at 12:02
  • 1
    Memory compression has been in Windows 10 since the beginning. If you have battery issues since this week it's not because of this feature. The kernel does a lot more than just memory compression. It makes all applications work on your system. – ZippyV Nov 14 '15 at 12:33
  • 1
    What makes you think that memory compression is the problem? Have you used a detailed process analyser? If not, you should. As @ZippyV says, ntoskrnl.exe handles all core functions, and there are many of them, so I see no reason to single out memory compression as the culprit. – AFH Nov 14 '15 at 13:56
  • 1
    this is no new feature of the update. This feature is already part of the first release, see the duplicate link. – magicandre1981 Nov 14 '15 at 19:22
20

This is a good feature to avoid paging (writing data to pagefile.sys on the HDD) .

If you want to test your Windows 10 without memory compression, start powershell as admin

enter image description here

and run the command Disable-MMAgent -mc and reboot. This disables the compression. To enable it later again, run again powershell as admin and run the Enable-MMAgent -mc command.

  • 1
    Thanks for your answer. Regarding "good feature to avoid paging". I'd argue it depends. I was developing software with a heavy IDE on a ULV processor with a decent amount of ram and fast SSD. Ignoring the "out of memory" exceptions I'd get with the feature ON, I'd still prefer the occasional page file IO over the CPU hit. – Kevin Dec 5 '16 at 20:17
  • 2
    @Kevin no, paging and IO is more expensive in term of responsiveness of a OS – magicandre1981 Dec 6 '16 at 5:10
  • 2
    @magicandre1981 It ain't necessarily so. I have 16GB of RAM, and memory compression typically uses 3GB and up to 5 GB. I get windows popping up telling me that I am out of memory and suggesting that I kill some application. There is no question that I would be better off without memory compression, having slower paging but keeping may applications running. – user184411 Dec 25 '16 at 3:34
  • 1
    I will add that you can use Get-MMAgent prior to this command to confirm the current state of memory compression among other things. – Souhaieb Besbes Dec 29 '16 at 10:09
  • 1
    Does this only work on certain version of win10? I can't get the disable command to work with -mc nor -memorycompression – TombMedia Jul 12 '17 at 19:38
8

You can check the full answer at What is the cause of a high CPU usage of 'system and compressed memory' in Windows 10?. But for a short version:

I went to:

Start->Control Panel->Administrative Tools->Task Scheduler->Task Scheduler

Library->Microsoft->Windows->MemoryDiagnostic

There are two line items. Running of the task may be dependent upon log events. I'm not sure if they just have to exist, or if they trigger upon entry into the log. In any case, I disabled the entry labelled as RunFullMemoryDiagnosticEntry. That solved my instance of the problem.

If this doesn't solve your issue, instructions earlier in the answer suggest using the Windows Performance Analyzer to help find a solution.

  • 2
    Sounded logical, so I tried it. But the problem returned. : / – arod May 23 '16 at 21:34
  • Would it be possible to configure Windows 10 so that is uses the page file more often than what it already does by default, and uses the compression less often? From what I've seen online, it appears as though any attempts to completely disable the new memory management scheme yield little-to-no results. I'm sporting and AMD E-Series APU with 4 GB of ram, and no possibility of a memory upgrade. Laptops hurt. – TopHatProductions115 Jun 10 '16 at 0:50
  • Can I just confirm that this definitely and definitively disables memory compression? I toggled this a couple of days ago, but last night on (yet another freeze) I noticed procexp reporting utilisation during one of my increasingly frequent system freezes imgur.com/a/iPKY2 – fostandy Aug 11 '16 at 23:33
  • The answer isn't easy. One setting doesn't fix everyone's problem. Everyone's system is different and has different issues at heart. And different things are installed. But... in the link I offered, I show the way I found out what my particular issue was. That tool set is general enough that it may help you find the root issue and over a specialized solution for your particular environment. Or, ... dare I say it... find someone who can run the tools for you, read the tea leaves, and figure something out. :-) – Raymond Burkholder Aug 12 '16 at 11:38

Not the answer you're looking for? Browse other questions tagged or ask your own question.