0

So I'm running the N edition of Windows 10 Pro which means I need the MFP (Media Feature Pack) to get Windows Media Player and several codecs or the MFPlat.dll that's often needed to play games like Black Ops 3 as an example.

I already had this before the November update, but after installing the update, it's completely removed the MFP so I have no Media Player, I can't use the edge browser to view PDFs anymore, and I can't play various games.

Of course, this prompted me to reinstall the MFP, so I went and did just that, but... Nothing has changed other than it listing that the package exists, I still can't play those games, nor do I have Media Player and PDFs still can't be opened. I tried restarting several times, I got the Windows is updating message on the second reboot, but that's all. If I attempt to install it again, it says it already exists, if I try to remove it, it says that I can't because it's a required package.

Is there anything else I can try to get the MFP to work?

0

Microsoft just re-released the MFP to solve this issue:

https://support.microsoft.com/en-us/kb/3099229

  • Trying it out now. – PairedPrototype Nov 15 '15 at 15:50
  • Perfect! Thanks man, I've got Media Player and the MFPlat.dll back. – PairedPrototype Nov 15 '15 at 16:01
  • No problem.. I was on the verge of re-installing but luckily I found this fix. – Rufus Nov 15 '15 at 16:05
  • this is what I already posted yesterday with the same KB link ... – magicandre1981 Nov 15 '15 at 19:48
  • LOL @ magicandre1981... you posted the link to the old MFP the other day and just edited the new one in now. I know because I checked your solution the other day trying to solve the problem. Also, you downvoted my answer as well? Really? – Rufus Nov 15 '15 at 20:51
0

The November update has Build 10586, so you have to install the Media Feature Pack for this build, which you can download from here.

  • Yes, that is what I've installed. But nothing from the MFP exists on my PC other than the pack existing in wusa. Media Player is nowhere to be seen, Edge still wants it to display PDFs and the MFPlat.dll still doesn't exist. I've tried rebooting numerous times as well. – PairedPrototype Nov 15 '15 at 4:33
  • open programs & features in classic control panel and activate Media Player. Or is the Media Player still not listed there? Was the update installed correctly? – magicandre1981 Nov 15 '15 at 11:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.