21

I have seen a few people with this problem on forums, but nobody seems to have a solution yet. Windows says I should restart because I have an update pending (this is 10586). During restart there is no indication that any updated are being installed or have failed to be installed. Once I log back into Windows I am told that there was a problem installing updates.

enter image description here

In the event log I can see:

Installation Failure: Windows failed to install the following update with error 0x8024200D: Upgrade to Windows 10 Pro, version 1511, 10586.

Does anybody know what is wrong or how to fix this?

  • I missed the original deployment of this update because I had the business update-delay checked. Now that I have unchecked that and Microsoft has pushed this update out again, I too am seeing this. Thanks to the ever-so-helpful error message by Microsoft, as you have posted: "We couldn't finish installing updates." If you click to learn more, you learn... Yup, you guessed it: Absolutely nothing of value! – TGP1994 Nov 30 '15 at 23:47
11

Here is how I fixed this issue:

  1. I booted into safe mode (using MSCONFIG).
  2. I deleted the contents of C:\Windows\SoftwareDistribution\Download
  3. I turned off safe mode and booted into windows normally.
  4. I re-downloaded and attempted to install the update again.
  • Multiple retry attempts (as suggested in the top-rated answer) did not resolve the problem for me. But these instructions did work - thank you! – Jason Buberel Nov 17 '15 at 1:26
  • I was just going to add that you should be able to stop the wuauserv (Windows Update) service and delete the Download folder without having to boot into Safe Mode; alas, when I tried that, one file in particular named "WindowsUpdateBox.exe" could not be deleted despite no process having an open handle on the file. Strange, so I'm assuming safe mode gets around this. – TGP1994 Nov 30 '15 at 23:56
7

The error code 0x8024200D means, that the files had to be downloaded again.

//
// MessageId: WU_E_UH_NEEDANOTHERDOWNLOAD
//
// MessageText:
//
// The update handler did not install the update because it needs to be downloaded again.
//
#define WU_E_UH_NEEDANOTHERDOWNLOAD      _HRESULT_TYPEDEF_(0x8024200DL)

So try it again, or download the Windows 10 Version 1511 ISO, mount the ISO, run setup.exe and upgrade to the new build.

  • 2
    Ultimately, this is what fixed it for me. No amount of deleting the Download folder could get this update to go through. – TGP1994 Dec 1 '15 at 16:46
  • Nothing seems to work for me. Trying this yields a dialog box with title "Something happened", and text "Windows 10 installation has failed. I just mounted the ISO wiht magicdisk -- is that something reasonable? – Jimmy Feb 10 '16 at 22:57
  • @Jimmy which error code/message do you see? – magicandre1981 Feb 11 '16 at 5:03
  • Well it seems I'm having HDD issues. When I try to install the update using windows update, I was seeing "The device, \Device\Harddisk1\DR1, has a bad block" in the system log. Same thing with the downloaded version. So I'm going to try to replace the HDD and see if that fixes it. Will Macrium Reflect be able to clone a hard drive with bad sectors? – Jimmy Feb 11 '16 at 15:35
  • @Jimmy try it out and let us know. – magicandre1981 Feb 11 '16 at 17:18
-1

I found that my system partition of 100Mb had only 3Mb free space. The solution was to resize the partition to 300Mb by transferring free space from the C: drive partition.

I used this webpage as a guide.

  1. Take all the regular precautions, backing up etc.
  2. Download and install MiniTool Partition Wizard Free
  3. Install and run the program.
  4. Right click on the System 100Mb partition and select EXTEND.
  5. Here is the annoying part. The slider is over sensitive. So I weighed down my arrow key and had it go up 200Kb per second. It took a couple of hours. I extended from 100Mb to 300Mb. Do try the slider, you may get closer to your desired size before using a weight on the arrow key to refine.
  6. Apply, reboot, the program will resize and then try your updates again.

protected by Community Nov 26 '15 at 23:52

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.