72

When I have multiple keyboard layouts enabled, Windows 10 seems to switch between them randomly (similar to what's described here). I suspect I am accidentally pressing Win+Space, so I'd like to disable this shortcut.

However, looking at the "language options" page, I don't see any settings related to this keyboard shortcut, or a way to disable it. How can I disable this shortcut?

5
  • As long as you don't need multiple keyboard layouts you can "disable" the shortcut by removing the unneeded keyboard layouts - This is one of the first things I do on a fresh install.
    – Klinghust
    Jun 25, 2017 at 16:31
  • 1
    @Klinghust The default is to only have one layout, so I wouldn't have discovered this shortcut if I hadn't intentionally enabled a second layout! Jun 25, 2017 at 21:05
  • 1
    The default in Norway is two keyboard layouts - Norwegian and US English that's why I suggested removing one. -Kling
    – Klinghust
    Jun 27, 2017 at 15:25
  • @Klinghust Fair enough! Jun 27, 2017 at 16:23
  • 3
    This has confused me for 15 years. Finally I know why the language kept changing.
    – Anders_K
    Feb 20, 2020 at 9:14

8 Answers 8

29

Disable Win+Space keyboad-layout swap

AFAIK this is the only way to disable Win+Space keyboad-layout swap without disabling all other Win+XYZ shortcuts:

This is how to do it:

  1. Download AHK (AutoHotkey)
  2. Install AHK
  3. Right click any folder and choose New > AutoHotkey Script Create new script

  4. Right click the script and choose Edit Script Edit Script

  5. Replace whatever is there with this (and save):

    #space::
    
  6. Right click the script and choose Compile Script Compile script

  7. Run script by double clicking the newly created .exe and do a test. Rename it whatever you want and store it for the next time you want to disable the Win+Space shortcut.

Additional step to make it persistent:

Copy the .exe to the startup folder. Below I've listed the path for the folders:

Current user:

C:\Users\%Username%\AppData\Roaming\Microsoft\Windows\Start Menu\Programs\Startup

All users:

C:\ProgramData\Microsoft\Windows\Start Menu\Programs\StartUp

10
  • 1
    I was assuming you'd tested it, but I like to test answers myself before marking them "accepted"! I just commented because I made an exception in this case. Jun 29, 2017 at 21:30
  • 2
    I can confirm it works perfectly on a regular install. Thanks!
    – John Y
    Feb 16, 2018 at 12:54
  • 3
    Isn't it great how Windows makes options like 'switch between input languages' configurable, but this one you must have and want at all times? Thanks for the answer, helped a lot!
    – Mave
    Jan 22, 2020 at 9:24
  • 1
    I tested it on my Windows 10 Pro and it worked like a charm. Finally, I got rid of that annoying behavior.
    – Plicatibu
    Mar 3, 2020 at 13:16
  • 2
    Last time I tried a hotkey mapper like this I was banned from some online games because they thought I was using it to cheat. So be carefull with this if you play games that try to detect this kind of stuff as cheat. I gave up on this solution just because of that. I know Blizzard games will try to detect this and kick/ban you. I wonder why they left the Win+Space kotkey on without the option to turn it off (for so many years and after so many complaints).
    – Gus Neves
    Mar 4, 2020 at 1:36
39

You can also use the new PowerToys for Windows 10 to remap it. In my case I remapped it so that it brings up PowerToys Run when I press Win-Space enter image description here

4
  • 4
    This should be the accepted answer. While it does require an installation of additional software, it's still a Microsoft product (and it doesn't need be running to work). While the shortcut cannot really be disabled, it can be remapped to something inert or inconsequential (I've remapped mine to Alt Gr). And from what I could find, there is no better option than this. Jan 27, 2021 at 15:34
  • 6
    Helped me, I was able to remap "Win (left)" + "Space" to "Undefined" which effectively disabled the shortcut.
    – alx
    Feb 18, 2021 at 9:00
  • 2
    @Karlovsky120 Just a remark: I've just installed PowerToys v0.43.0 and the shortcut remap only works while it is running. If I close it, the shortcut goes back to the default behavior.
    – Alexandre
    Aug 27, 2021 at 14:43
  • This does not answer the question, the question is about disabling the shortcut not remaping.
    – gagarine
    Oct 6, 2022 at 23:39
26

This is an addition to the answer from Calsal, as I had the same problem that he described, but in Windows 10.

For Windows 10:

  • go to Edit language and keyboard options -> Advanced Keyboard Settings -> Language Bar Options -> Advanced Key Settings
  • select Change Key Sequence for Between Input Languages
  • change "Switch Keyboard Layout" to "Not Assigned"

enjoy the good life.  The Windows+Space option still works; if you want that, see the upvoted answer.

1
  • 2
    Thanks a lot! I took some time to discover that "ctrl + shift" was a shortcut for that, it was driving me crazy! Aug 21, 2019 at 20:00
16

I found this while experiencing the same problem as the OP, on Windows 10. My findings were that Calsal's down-voted answer was what actually worked for me.

My problem had nothing to do with the Win+Space hotkey. Instead, it was switching "randomly" to "ENG INTL" because the hotkeys for "Between Input Languages" were configured by default to switch the keyboard layout if you pressed "Ctrl + Shift". As a programmer who uses lots of hotkeys, I end up hitting "Ctrl" and "Shift" at the same time a lot.

2
  • 1
    You are correct that those settings can work for your case, but this is not what the original question is about.
    – JBert
    Mar 1, 2018 at 13:19
  • 13
    Still this answer may be helpful, because we not always ask what we should.
    – Jarekczek
    Mar 18, 2018 at 15:45
6

If you DON'T have multiple keyboard layouts enabled, but Win+Space keeps switching to other options anyway as if you had, you can just add those languages/keyboards under Language Options, then remove them.

In my case, I only had pt-br ABNT2 enabled, but Win+Space would act as if pt-br ABNT and English US were enabled too. By adding then removing them, Windows finally realized they were disabled, and Win+Space stopped popping up on the screen for lack of other options.

This is not the exact situation the OP was in, but it's a correct solution for when Windows is behaving as if it were in that situation.

4
  • 1
    This doesn't work if your keyboard layout belongs to the same language as the one you want to use. Jan 27, 2021 at 15:33
  • This worked for me! En-US was always available, en-GB is my default everywhere, could not get rid of the US language until I forcibly installed then removed it.
    – Doug
    Feb 22, 2021 at 9:48
  • THANK YOU! At first when I started adding the wrong keyboard back to remove it, it exploded and added 4 more, but by adding and removing them, I was finally back at my single preferred locale with single preferred keyboard.
    – DennisK
    Mar 2, 2021 at 13:34
  • Still works and is still necessary when W11 randomly decides to add languages and a Language Bar regardless of what your settings say. Note that you need to match the language and keyboard exactly to what appears in the language bar. Adding and then removing a language won't work unless it's added with the same keyboard.
    – Lilienthal
    Apr 21, 2022 at 13:10
3

You can directly open the dialog where you can configure the hotkeys using the following command:

Press Win+R and execute

"C:\Windows\system32\rundll32.exe" Shell32.dll,Control_RunDLL input.dll,,{C07337D3-DB2C-4D0B-9A93-B722A6C106E2}{HOTKEYS}
3
  • 9
    Explain more what this does and why it works, how do you know, and so forth. Aug 16, 2019 at 22:58
  • 2
    This is literally the command that is executed to bring up the last dialog when you follow @koen's answer. From there you can unassign the Ctrl+Shift keybindings.
    – pix
    Dec 11, 2019 at 10:57
  • 7
    There's no way to disable the Win+Space shortcut from that dialog. Mar 18, 2020 at 14:17
2

SEPT 2022 UPDATED ANSWER

For whatever reason the language bar settings allow you to disable the Ctrl+Shift shortcut, yet not Win+Space shortcut which does the exact same thing.

As suggested in an earlier answer roughly 2 years ago, you can accomplish this using Microsoft PowerToys. In the most recent release (currently 0.61.1 as of Sept/22) you can select the other tools that you won't be using such as "Color Picker", "FancyZones" etc. and select 'disable' on all of them except for "Keyboard Manager".

Within "Keyboard Manager" select "Remap a shortcut". Hit "Type" then press Win+Space. You don't have to set it to another keyboard key which 'won't do much'. Under "Mapped to:" you can simply use the dropdown menu to select "Undefined". The Win+Space shortcut will now do nothing.

Yes, the program does have to be running for the keyboard remapping to work. However, if you have all of the tools except "Keyboard Manager" disabled, it uses next to no system resources at all (<0.1% CPU, 5MB of Memory). If you set it to run at startup so you don't have to think about it, it won't at all increase your startup time either. I know most powerusers just hate to see any additional icon on that taskbar, but an icon is really all it is.

0

This has bothered me as well for a long time especially when I am playing games. The simplest way is to keep only the language that you'd prefer and remove the rest of them. It also clears the language option from taskbar and makes it look simplistic.

1
  • 1
    As it’s currently written, your answer is unclear. Please edit to add additional details that will help others understand how this addresses the question asked. You can find more information on how to write good answers in the help center.
    – Community Bot
    Mar 23, 2022 at 14:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.