5

I have a Logitech K800 wireless keyboard and Performance MX mouse running off of the same Unifying Receiver on Windows 10. All of a sudden, the keyboard doesn't type anything. The function keys work (I can mute, change volume, etc), but I can't input any numbers or letters.

The mouse still works just fine. The keyboard pairs correctly using the Unifying software and when I press a key on it, the icon lights up that the computer received input, but nothing happens.

I tried using the keyboard on another computer and it works just fine, so it must be a Windows issue. Strangely enough, my spare Mac corded keyboard works just fine (and that's what I'm using to type this)...

Searching for this issue and trying the few suggestions doesn't yield any success. Many recommend updating the device driver from the Device Manager, but the only keyboard listed is the corded Mac keyboard. Plugging the Unifying Receiver into different USB ports also doesn't change anything, nor does simply rebooting the machine.

What could possibly be causing this?

2
  • You might try uninstalling the wireless keyboard driver/software and reinstalling. Nov 15 '15 at 19:21
  • Reinstalling Unifying Software doesn't resolve anything, unfortunately.
    – scferg5
    Nov 15 '15 at 21:45
3

I found a solution that worked for me. Go to control panel - ease of access - make keyboard easer to use, then turn off "turn on filter keys"

3
  • 1
    This makes NO sense ... but it worked. I didn't reinstall, I just turned on filter keys, applied, turned it off again, applied, and then I could pair and type. I hate this kind of voodoo.
    – mhvelplund
    Jan 27 '20 at 8:17
  • @mhvelplund these are caused because of bugs on Microsoft's (or the company in general) account. So people figure out these "voodoo" stuff to circumvent them. I still strongly advice against wireless mice/keyboard devices.
    – KeyC0de
    Mar 3 '20 at 14:02
  • Just bought the MX Keys in 2020... had this issue instantly. And this worked 5 years later :P Nov 22 '20 at 11:13
2

For others with this problem, changing the Filter Keys option didn't make the keyboard work for myself.

However, after getting the keyboard to a state where the Function keys would work (such as muting the sound and so on) I restarted my computer with everything connected to it. After the restart, the keyboard worked as expected

1

I had the same problem with my K800. It was paired fine, but I took my laptop home from work and paired it with a different mouse and when I came back to work the keyboard wouldn't work. The mouse worked fine and the keyboard would pair but not type anything. This was fixed by changing the USB port the Unifying Receiver was plugged into.

1

"I found a solution that worked for me. Go to control panel - ease of access - make keyboard easer to use, then turn off "turn on filter keys"

I had the exact opposite be my solution. After uninstalling/reinstalling the software and turning off filter keys, it ended up working for me.

0

I had the same problem with a K750 and Performance MX: mouse worked fine, keyboard would seem to pair but no characters would make it to the computer. I tried the Filter Keys solution recommended here. No joy.

Finally, I unpaired the mouse and paired the keyboard. The keyboard started working. Then I tried to re-pair the mouse and it initially exhibited the same bad behavior that the keyboard had: it would pair but no mouse activity was getting to the computer.

Leaving the keyboard paired I exited and restarted the Unify software and tried to pair the mouse again from the Advanced screen and it immediately paired and started working. Now everything is good again.

0

Had the exact same problem with my K750. Seemed to be paired fine, and all the function keys were working, but nothing else. Looks like this is a Windows issue. I suspect that I had something sitting on a keyboard key, and Windows automatically started to filter all that input. I tried unpairing and repairing with no success, but toggling the Windows Keyboard filter worked like a charm.

-2

I fixed this issue by taking the following steps:

  • I uninstalled the keyboard from the devices under Device Manager
  • I rebooted

and the keyboard was reinstalled with the same driver.

Now it is typing fine.

0

Not the answer you're looking for? Browse other questions tagged or ask your own question.