17

I've recently upgraded to Window 10, and ever since then my backtick is not working. It's a keyboard with a US layout, and in my language settings this seems to be properly set up. When I switch to another layout (I used German for testing), the (physical) button is working. So the keyboard itself is fine.

Here are some pictures for reference:

Settings

language settings Input method

Keyboard

keyboard photo

21

Update (2018-07-05): Recent versions of Windows 10 may have changed the location of the settings menu. See the answer of @Wingu for an alternative.


I finally figured it out. The problem is that the Windows language switcher uses the tilde to switch between layouts. To fix this, go to Advanced Language Settings in the Control Panel:

Advanced Language Settings

Click on "Change Language Bar Hotkeys", which opens up the following dialog:

Advanced Key Settings

Here, click on "Change Key Sequence", and on the following dialog change the assignment away from the tilde/grave accent key. Or simply unassign it.

Final Dialog

7
  • Awesome, thanks for figuring this out! Hard to believe you and I are the only ones having this problem?!
    – Junuxx
    Jan 27 '16 at 6:45
  • 1
    I believe this is only a problem when you are using an input language with multiple layouts? Maybe? I also installed a Japanese IME a while back which needs a switcher for Hiragana, Katakana and Kanji. My wild guess is that this is why it got borked. Just a wild guess though. But yes, it seems like it's a fairly uncommon problem. Glad I was able to help though :)
    – exhuma
    Jan 27 '16 at 14:31
  • 2
    I had this problem with US international layout and Thai. I was really desperate because it makes it almost impossible to write markdown documentation with embedded code.
    – FSMaxB
    Sep 7 '16 at 1:22
  • Just logged in here to say thank you! this is my problem since May this year! I did so many tricks but this one is a life saver :) Good job mate! Dec 2 '16 at 3:56
  • 1
    This doesn't solve my problem, but I'm upvoting because I didn't know that backtick can be used there (already unassigned both sequences long time ago).
    – Wirone
    Jan 11 '17 at 15:35
6

I have Windows 10 yet I cannot find Advanced Language Settings in the Control Panel so to the others who have the same problem, heres how I found it and follow the instructions by exhuma!

Open Windows Settings and search for Region and language settings

In related settings, you will find Advanced Keyboard Settings

In Switching input methods, you will find Language bar options

Then continue to proceed with exhuma's instructions after the first image included.

1
  • Thanks for noticing this. I've added a link to this answer to my original answer so you are properly credited and have a chance to get upvotes. Credit where credit is due! ;)
    – exhuma
    Jul 11 '18 at 10:59
2

I experienced a similar issue with the backtick key not working directly -- on the second keypress, it would type two backticks. This was interfering with my use of Ctrl-` as a shortcut in my IDE.

The solution I found was to change Language Setting to English (United States), to use the 'US Keyboard' settings.

Windows Language Settings page

As a side note, I would tend to observe that Windows 10's Settings UI -- being a mixture of new pages, links to older dialogs, and Control Panel -- is a sodden mush of dog's breakfast which makes most tasks harder & more confusing rather than clearer.

0

Found faster way for windows 10 (20190417) :

Search for "Language Bar Options" then follow the "Change Key Sequence" instructions posted by exhuma : https://superuser.com/posts/1003913/revisions

1
  • I can't reproduce this. Where exactly do you search? In the start menu? Which build number of Windows is this? The value you specify 20190417 does not seem like a build number. Can you add these details? If I am able to reproduce it I will add it to my updates and redirect people to this answer as well.
    – exhuma
    Apr 18 '19 at 8:24

Not the answer you're looking for? Browse other questions tagged or ask your own question.