4

I have configured a Windows Server 2008 guest on VirtualBox v5.0.10 on a Windows 8 host laptop. They work fine and ping each other on bridged mode, IP address are served by a wireless router.

Whenever I take the laptop off the Wi-Fi network, this setup no longer works, so I have switched to a host-only config with DHCP server enabled.

By default, Windows places all networks as public, and I was unable to change it until I found this article which says that you need to provide a default gateway entry for the NIC to be able to set the network location. After doing that (set gateway to host IP address), I could change the location and could ping the guest from the host.

I did the same on Windows 8 host. When I changed the gateway address to point to the guest IP address, I was prompted from the charms bar: "Do you want to turn on sharing between PCs and connect to devices on this network?". I chose Yes. Now the guest can ping the host.

Problem is, now I can't access that same configuration again. I followed this tutorial but the "VirtualBox Host-Only Network" adapter won't show on the network list (I'm not running Windows 8 Pro, so I don't have "Local Group Policy Editor" gpedit.msc). I would expect something like this below, but I don't see the "Connections" section, only Wi-Fi:

Screen shot of the Networks charm bar with the lists connections and wi-fi][1

From reading this answer to a different question, my guess is that because the network card on the host side is virtual, it's hidden from the charms bar network configuration.

So how can I alternate the "Network location" between Public/Private for the "VirtualBox Host-Only Network" adapter on Windows 8? Is there a way to make it visible on the "Connections" list?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.