0

I bought 2x2 GB Transcend DDR2 paired sticks for my PC and detached my old 2 GB stick. My Windows 7 shows 4GB(2GB usable). In Resource Monitor it says 2 GB is hardware reserved. I checked all hardware compatibility and everything is okay. Check both stick solo and they work without a problem. I followed the manual and plugged them in the right spot. Even CPU-Z says that I have 4 GB that are running in dual channel mode.

I haven't found any options in bios that might help me. I tried editing stuff in msconfig like some forums said. The stuff with the maximum memory. I even tried editing the virtual memory page. My specification is:
Processor AMD Athlon II X4 620
Motherboard M720-US3 Gigabyte
RAM Transcend TQ243PCF8
OS is Windows 7 Professional 32 bit(I know this might be an issue but it should give me at least 3.2 GB)

Any idea where I should start searching for the problem?

  • BIOS is up to date – jasaleja Nov 16 '15 at 1:44
  • spend some time checking out ALL (because some are different) the various answers at superuser.com/questions/56157/… , what to check in your bios, and how to check in windows device manager. – Psycogeek Nov 16 '15 at 3:21
  • 1
    What graphics card? – qasdfdsaq Nov 16 '15 at 3:30
  • It is an external graphic card. GeForce GTX 260. – jasaleja Nov 16 '15 at 21:48
0

32-bit Windows doesn't guarantee that any amount of RAM will be accessible. Usually it's between 3.3-3.5 GB, but it depends on your hardware and how BIOS maps memory. Some systems will report only 3 GB usable, some will run with 3.7 GB or so. It's very likely that 32-bit Windows is the culprit.

You can download 64-bit version of Ubuntu, make a bootable USB flash disk, boot it and see if it detects 4 GB of RAM. It won't affect your system and you'll be sure.

  • I will try this with Ubuntu. It will give me the best insight if it is up to Windows or hardware compatibility. – jasaleja Nov 16 '15 at 21:49
1

I have seen this issue in 2 separate cases.

  1. As Gronostaj said, Windows 7 32-bit will only recognize up to 4gb of RAM. With that being said, it usually only allows ~3.5gb RAM for processes while observing the entire 4gb. Anything above 4gb will not be recognized by the OS and deem it unusable.
  2. The other possibility for the error you are receiving is with Compatibility. There have been instances where certain brands, speeds or sizes of RAM are not compatible with other certain brands of hardware. When this happens with RAM and Motehboards, you will receive this "reserved RAM" issue and you will be unable to use your system's full capacity. The best thing to do is to check with your Manufactures RAM compatibility list to ensure that it is compatible and that is has been tested.

With that being said, here is a link to your specific motherboard "Tech-Specs" - http://www.gigabyte.com/products/product-page.aspx?pid=3006#sp -

The next thing to check would be the Memory Support List for your board, which you can find at this link: http://www.gigabyte.com/products/product-page.aspx?pid=3006#dl - Just enter Windows 7 32-bit and you should see a link for the Memory Support List. Ensure that your Memory is compatible. If not, it may be best to look at getting a set that is.

  • As I have said in my post, I have pre-checked all hardware compatibility before posting anything. All the ones you mentioned. I will try Windows 64 bit. – jasaleja Nov 16 '15 at 21:45
1

Your BIOS is set for a 64-bit operating system. Look through your BIOS settings for a setting called "memory remapping". Turn it OFF.

Your BIOS is leaving as much room as possible for low mapping, moving memory out of the way. For a 64-bit system, that's great, since it can access the memory anywhere and likes to have lots of space for hardware mappings. But a 32-bit OS can't access the remapped memory.

Make sure to turn it back on if you switch to a 64-bit operating system.

  • I don't have that option in my BIOS. – jasaleja Nov 16 '15 at 21:50
  • 1
    It may have some other name, but you probably have some such option in your BIOS. – David Schwartz Nov 16 '15 at 22:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.