2

On my PC, I have IIS running.

First, I verified I could access the text file C:\inetpub\wwwroot\test.txt by browsing to http://localhost/test.txt.

Next, I substituted my IP address, and browsed to the same file: http://192.168.2.207/test.txt.

So, I passed this URL to a coworker, but it times out for him: http://192.168.2.207/test.txt

If I go in and turn off Windows Firewall, he can access the file just fine.

I cannot find the settings for IIS on Windows 10.

How do I configure IIS on Windows 10 to allow other PCs on the network to browse files and folders in my wwwroot folder?

Some seem to think this post answers my question:

Allowing Remote Connection in IIS on Windows 7

Not really. That question is about Windows 7. Windows 10 is a much different animal.

2

Windows must have corrupted my IIS install.

Windows+R to pull up the Run Command.

Enter OptionalFeatures.exe to pull up Windows Features.

Uncheck the Internet Information Services box.

Click OK to save.

After Windows finished, do these steps again to bring up the Windows Features dialog.

This time, while checking Internet Information Services, I also check the Internet Information Services Hostable Web Core below it.

Click OK to save.

When Windows finishes, my IIS folder was in the Windows Administrative Tools folder (filed under W in Windows 10).

screenshot

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.