I have a very simple home network system. I'm trying to replace an older 10/100 4-port switch with a new gigabit 8-port switch to support additional computers without much luck.

Configuration is:

  1. Cox internet cable service directly into a NetGear C3700 Wifi Cable modem router (we do not subscribe to cable TV). Modem wifi is turned off for now but might be used later. The router has two gigabit ports; one feeds several computers in the basement via a NetGear GS308 8-port switch (which works fine now), and the other drives a cat6 cable to the upstairs.

  2. The upstairs network currently has a Linksys EZXS55W 5-port 10/100 switch which works great but doesn't have enough ports to support a new additional PC. I've tried replacing it with both a D-Link DGS-108 and a NetGear GS308 8-port gigabit switch, but when I do, I lose internet connectivity on the upstairs PCs. Pings to the cable modem time out more than 50% of the time, and browsers on the upstairs machines can't get to the outside.

If I use the 10/100 switch with a single PC behind it upstairs it connects to the modem, receives an IP address via DHCP fine, does not drop any pings to the modem at all, and connects to the internet well. If I simply replace the 10/100 switch with one of the gigabit switches, most of the pings fail and I have extremely limited internet access.

This isn't rocket science, it's simply replacing an old switch with a new switch, which should be bulletproof. But I can't get it to work with any combination of cable plugin order, power cycles, etc. Is there something about 8-port gigabit switches that they're not telling me (yes I've read the manual many times over, it's not that deep)? The only difference I can see is that the 10/100 switch has a dedicated WAN port (which is what I plug the cat6 going to the modem into) and the 8-port has auto-sensing.

Please help...thanks.

UPDATE: I've ruled out cabling and other problems. I took one of the upstairs machines to the basement, plugged it directly into the router's "upstairs" gigabit port with a brand new 10' cat6 cable and verified I could always connect (download speeds > 100Mbps). Did the same thing with a second new 10' cat6 and it also worked fine, > 100Mbps. Now I have two proven cables, so the cables/router/PC are not the problem. Putting the old 10/100 switch between the router and the PC with the known good cables dropped it to ~18Mbps but it was still solid, no dropped pings. Replacing the 10/100 switch with either the D-Link or the NetGear gigabit switches dropped pings to the router more than 50% of the time ("Request timed out") even though the speed indicators on the switches showed they were connected at gigabit speeds. The connection was bad enough that I couldn't even open a browser to perform speed tests.

I took the PC back upstairs and plugged in the "upstairs" cable directly to it (100' cat6 routed through the furnace chase). It worked fine, pulling in ~80Mbps consistently. This was in the evening and Cox sometimes throttles bandwidth even for customers who are paying for the highest speeds (my contract reads 125Mbps), and it was obvious that the connection was being throttled at this time so I'm not too worried about the speed drop.

However, once I use one of the gigabit switches on the end of the 100' cable and try to fan out to the existing machines upstairs it all goes dark again...dropped pings, no connection, just like in the basement. It's bizarre.

  • 3
    That sounds like a cabling problem. Gigabit ethernet requires all eight wires be correctly connected. You could have split pairs or some other problem in the wiring. Just because all eight are connected straight through doesn't mean they are correctly paired. Fast ethernet only uses two pairs.
    – Ron Maupin
    Nov 17, 2015 at 6:58
  • 1
    Did you (start to) systematically rule out the possible sources of the problem? What happens if you e.g. place your upstairs equipment downstairs and connect the two switches with a shorter cable? Etc.
    – Run CMD
    Nov 17, 2015 at 6:59
  • This is almost definitely a cable whose pins are not mapped to pairs correctly. Nov 20, 2015 at 1:14
  • So, when you use the gigabit switch upstairs, are those computers on DHCP or are the addresses being set statically? Are computers upstairs getting DHCP from the router without issue? I have to agree with the other commenters that it sounds like a cabling problem. A dumb switch, regardless of speed, does not have any characteristics that would stop it from working other than a cable with some issue between the two endpoints.
    – Richie086
    Nov 20, 2015 at 2:25
  • All computers are on DHCP served from the modem in the basement. When I hook up the long cable going upstairs directly into one of the PCs it retrieves an IP address without problem. If I use the 10/100 switch upstairs, all PCs tied into it also get IP addresses from the modem. If I use either gigabit switch upstairs I can't get IPs to renew, presumably because the pings to the modem also fail most of the time. There is an older print server hub upstairs that has a static IP (just to keep things simple) but that IP is outside the range the modem is configured to serve out.
    – Tim
    Nov 22, 2015 at 1:27

1 Answer 1


Since the 10/100 switch has an uplink port and the gigabit one doesn't, try using a cross-over cable between the modem and the switch.

  • Both gigabit switches have built-in Auto-MDI/MDIX on all ports, so using a crossover cable will just make the port it's plugged into flip modes...won't it?
    – Tim
    Nov 22, 2015 at 1:47
  • Logically it should, but I had a nearly identical situation where the only solution was the crossover cable. Nothing I could do would get the straight cable to work.
    – user76732
    Nov 22, 2015 at 16:05
  • Finally found a "real" gigabit crossover adapter that fits on the end of a regular gigabit cable and tried it. With or without it in place on the end of the feed cable, the new gigabit switch upstairs simply will not connect with the router properly. Pings are dropped, and there's not enough connectivity to even bring up a simple Google page (fails lookup). I think I'm just going to chalk it all up to "equipment won't talk to each other even though it's the same manufacturer" syndrome. Ridiculous and frustrating.
    – Tim
    Jan 1, 2016 at 0:45
  • You're right, this can be frustrating. To make sure that I've got this right- you can plug in an"upstairs computer" anywhere downstairs or basement and it works fine. Upstairs into a gigabit switch - with or without crossover adapter- it fails. Have you actually replaced the cat6 cable to the upstairs with another cable? It just seems like the fail point is that cable.
    – user76732
    Jan 1, 2016 at 1:30
  • I have not yet replaced the cat6 cable going upstairs. I agree, the cable seems to be the culprit. However, I can connect a new Linksys AC1600 Wifi router configured as a slave router (i.e. DHCP turned off; it also has 4 gigabit ports) to the upstairs side of the cable and get very reasonable speeds out of it, both for upstairs PCs wired into the AC1600 ports and for several devices via the wireless (currently testing at 125+Mbps for wired).
    – Tim
    Jan 4, 2016 at 2:23

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .