105

enter image description here

Image of Word icon

If this is a duplicate post, my apologies but I couldn't find one. On some icons I am seeing a two blue arrows at the top the right pointing towards each other. I first noticed it on the icons on folders which I archived which happened randomly. I archived the folder and the text went blue as expected, then when I went to the folder again the text was black and the folder icon has these arrows. When I just recently installed Office 2007, I noticed the same arrows on the icons for the programs.

OS: Windows 10 Pro 64-bit (the latest update: 1115) Application: Microsoft Office 2007 suite and file explorer

  • 7
    It is supposed to indicate NTFS compression. Right click on the partition/volume in question select properties, and see if it is on? – Psycogeek Nov 17 '15 at 21:28
  • @Psycogeek Yes, the volumes are all NTFS. – Dominic JL Nov 17 '15 at 21:45
68

I archived the folder and the text went blue as expected...

Blue text in Explorer = NTFS compression is enabled via the properties (this has been standard in Windows for many versions now).

enter image description here

Two blue arrows is Windows 10's new way of showing the same thing, at the icon-level.

enter image description here

Reference/More info:

edit:

When I just recently installed Office 2007, I noticed the same arrows on the icons for the programs.

That's kind of weird, and is may be just a matter of icon cache corruption.

For that, here's a couple things to try:

Ensure the EXEs are not actually compressed.

Try creating new shortcuts to the EXEs and see if they appear as expected.

Try clearing Windows' icon cache and see if that corrects the icons. For that, see this existing SU question: Refresh Icon Cache Without Rebooting

  • Cheers, but why then would the office shortcuts be compressed? The .exe files are not archived, only apparently the shortcuts. When I then try to uncompress them they are not compressed. – Dominic JL Nov 17 '15 at 23:38
  • @DominicJL You're right, sorry about that. I would have suggested exactly what you did as laid out in your answer -- try recreating the shortcuts, and/or clearing the Icon cache. :) – Ƭᴇcʜιᴇ007 Nov 18 '15 at 13:01
  • Interesting, I seem to get this when I generate an advertised shortcut with WiX, but I checked the compression property and it's disabled. – Drazen Bjelovuk May 16 '16 at 3:10
8

The real problem seems to be a bug: the (Office) shortcuts refer to icons that are in %systemroot%\installer... and these folders are now compressed so also the icon is compressed. Workaround: create new shortcuts that refer to the (uncompressed) executables. (or uncompress the installer folders: not recommended).

6

To elaborate on the potential root cause, this will occur more often on Windows 10 systems that are running relatively low on free disk space. The Windows Update process will automatically compress files and folders to ensure that crucial operating system patches will install successfully:

Compressing files

To help free up disk space, this update may compress files in your user profile directory so that Windows Update can install important updates. When files or folders are compressed, they appear as having two blue arrows overlaid on the icon. Depending on your File Explorer settings, you may see icons that look larger or smaller. The following screen shot shows an example of these icons.

Compressing files

After you install the update, your files are restored to their original state, and the blue arrows disappear from the file icons in File Explorer. At any point during the update process, you should be able to access your files.


Sources:
Windows Update - KB4023057 Release Notes
Microsoft trying to push KB4023057 again to user systems

  • Hell, I didn't know about this behaviour until it happened to me today. I downloaded 2GB of ebooks and my C drive free space fell to about 10GB. The Advanced properties fixes mentioned here work for me. – Dizzley Jan 4 at 12:02
5

This does indicate compressed files and in my experience had some broken behavior with shortcuts, so I "fixed" it a few weeks ago. You can hide this overlay in the same way as people have been hiding the shortcut arrow overlay for years, it's just a different number key in the registry.

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Shell Icons]
"179"="empty.ico,0"

Put a blank icon file in Windows/System32 and perform the registry change above (easiest way is to copy the above and paste in to notepad, save as a new file with the .reg extension, then double click that file).

If you're doing it manually that's a String/REG_SZ value, and you can of course put a full file path there if you don't want to put things in System32.

You can read about how I found this out, download an empty icon, enable/disable .reg files and a batch file to both copy the icon and run the registry change on my blog: http://nerdshack.info/windows-10-and-double-arrow-icon-of-death/

Hope that helps :)

5

The files under Desktop folder have same issue. I solved problem using below steps.

  • Right click to Desktop folder.
  • Click to Advanced button
  • Unchecked compress contents to save disk spaces. Click Ok, ok and apply buttons.

After these steps, arrows should be disappeared and also you can use below command to clear icon cache.

ie4uinit.exe -ClearIconCache
4

I ran into this when building installers with InstallShield. The solution was to edit the shortcuts "Behavior" from "advertised=YES" to "advertised=NO".

  • 1
    This is absolutely true for the InstallShield shortcut icons. If 'advertised' is set to true, the shortcut file mapping information is coming from MSI database whilst non-advertised (normal) one is from the target directly. The benefit to take this way is the self-maintenance using MSI database. eg. missing files can be recovered from MSI. However, the problem here is, that MSI database itself may be compressed to save disk spaces, which is reasonable as they won't be accessed frequently. Therefore, all were just doing their parts - and simply we don't like the result of that. – Scott Rhee Oct 18 '16 at 3:39
  • 1
    Thanks for the explanation! Also, thanks for the up vote. I was previously down voted on this, which I find irritating when I post a useful and proven answer! Especially when no comment is left was to why someone wants to burn their own rep points to discredit me. – BuvinJ Oct 18 '16 at 12:26
3

I didn't find out the problem, but I did come up with a solution. I simply remade the shortcuts from the .exe files, deleted the old shortcuts and the icons were as usual. Perhaps this is just a bug with Windows 10 like some apps have the icon of other apps.

2

Other answers have provided great solutions. It's also important to know that if your Hard Drive storage becomes too low, Windows automatically compresses your files (as indicated with the arrows in the upper right hand portion of your icons). So when the other user here mentions they "just recently installed Office 2007, I noticed the same arrows on the icons for the programs" - it may not be Office 2007 as much as the installation subsequently ran storage space very low.

You can turn off this compression by changing your settings via the following steps:

Settings / Windows Settings -> System (Icon) -> Storage (left hand column) -> "Change how we free up space automatically" (Blue hyperlink) -> Storage Sense (Toggle) -> Turn Storage Sense off.

Hope this helps explain to some people why this was happening and an easy (eg non Powershell) method of 'fixing' things.

  • Personally, I'd rather have windows compress some files as opposed to failing some potentially important save/install/etc operation because I was too preoccupied to realize that I was low on space. It's not a particularly invasive feature, but I didn't know it was toggle-able so thanks for pointing it out. – b1nary.atr0phy yesterday
1

Or you could just look up the root folder and uncompress it, if its the harddrive, untick the box. Otherwise you have to right click the folder, properties, general, advanced and untick the compress box.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.