3

Could you please any one help me?

I'm getting following error message "error: rpmdb: damaged header #1439 retrieved -- skipping." while I'm trying to install Samba server. I tried Google search but unable to solve my problem.

4
  • What distribution are you using? If it is Fedora, please add the full output and the command you are issuing.
    – skytux
    Nov 18, 2015 at 18:10
  • Thank you for answering my question I'm using CentOS kernal ver 2.6.32-573.8.1.el6.x86_64 CentOS release 6.7 (Final) Nov 18, 2015 at 20:00
  • sudo yum -y install samba I'm using this command to install samba Nov 18, 2015 at 20:19
  • You shoudn't tag this question as ubuntu or fedora, but anyway I'm going to write an asnwer that I think it is the one that will solve your issue.
    – skytux
    Nov 18, 2015 at 22:25

1 Answer 1

11

It seems that the RPM database is corrupted in some way, so you should try to restore it:

sudo rm -f /var/lib/rpm/__db*

and then rebuild it:

sudo rpm --rebuilddb

Hope this helps!!

5
  • Thank you skytux my problem has been solved. and sorry for the wrong tagging. Nov 19, 2015 at 20:39
  • I'm glad you solved your issue! :)
    – skytux
    Nov 19, 2015 at 22:21
  • You are free to vote if the answer helped you!! ;)
    – skytux
    Nov 21, 2015 at 17:29
  • I'm unable to vote your answer. Nov 23, 2015 at 15:27
  • Hmmm, didn't have that file/directory, the rebuild command trew another, different error, but a second rebuild command finished without error. After, the initial error about damaged headers was gone.
    – sweber
    Sep 4, 2017 at 18:07

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .