11

I was tired to do everything indicated on net. I am using Genymotion to start virtual device but when i start device it's gives me that error Error Image

Note: When i start virtual operating System Linux it's successfully started.But when i am trying to start Samsumg Galaxy S2 it's give me error

Failed to open a session for the virtual machine Samsung Galaxy S2 -

4.1.1 - API 16 - 480x800. Failed to open/create the internal network 'HostInterfaceNetworking-VirtualBox Host-Only Ethernet Adapter'

(VERR_INTNET_FLT_IF_NOT_FOUND). Failed to attach the network LUN

(VERR_INTNET_FLT_IF_NOT_FOUND). Result Code: E_FAIL (0x80004005)

Component: ConsoleWrap Interface: IConsole

{872da645-4a9b-1727-bee2-5585105b9eed}

I am using Windows 10 Pro.Before update Windows 10 it's virtual device start's successfully. But when i update windows it's not running. I try everything. uninstall reinstall VB. But it's not working. Please someone helps

21

I had exactly the same problem as you, tried everything, but the solution is really easy:

  1. Open network center
  2. Change adapter settings
  3. Right click your Virtualbox host-only adapter and select Properties
  4. Enable "Virtualbox NDIS6 Bridget Networking Driver" (if it's disabled - if it's not, see next)

If the checkbox in step 4 was disabled, VB should work just fine now (no reboot needed). Otherwise repeat steps 3-4 for every network adapter you have (Ethernet, WiFi...) and always uncheck the NDIS6 checkbox -> apply -> check it again -> apply.

Hope this helps - worked for me on 2 different machines (it seems that this is caused by last Windows 10 update - thanks Microsoft for wasting another 4 hours of my life).

  • 1
    Thanks bro...but i uninstall windows updates after that i am getting this error. I created another host-only adapter after restart it's successfully running. – viratpuar Nov 18 '15 at 12:36
  • Thank you for saving (at least!) 4 hours of my life! The same Windows update had been in a failed-install state for a couple months, and when I finally fixed that sufficient for it to finish installing I was rewarded with this error. ;) – pztrick Jan 14 '16 at 23:47
  • Thank you very much. Same problem here but linked to Vagrant not being able to pull up any VM anymore. Solved as you described :) – Stefano Fratini Jan 21 '16 at 5:14
  • Absolutely incorrect answer cannot believe this is being suggested! The HOST-ONLY adapters (Virtualbox/VMware) DO NOT BRIDGE anything - they are HOST ONLY! Enabling BRIDGING on them is incorrect. Don't believe me? Install VMware and look at it's adapters the BRIDGING adapter DOES need it enabled - the HOST ONLY does not and should not. If you need it - you have something mis-configured. – Collin Chaffin May 15 '18 at 16:55
  • @CollinChaffin Easy, pal. It has obviously worked for 20+ people. I don't care if it's not the "proper" way to fix the error - it's one of the easiest and fastest. You can provide a better one. I believe this is only a matter of terminology; yes, the adapter (and connection) is host only, but the VB driver is still called "Bridget Networking Driver", no matter what. But feel free to reach out anytime with another clever note. – mxmx Sep 9 '18 at 13:42

protected by magicandre1981 Jan 13 '16 at 17:34

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.