0

I can't understand how is this possible:

If I use two 4GB memory kit-s (4 modules, 8GB total) as soon as I boot there are ext4 errors (missing files, mysql indicates InnoDB corruption, etc). It's Ubuntu 14.04.3 LTS 64 bit.

Still, memtest86+ does not show any errors (v4.2 or v5.01). I ran it for 5 hours, 3 passes.

If I replace a kit with a smaller one, or just use one kit, the ext4 errors disappear, machine runs flawlessly.

Probably related thing: with the two failing kits the machine can't even shut down properly, the fans start to run at maximum speed and the machine never stops. This also happens if booted from pendrive, so it's not a corrupted config file.

My question is: is there a way to use these to kits in a reliable way, or in fact the memory kits are incompatible, but memtest86+ isn't capable to detect that.

update: corrected memtest name to memtest86+

update2:

  • The machine is a hp dc7900 ultra slim with 4 DDR2 memory slots.
  • OS: Ubuntu 14.04.3 LTS 64 bit
  • 1st kit: CSX 2x2GB 800 MHz, 2nd kit: Kingston kvr800d2n5k2/4g 2x2GB 800 MHz

These two kits separately work good, and even with other smaller kits or single modules. Only these two kits together produce the weird ext4 errors. But Memtest finds no problems.

I'm thinking that maybe the total of 8GB is the problem, not the memory modules themselfs. The maschine works with 4GB or 6GB just fine.

  • @Psycogeek Sorry, it's memtest86+ I just remembered the name wrong. – EdgarPE Nov 18 '15 at 13:03
  • Provide specific hardware information if you want help. If the system is not stable with the 4 GB modules logic would indicate they are not compatible. – Ramhound Nov 18 '15 at 13:23
  • I recently put a similar question here and recevied no answer, that is because there was no answer. For me installing 8GB of ram cause video card hardware acceleration issues, everything else worked fine. Then I found the specs page of my HP xw6400 and it says that it cannot work with more than 4GB of non-HP ram. Unfortunately your page: support.hp.com/ro-en/document/c01570345 is not that detailed, it just says that it supports 8GB. So if you really need 8GB try putting your hands on some modules manufactured by HP other than that there is probably nothing else you can do. – soger Oct 15 '18 at 22:02
0

Memtest86+ is not designed to detect incompatibility issues. it reads and writes specific addresses in the direct mode without splitting modules into channels/banks. So, basically it is clear why it gives to errors - all the memory cells are fine.

To address the issue I advise to try to update BIOS and to try different combinations of the modules in different slots. Depending on the chipset and BIOS dual channel modes can be realized differently (with or without interleave/Asymmetric modes).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.