40

I have just got a new laptop with Microsoft Windows 10. My previous laptop ran Windows 7.

I'm trying to get applications to "run as administrator" by default, so that I'm not constantly having trouble saving/overwriting files, etc. The priority here is to be able to modify my own files on an external hard drive; I wouldn't have expected that I'd have to do anything special to be able to do this. My user account on the laptop is an "Administrator" account, and I have set the User Account Control setting to "Never notify". I thought that this would achieve the effect I want (as also suggested in this related question in relation to Windows 7).

Here's a screenshot of my setting to disable UAC in Windows 10: User Account Control Settings

Still, Notepad++ (for one) is not automatically starting with administrative rights. What else do I need to do, or what am I overlooking?

Thanks

PS. I'm aware that what I'm trying to do is a security risk, but that's not the point of this question; whether I should or should not do something is different to whether I can or cannot do something.

  • 2
    Considering you cannot fully disable UAC in Windows 8 and above I am not sure how you followed the related question's answer. You can normally do this by setting the shortcut to the application in question to always run as an Administrator. You do understand what you are asking is a HUGE security risk on your part, always running stuff as an Administrator, is how the randsomware malware encrypts your files (the process requires Administrator permissions ). – Ramhound Nov 18 '15 at 12:36
  • 2
    If you’re “constantly having trouble saving/overwriting files, etc”, you should probably rethink the way you use your computer. This type of stuff just doesn’t happen, ever, when normally using a computer. – Daniel B Nov 18 '15 at 14:31
  • @Daniel It may be something simple that I've overlooked, but without running Notepad++ as administrator, I don't seem to be able to overwrite simple text files that I have on an external hard drive. I consider this to be "normally using a computer". I know I could right-click the Notepad++ icon to run as administrator, but I generally run Notepad++ by right-clicking on a text file and using the Explorer context menu to open in Notepad++ and that doesn't seem to run Notepad++ with admin rights. – osullic Nov 18 '15 at 16:31
  • @osullic You should change the access control lists on those files so your account has Full Control. Running as elevated admin all the time is way overkill. – Ben N Nov 18 '15 at 16:37
  • Thanks @Ben, that sounds like a better solution. How do I change the access control lists? Is that by right-clicking on a file/folder and changing permissions in the Security tab? – osullic Nov 18 '15 at 17:11
23

Updated answer: solving the problem instead of answering the question.

To change the ACLs on the external drive, open its properties and go to the Security tab:

disk properties - security

Notice that Authenticated Users doesn't have "Full control"; only Administrators does, and you're not really a member of Administrators unless elevated. Click Advanced.

advanced security

(The owner will probably be Administrators.) Click Add.

adding a permission entry

Click "Select a principal", and type your username in the box. Check "Full control", then click OK.

Now that we're back in the advanced ACL editor, check the box that replaces child item ACLs. Click OK and accept the warning. Click OK on the properties window, wait for the operation to complete (if there is one), and you're done.

The original (dangerous) answer follows below the line.


Danger! This is almost certainly a bad plan, for reasons explained in Ramhound's comment.

Run gpedit.msc to open the Local Group Policy Editor. Expand Computer Configuration, Windows Settings, Security Settings, Local Policies, and Security Options. Four settings need to be updated:

  1. Set "User Account Control: Behavior of the elevation prompt for administrators in Admin Approval Mode" to Elevate without prompting.
  2. Set "User Account Control: Detect application installations and prompt for elevation" to Disabled.
  3. Set "User Account Control: Run all administrators in Admin Approval Mode" to Disabled.
  4. Set "User Account Control: Only elevate UIAccess applications that are installed in secure locations" to Disabled.

The LGPE automatically saves all changes, so exit it and reboot.

Again, this is a very insecure configuration that you're creating here.

  • 4
    I should add doing what is suggest will break ALL Windows Store applications in Windows 10. This includes the default applications like Calculator and the new way to access the control panel. – Ramhound Nov 18 '15 at 14:27
  • Thanks for the solution. I'm surprised that this problem and solution are not more widely encountered/publicised. – osullic Nov 18 '15 at 17:34
  • @osullic - It is widely encountered but in 99% of the cases an application only requests elevated permission when its required and most people are fine with that. This will come at a shock to you. Running with Full Control set to certain directory will still present problems. – Ramhound Nov 18 '15 at 17:41
  • 4
    Thanks for the "dangerous" solution! It helped. I'm a programmer, working 20 years with computers. I know what I download and what I do and what I run. I have an antivirus and a firewall. I always have all the necessary latest security updates. That's enough! I don't want freaking Windows to prohibit me from saving a file where I want it to be saved and I don't want to explicitly run the program as Administrator. I hate this shit. Again, thank you! – nightcoder Dec 7 '17 at 18:25
  • 1
    @setec You might need to change the owner to yourself or Administrators before granting yourself full control; some folders are restricted and initially owned by TrustedInstaller. – Ben N May 14 '18 at 17:03
19

It looks like there are a few options to run an application as administrator by default that you can try.

  1. Right-click the application's Shortcut >> Go to Properties >> Click the Advanced button on the Shortcut tab >> Check the "Run as administrator" box >> Click OK. -

enter image description here

  1. Right-click the application >> Go to Properties >> Click the Compatibility tab >> Check "Run this program as an administrator" >> Click OK. -

enter image description here

Note: While trying my second option (above), I had one application that didn't initially have the "Run this program as an administrator" checkbox. I had to do the following to get the checkbox to appear and to always run as an administrator:

  1. Click the "Run compatibility troubleshooter" button
  2. Click the "Troubleshoot Program" option
  3. Check the "The program requires additional permissions" checkbox.
  4. Click "Next" and click the "Test the program..." button (to verify the program runs properly).
  5. Click "Next" and click the "Yes, save these settings for this program"

Bill Garrison confirmed that the solution found at How can I run ALL my Apps “as administrator” by default in Windows 7? works for Windows 10. There is at least one other method, you can set UAC to the lowest setting, but doing so also causes the Windows 10 native apps (like the calculator) to fail.

Below is the quoted answer:

Add User To Administrators Group And Remove From Users Group:

  1. Log In As Administrator

  2. Go To Run ( WinKey + R )

  3. Type "control userpasswords2"

  4. Select Your Account And Click On "Properties"

  5. Select "Group Membership" Tab

  6. Select "Administrators"

  7. Click OK And OK

Disable Approval Mode

  1. Log In As Administrator

  2. Go To Run ( WinKey + R )

  3. Type "secpol.msc"

  4. Go To Local Polices > Security Options

  5. Find "User Account Control: Switch to the secure desktop when prompting for elevation"

  6. Open It Click Disable It And Click Ok.

  7. Restart Computer( Very Important Log Off Doesn't Work )

  • I provided edits to your answer, in a hope, you now can see what we expect out of answers. – Ramhound Jul 22 '16 at 15:50
  • Unfortunately, my reputation wasn't high enough to embed the images (vs the links I posted), but thank you for the edits. – majestzim Jul 25 '16 at 19:29
  • My comment had nothing to do with the images but everything else (text) – Ramhound Jul 25 '16 at 20:00
  • 2
    This is not running everything as admin. You have to repeat it for every application that you want. See answers from @fritzmg or mine on how to run everything as admin. – Dio Phung Mar 24 '17 at 0:46
12

To disable UAC completely, the EnableLUAproperty of

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System

in the registry needs to be changed to 0. This disables the "administrator in Admin Approval Mode" user type, thus allowing all administrator users to run their processes as administrators by default.

See also: EnableLUA | msdn.microsoft.com

After doing that, your programs/processes will be run in Administrator mode by default (given that your user is an Administrator), i.e. you will not be having (so much) trouble saving files to certain locations, without launching the respective program specifically as Administrator first.

(from Always run programs as administrator in Windows 10 | Super User)

// ah sorry, this is a duplicate of @ben-n 's original answer - only difference is doing it via the Registry instead of gpedit.msc

6

If a search lead you here, and you want to always run a specific application as administrator even when launching its associated file type, you have to use the registry. Those compatibility tabs on properties are no longer available in windows 10.

If you don't already know why you shouldn't do this, you should stop now.

For Why you should or shouldn't do this you need to look elsewhere.

Below you will learn how.

Create a new registry key in one of these existing keys: (create the "Layers" key also - if necessary)

(for current account only)
HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\AppCompatFlags\Layers
(for all users)
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\AppCompatFlags\Layers

The name of the new key should be the path (without quotes) to the application you want to always launch elevated.

For example:

"C:\Program Files (x86)\Microsoft Visual Studio\2017\Professional\Common7\IDE\devenv.exe"
(but WITHOUT quotes!)

The value of this key should be

~ RUNASADMIN

it should look like this: registry key to always run elevated in windows 10

After you set the key value and name correctly, you are done! Launch the app using an associated file and you'll see the elevation prompt.

  • Can you add reference for For Why you should or shouldn't do this you need to look elsewhere. what this refers here, your solution or setting UAC ? – Prateek Sep 20 '18 at 18:11
  • 1
    Prateek, UAC is a security measure. You can probably guess that bypassing it makes your PC less secure. If you don't already know that, your are in no position to determine if bypassing it is really the right thing for you to do. So I am asking you not to use the instructions for making dynamite that follow. The goal is to have you recognize that your are out of your depth and turn back safely - not give you further false confidence. – DanO Nov 5 '18 at 18:06
5

Just run Powershell as Administrator, then enter this:

Set-ItemProperty -Path "HKLM:\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System" -Name "EnableLUA" -Value "0"

shutdown -r -t 0
  • 1
    Take note: on Windows 10, if you disable UAC, some built-in apps (Maps, Edge, Calculator) refused to run. – Dio Phung Feb 1 '18 at 22:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.