0

I recently added a Ubiquiti AirRouter to my network. (Let's call this AR) It is wired to my TP-Link router (Let's call this TP) which is wired to my modem.

TP is my DHCP server. Wired clients to AR are reflected in the TP clients list, and can access the internet. They do receive an ip within the TP DHCP range (192.168.4.1 to 192.168.4.254). Wireless clients, according to their ipconfig and the AR clients list, attempt to use a 169.x address.

These are the AR settings:

enter image description here enter image description here

These are the TP settings:

enter image description here enter image description here

ipconfig for a wired connection to either device looks like this:

enter image description here

ipconfig for a wireless connection to AR looks like this:

enter image description here

I can post more of the settings or anything else needed to figure this out. Thank you!

  • Why are you putting AR on a different IP subnet than TP? Why are you having AR act as a DHCP relay to a (possibly non-existent?) DHCP server? What other interfaces of the AR are attached to BRIDGE0? – Spiff Nov 18 '15 at 19:47
  • Does every device in your network use a 255.255.0.0 netmask? Does the DHCP server assign IPs with this subnet mask? Are you trying to just use the AR as a switch and access point? Or are you trying to use it to do actual routing? – David Schwartz Nov 18 '15 at 20:01
  • @Spiff The mask should always be 255.255.0.0. TP (at 192.168.1.1) is my DHCP server. Nothing else is attached to BRIDGE0 I don't think... – GiantDuck Nov 18 '15 at 23:37
  • @DavidSchwartz Yes everything is 255.255.0.0. I believe it does (Please see the ipconfig results). I only want AR to be a switch and AP. Thank you! – GiantDuck Nov 18 '15 at 23:38
  • @GiantDuck If you only want it to be a switch and an AP, why does it have two IP addresses assigned to it? – David Schwartz Nov 18 '15 at 23:45
2

Judging from the Ubiquiti AirRouter User Guide, you almost certainly have AR in "Router" or "SOHO Router" mode, when you need it to be in "Bridge" mode.

Note that disabling NAT does not enable Bridge mode. Disabling NAT just makes it a traditional IP router (routing between two IP subnets without translating/masquerading IP addresses).

Switch it to Bridge mode and it should work the way you want.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.