0

I want to enable the UPnP to make programs like Gameranger host some games without problems .

I am connecting using a Gargoyle router , and that router is connecting to the internet using ZET ZXV10 W300 modem .

I have the UPnP enabled at the Gargoyle router only now , should I enable it at the ZET modem also ? knowing that this modem has the firewall and the SPI firewall enabled with this warning (If You enabled SPI, all traffics initiated from WAN would be blocked, including DMZ, Virtual Server, and ACL WAN side) , I have two options for the UPnP

UPnP : (Activated/Deactivated)
Auto-configured : (Activated/Deactivated) (by UPnP-enabled Application)


EDIT 1:


@Spiff According to your Answer and with some search , I have made these changes , want to check if they are correct :

For the Modem :

*Firewall : Enabled

*SPI Firewall : Disabled

*DMZ for a Single IP enabled (192.168.1.2) which is my Router IP

*UPnP : Deactivated

For the Gargoyle Router :

*Enable UPnP & NAT-PMP service

Should it work correctly now ? i think the DMZ at the modem for the Router ip will overpass the modem NAT and at the same time the security is not a problem as the Gargoyle router firewall is on ?


Edit 2:


@Spiff @David Schwartz thanks for replaying , But the problem is that when I disable the NAT option at the ZTE modem/router all my internet connections are down , I think i need to do some port forward to the Gargoyle router but don't know how .

And the only program i could find to check the first solution is this http://www.softpedia.com/get/Security/Security-Related/ScanNow-UPnP.shtml and showing the following :

TEST 1 - Operating System Support - PASSED

TEST 2 - SSDP Service Running Check - PASSED

TEST 3 - SSDP Service Automatic Check - FAILED

TEST 4 - UPnPHost Service Running Check - FAILED

TEST 5 - UPnPHost Service Automatic Check - FAILED

TEST 6 - UPnP Framework Firewall Exception Check - PASSED

TEST 7 - Adapter #0 - 192.168.0.30 - FAILED

TEST 8 - Get External IP Address - FAILED

But i suspect the problem is that the program server is down and not only the UPNP .


Edit 3:


I have managed to disable the double NAT by choosing Bridge Mode instead-of PPPoE/PPPoA at the Modem and choose PPPoE (Wired) at gargoyle , then entered my username and password .

Also i have found very useful program to check the double-Nat/Port-forwarding/Server issue , its the server program of (Air Video HD) , any one can test connection by it .

  • You will probably not be able to get double NAT to work with UPnP. Unless you have a really, really, really good reason, ditch the double NAT. – David Schwartz Nov 19 '15 at 22:52
0

Double NAT is always a bad idea unless you really, really know what you are doing. So disable NAT on one of those two devices. I'm pretty sure UPnP does not have a mechanism for cascading through multiple NATs. So if you're double-NATting, only the closest (downstream) NAT will get the UPnP request to open the game-host ports, and the far (upstream) one will remain clueless and not know to open them.

By the way, NAT is a step above routing, so any box that does NAT is a router and more. So don't fool yourself into thinking your modem is just a modem, even if that's what it says on the box. It's really a home gateway router with an integrated modem.

  • kindly check the edit – thelordabdo Nov 19 '15 at 22:01
  • @thelordabdo You're still doing double NAT, which is still a bad idea, but might not be a deal-breaker. I don't know what the non-SPI firewall on the ZTE box does, nor how you have it configured, so I can't tell you if that's going to get in your way or not. – Spiff Nov 19 '15 at 22:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.